Artigo: 319844 - Última revisão: quarta-feira, 5 de Dezembro de 2007 - Revisão: 8.5

Recebe uma mensagem de erro "O componente ActiveX não consegue criar o objecto" quando utiliza o Access

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Para obter uma versão deste artigo referente ao Microsoft Access 2000, consulte 319841  (http://support.microsoft.com/kb/319841/ ) .

Principiante: requer conhecimentos sobre a interface de utilizador em computadores individuais.

Para obter uma versão deste artigo referente ao Microsoft Access 97, consulte 296205  (http://support.microsoft.com/kb/296205/ ) .

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando utiliza o Microsoft Access, recebe a seguinte mensagem de erro:
O componente ActiveX não consegue criar o objecto
Este artigo descreve algumas causas mais comuns para esta mensagem de erro e fornece métodos que podem ser utilizados para resolver o problema.

Causa

Este comportamento pode ocorrer se se verificar uma das seguintes condições:
  • O Data Access Objects (DAO) não está correctamente registado.

    - ou -
  • Uma ou mais referências estão em falta.

    - ou -
  • Existe uma referência da base de dados de utilitários que não é válida.

    - ou -
  • Não dispõe das permissões necessárias para as bibliotecas necessárias.

    - ou -
  • Existe um ficheiro do assistente danificado.

Resolução

Causa 1: O DAO não está devidamente registado

Resolução

  1. No computador que hospeda o Microsoft Windows Terminal Server ou no computador em que o Microsoft Access está instalado, clique em Iniciar e clique em Executar.
  2. Escreva regsvr32 seguido do caminho para o ficheiro DAO. Coloque este caminho entre aspas. Por exemplo, para registar a biblioteca DAO 3.6, utilize o seguinte comando:
    regsvr32 "C:\Programas\Ficheiros Comuns\Microsoft Shared\DAO\DAO360.DLL"

Causa 2: Uma ou mais referências estão em falta

Resolução

  1. Abra a base de dados relativamente à qual recebe a mensagem de erro.
  2. Prima ALT+F11 para abrir o editor do Microsoft Visual Basic.
  3. No editor do Visual Basic, clique em References no menu Tools.
  4. Examine a lista de bibliotecas. Se existirem itens marcados como "em falta", localize o ficheiro de biblioteca e associe novamente a referência. Ou, clique para desmarcar a caixa de verificação junto ao nome da biblioteca.

Causa 3: Existe uma referência a uma base de dados de utilitários que não é válida

Resolução

  1. Abra a base de dados relativamente à qual recebe a mensagem de erro.
  2. Prima ALT+F11 para abrir o editor do Visual Basic.
  3. No editor do Visual Basic, clique em References no menu Tools.
  4. Clique para desmarcar a caixa de verificação junto de qualquer referência à base de dados de utilitários ou Utility.mda.

Causa 4: Não dispõe das permissões necessárias para as bibliotecas necessárias

Resolução

  • Certifique-se de que os utilizadores têm permissões de leitura para todos os ficheiros nas pastas seguintes.
    Reduzir esta tabelaExpandir esta tabela
    Sistema operativoLocalização
    Windows XP\Windows\System32
    Windows NT e Windows 2000\Winnt\System32
    Windows 95, Windows 98 e Windows Millennium Edition\Windows\System
  • Se não for possível conceder permissões de leitura, poderá usar um utilitário como o FileMon para determinar o ficheiro ou ficheiros para os quais os utilizadores não têm as permissões de utilização necessárias. Para obter o FileMon, visite o seguinte Web site da Sysinternals:
    Sysinternals (http://www.microsoft.com/technet/sysinternals/default.mspx)

Causa 5: Existe um ficheiro de assistente danificado

Resolução

  1. Utilize o Explorador do Windows para localizar os seguintes ficheiros do assistente: Acwzmain.mde, Acwztool.mde e Acwzlib.mde.
  2. Altere a extensão do nome de cada ficheiro para "antigo". Por exemplo, altere Acwzmain.mde para Acwzmain.antigo.
  3. Reinstale o Access para restaurar os ficheiros.

Mais Informação

Os produtos de outros fabricantes referidos neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não concede nenhuma garantia, implícita ou de outra natureza, relativamente ao desempenho ou à fiabilidade destes produtos.

A informação contida neste artigo aplica-se a:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbpubtypekc kberrmsg kbprb KB319844