ID do artigo: 319844 - Última revisão: quinta-feira, 22 de março de 2007 - Revisão: 8.3

Uma mensagem de erro "Componente do ActiveX não pode criar objeto" é exibida ao usar o Access

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Para obter uma versão deste artigo para o Microsoft Access 2000, consulte 319841  (http://support.microsoft.com/kb/319841/ ) .

Iniciante: Requer conhecimentos de interface do usuário em computadores de usuário único.

Para obter uma versão deste artigo para o Microsoft Access 97, consulte 296205  (http://support.microsoft.com/kb/296205/ ) .

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao usar o Microsoft Access, a seguinte mensagem de erro é exibida:
Componente do ActiveX não pode criar objeto
Esse artigo descreve algumas das causas mais comuns da mensagem de erro, além de oferecer métodos que podem ser usados para resolver o problema.

Causa

Esse comportamento pode ocorrer se uma das seguintes condições for verdadeira:
  • O DAO (Data Access Objects) não está registrado corretamente.

    -ou-
  • Uma ou mais referências não foram encontradas.

    -ou-
  • Há uma referência de banco de dados do utilitário inválida.

    -ou-
  • Você não tem as permissões exigidas para as bibliotecas necessárias.

    -ou-
  • Há um arquivo do assistente danificado.

Resolução

Causa 1: o DAO não está registrado corretamente

Resolução

  1. No computador que hospeda o Microsoft Windows Terminal Server ou em que o Microsoft Access está instalado, clique em Iniciar e em Executar.
  2. Digite regsvr32 seguido pelo caminho para o arquivo DAO. Coloque o caminho entre aspas. Por exemplo, para registrar a biblioteca DAO 3.6, use o seguinte comando:
    regsvr32 "C:\Arquivos de programas\Arquivos comuns\Microsoft Shared\DAO\DAO360.DLL"

Causa 2: Uma ou mais referências não foram encontradas

Resolução

  1. Abra o banco de dados no qual a mensagem de erro é exibida.
  2. Pressione ALT+F11 para abrir o Editor do Microsoft Visual Basic.
  3. No Editor do Microsoft Visual Basic, clique em Referências no menu Ferramentas.
  4. Examine a lista de bibliotecas. Se houver algum item marcado como "não encontrado", localize o arquivo da biblioteca e associe novamente a referência. Ou desmarque a caixa de seleção próxima ao arquivo da biblioteca.

Causa 3: Há uma referência de banco de dados do utilitário inválida

Resolução

  1. Abra o banco de dados no qual a mensagem de erro é exibida.
  2. Pressione ALT+F11 para abrir o Editor do Microsoft Visual Basic.
  3. No Editor do Microsoft Visual Basic, clique em Referências no menu Ferramentas.
  4. Desmarque a caixa de seleção próxima às referências para o Utility Database ou o Utility.mda.

Causa 4: Você não tem as permissões exigidas para as bibliotecas necessárias

Resolução

  • Certifique-se de que os usuários têm permissões "de leitura" para todos os arquivos nas seguintes pastas.
    Recolher esta tabelaExpandir esta tabela
    Sistema operacionalLocal
    Windows XP\Windows\System32
    Windows NT e Windows 2000\Winnt\System32
    Windows 95, Windows 98 e Windows Millennium Edition (Me)\Windows\System
  • Se não puder conceder permissões de leitura, é possível usar um utilitário como o FileMon para definir em qual(is) arquivo(s) os usuários não terão as permissões necessárias para usar. Para obter o FileMon, consulte o seguinte site da Sysinternals:
    Sysinternals (http://www.microsoft.com/brasil/technet/sysinternals/default.mspx)

Causa 5: Há um arquivo do assistente danificado

Resolução

  1. Use o Windows Explorer para localizar os seguintes arquivos do assistente: Acwzmain.mde, Acwztool.mde e Acwzlib.mde.
  2. Altere a extensão do nome de cada arquivo para "old". Por exemplo, altere de Acwzmain.mde para Acwzmain.old.
  3. Reinstale o Access para restaurar os arquivos.

Mais Informações

Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

A informação contida neste artigo aplica-se a:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
Palavras-chave: 
kbmsccsearch kbpubtypekc kberrmsg kbprb KB319844