Un usuario puede experimentar un proceso de cierre de sesión lento debido a un identificador de abrir el registro en la sección de clases de

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Síntomas

El primer usuario que inicia sesión en una estación de trabajo después de reiniciar el equipo puede experimentar un cierre de sesión lento horas (más de 60 segundos). Cuando se produce este problema, el archivo Userenv.log contiene entradas similares para:
USERENV(76c.818) 13:06:00:133 MyRegUnLoadKey: error de descarga de subárbol para S-1-5-21-789336058-1580818891-1801674531-1106_Classes debido al clave del registro abierto. Windows intentará descargar el subárbol del registro una vez un segundo durante los próximos 60 segundos (max).
-o bien -
Tipo de evento: error
Origen de evento: Userenv
Categoría del suceso: ninguna
Evento ID:1000
Fecha: 4/26/2002
Time:10:54:46 A.M.
Usuario: NT AUTHORITY\SYSTEM
NombreDeEquipo: equipo
Descripción:
Windows no puede descargar el archivo de registro de la clase. Si posee un perfil móvil, su configuración no está duplicada. Póngase en contacto con el administrador.

Detalle acceso denegado. Número de compilación ((2195)).
Herramientas de diagnóstico (como Oh.exe) muestran que Lsass.exe tiene un identificador abierto a esta clave.

Causa

La biblioteca de dynamic-link activeds.dll (DLL) crea COM instancias durante la inicialización. Esto hace indirectamente que un controlador HKEY_CURRENT_USER\Software\Classes que se va a almacenar en caché. Si activeds.dll es inicializada por un subproceso en un proceso de servicio mientras el subproceso suplanta a un usuario, el identificador persiste después de que el usuario cierre sesión.

Solución

Para resolver este problema, obtenga el Service Pack más reciente de Windows 2000. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910Cómo obtener el Service Pack más reciente para Windows 2000
La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   15-Apr-2002  15:20  5.0.2195.4898  182,544  Activeds.dll
				
Nota Aunque el paquete de revisión de esta revisión aparece como posteriores, la revisión se incluye en Windows 2000 Service Pack 3 (SP3).

Solución

Para evitar este problema, activar la directiva IPSec agente.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo. Este problema se corrigió por primera vez en el Service Pack 3 de Windows 2000.

Más información

HKEY_CURRENT_USER\Software\Classes es un alias de HKEY_USERS\_user_sid_Classes , que es clases privadas subárbol un usuario (el archivo \Local Settings\Application Data\Microsoft\Windows\UsrClass.dat Userprofile). Cuando tiene acceso a HKEY_CLASSES_ROOT (que es un alias para HKEY_LOCAL_MACHINE\Software\Classes ), Advapi32 primero busca HKEY_CURRENT_USER\Software\Classes un reemplazo. Un identificador abierto en la clave del usuario clases privadas se almacena en caché por motivos de rendimiento.

Si está ejecutando el agente de directivas IPSec (se ejecuta en Lsass.exe), carga e inicializa Activeds en el sistema de contexto durante el proceso de inicio. Reemplazos de claves de clase de usuario no son posibles en este caso. Sin embargo, si no se está ejecutando el agente, puede ser la primera vez que HKEY_CLASSES_ROOT es de lectura en el contexto del usuario (es decir, un subproceso de suplantación durante de inicio de sesión del usuario). Esto hace que un identificador de la clave del usuario clases que se va a almacenar en caché.

Para obtener información adicional acerca de cómo obtener un hotfix para Windows 2000 Datacenter Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
265173El programa Datacenter y el producto servidor de Windows 2000 Datacenter
Para obtener información adicional acerca de cómo instalar varias revisiones con sólo un reinicio, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
296861Utilizar QChain.exe para instalar varias revisiones con sólo un reinicio
Para obtener información adicional acerca de cómo instalar Windows 2000 y el hotfix de Windows 2000 al mismo tiempo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
249149Instalar Microsoft Windows 2000 y revisiones para Windows 2000

Propiedades

Id. de artículo: 319909 - Última revisión: jueves, 01 de febrero de 2007 - Versión: 2.5
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
Palabras clave: 
kbmt kbhotfixserver kbqfe kbbug kbdirservices kbfix kbwin2000presp3fix kbwin2000sp3fix KB319909 KbMtes
Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 319909

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