Artigo: 319949 - Última revisão: quinta-feira, 13 de Abril de 2006 - Revisão: 4.0

Mensagem de erro: "Não é possível localizar um ficheiro necessário à execução do 'Assistente de pesquisa'."

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Depois de ligar a um Web site, pode receber a seguinte mensagem de erro:
Não é possível localizar um ficheiro necessário à execução do 'Assistente de pesquisa'. Poderá ter de executar o programa de configuração.
Depois de receber esta mensagem de erro, não consegue utilizar o Assistente de pesquisa para procurar ficheiros ou pastas ou para pesquisar na Internet. As opções para procurar ficheiros ou pastas ou para pesquisar na Internet estão indisponíveis.

Causa

Este comportamento pode ocorrer se um ficheiro necessário para executar o Assistente de pesquisa estiver em falta ou danificado. Note que este problema afecta apenas a versão inglesa do Windows XP.

NOTA: os ficheiros do Assistente de pesquisa podem ficar danificados se tiver o Assistente de pesquisa aberto quando liga a determinados fornecedores de serviços Internet.

Resolução

Para resolver este problema, utilize um dos métodos que se seguem.

Método 1: Instalar o Windows XP SP1

Para resolver este problema, obtenha o Service Pack mais recente do Windows XP. Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
322389  (http://support.microsoft.com/kb/322389/PT/ ) Como obter o Service Pack mais recente do Windows XP

Método 2: Transferir e instalar a correcção

O ficheiro que se segue está disponível para transferência a partir do centro de transferências da Microsoft:
Reduzir esta imagemExpandir esta imagem
Transferir
Transferir o pacote Q319949 agora (http://www.microsoft.com/Downloads/Release.asp?ReleaseID=39318)
Data de edição: 1 de Junho de 2002

Para obter informações adicionais sobre como transferir ficheiros de suporte da Microsoft, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
119591  (http://support.microsoft.com/kb/119591/PT/ ) Como obter ficheiros de suporte da Microsoft a partir de serviços online
A Microsoft procedeu à detecção de vírus neste ficheiro. A Microsoft utilizou o software de detecção de vírus mais actual, disponível na data de publicação do ficheiro. O ficheiro está armazenado em servidores com segurança melhorada, que ajudam a impedir quaisquer alterações não autorizadas ao ficheiro. A versão inglesa desta correcção tem os atributos de ficheiro listados na seguinte tabela (ou posteriores). As datas e horas destes ficheiros são indicadas no formato da hora universal coordenada (UTC, Coordinated Universal Time). Ao visualizar as informações dos ficheiros, estas serão convertidas na hora local. Para determinar a diferença entre a hora UTC e a hora local, utilize o separador Fuso horário da ferramenta Data e hora do Painel de controlo.
   Data         Hora   Versão      Tamanho  Ficheiro
   ---------------------------------------------------
   25-Mar-2002  22:54  1.0.0.2714  798,782  Srchui.dll       
				

Método 3: Reinstalar os ficheiros do 'Assistente de pesquisa'

Para resolver este problema sem obter a correcção ou instalar o Windows XP SP1, siga estes passos:
  1. Inicie sessão no computador utilizando uma conta com permissões de administrador.
  2. Clique em Iniciar, clique em Executar, escreva %systemroot%\inf e clique em OK.
  3. Localize o ficheiro Srchasst.inf.
  4. Clique com o botão direito do rato no ficheiro Srchasst.inf e clique em Instalar. Este procedimento reinstala os ficheiros utilizados pelo Assistente de pesquisa.
NOTA: o CD-ROM do Windows XP pode ser necessário para concluir a instalação do Assistente de pesquisa. Este problema pode voltar a ocorrer se tiver o Assistente de pesquisa aberto quando ligar ao seu fornecedor de serviços Internet.

Este problema pode continuar a ocorrer depois de desligar da Internet porque os ficheiros danificados foram colocados em cache. Pode visualizar os ficheiros adequados (abra-os com o Bloco de notas e não no Microsoft Internet Explorer) para determinar a origem dos danos. Os ficheiros envolvidos são:
  • Balloon.xsl
  • Bar.xsl
  • Lclsrch.xml

Como contornar

Para impedir a ocorrência este problema, certifique-se de que o Assistente de pesquisa está fechado antes de ligar ao fornecedor de serviços Internet.

Ponto Da Situação

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados no início deste artigo. Este problema foi corrigido pela primeira vez no Windows XP Service Pack 1.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Palavras-chave: 
kbqfe kbhotfixserver kberrmsg kbbug kbfix kbqfe KB319949