You Cannot Open a File That You Moved to a DFS Share

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Article ID: 319967 - View products that this article applies to.
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SYMPTOMS

You may not be able to open a file on a Distributed File System (DFS) share. This problem may occur in the following scenario:
  • You have a DFS share and a regular share on the same server.
  • You have mapped drive letters to both shares on a client computer.
  • You move a file from the regular share to the DFS share.
  • You try to open the file on the DFS share.
If you look in the Shared Folders snap-in, you see that there is still an open handle with write access to the file. The handle is not released when you log off the client.

CAUSE

This problem occurs because a handle that is supposed to be cleaned up asynchronously is not cleaned up.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix should have the following file attributes or later:
   Date         Time   Version        Size     File name
   ------------------------------------------------------
   05-Apr-2002  01:47  5.0.2195.5535  370,480  Mrxsmb.sys
   05-Apr-2002  01:47  5.0.2195.5535  131,984  Rdbss.sys
				

Note This fix must be installed on the client computers to avoid the problem.

WORKAROUND

To work around this problem, use either of the following methods:
  • Disconnect the client in the Shared Folders snap-in on the server. (This is the preferred method.)
  • Restart either the client or the server to close the handle on the server.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:
296861 How to Install Multiple Windows Updates or Hotfixes with Only One Reboot

Properties

Article ID: 319967 - Last Review: October 24, 2013 - Revision: 3.6
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kboswin2000fix kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix KB319967

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