Неожиданно меняется установленная домашняя страница. Не удается поменять домашнюю страницу

Переводы статьи Переводы статьи
Код статьи: 320159 - Vizualiza?i produsele pentru care se aplic? acest articol.
Внимание! Решение проблемы связано с внесением изменений в системный реестр. Перед внесением изменений рекомендуется создать резервную копию системного реестра и изучить процедуру его восстановления. Дополнительные сведения об архивации, восстановлении и изменении реестра см. в следующей статье базы знаний Майкрософт:
256986 Описание реестра Microsoft Windows
Развернуть все | Свернуть все

Проблема

В процессе работы с обозревателем Microsoft Internet Explorer или Windows Internet Explorer могут возникнуть следующие проблемы.
  • Вместо выбранной пользователем домашней страницы устанавливается другая.
  • Не удается изменить установленную домашнюю страницу.

    Так, например, не вводится текст в поле Адрес диалогового окна Свойства обозревателя (меню Сервис) и недоступны перечисленные ниже кнопки:
    • С текущей
    • С исходной
    • С пустой
  • Пользователь настраивает в диалоговом окне Свойства обозревателя нужную домашнюю страницу, но после перезагрузки компьютера она снова меняется.

Причина

Такая ситуация может возникнуть в следующих случаях.
  • Компьютер заражен вирусом, который меняет домашнюю страницу в Internet Explorer.

    Это характерно, например, для вирусов IRC.Becky.A и Trojan.JS.Clid.gen.
  • Компьютер подвергся вторжению со стороны злоумышленника.

    Так, например, домашнюю страницу в Internet Explorer меняет программа JS.Exception.Exploit.
  • Было установлено программное обеспечение сторонних производителей, которое изменило домашнюю страницу веб-обозревателя Internet Explorer.

    Так, например, панель инструментов Xupiter компании Xupiter.com, программа SecondPower Multimedia Speedbar компании SecondPower.com и надстройка GoHip! компании GoHip.com меняют домашнюю страницу в Internet Explorer. Запрос на установку одной из этих программ может появиться в процессе установки другого программного обеспечения.
  • Домашняя страница изменена администратором с помощью пакета Microsoft Internet Explorer Administration Kit (IEAK), при установке групповой или системной политики либо вручную в реестре (например, с помощью сценария входа в систему).

Решение

Предупреждение. Неправильное изменение параметров системного реестра с помощью редактора реестра или любым иным путем может привести к серьезным неполадкам, требующим переустановки операционной системы. Корпорация Майкрософт не гарантирует устранения этих неполадок. При изменении реестра полагайтесь на свой опыт и знания.

Для решения проблемы выполните следующие действия:

Примечание. Для выполнения описанных ниже действий на компьютере под управлением Windows NT 4.0, Windows 2000 или Windows XP необходимо войти в систему с правами администратора. Если домашняя страница была изменена системным администратором, обратитесь к нему перед выполнением представленных ниже действий.
  1. Запустите антивирусную программу с последним набором сигнатур вирусов и выполните инструкции по удалению обнаруженных вирусов. Корпорация Microsoft не занимается разработкой антивирусного программного обеспечения. Обратитесь к разработчику соответствующего программного обеспечения за сведениями об удалении вирусов и защите компьютера от возможного заражения в будущем. Зараженный компьютер может подвергнуться новым атакам. Дополнительные сведения о производителях антивирусного программного обеспечения, а также о наличии вирусов в системе, их удалении и предотвращении возможного заражения в будущем см. следующую статью базы знаний Майкрософт:
    129972 Компьютерные вирусы — описание, меры безопасности и удаление
    Дополнительные сведения о восстановлении зараженной системы см. на веб-узле координационного центра CERT по адресу:
    http://www.cert.org/tech_tips/win-UNIX-system_compromise.html
    Контактные данные независимых производителей предоставлены в данной статье с целью помочь пользователям в получении необходимой технической поддержки. Данная информация может быть изменена без предварительного уведомления. Корпорация Майкрософт не дает никаких явных или подразумеваемых гарантий относительно верности приведенных контактных данных независимых производителей.
  2. Перейдите на веб-узел, который необходимо установить в качестве домашней страницы в Internet Explorer.
  3. Выберите в меню Сервис пункт Свойства обозревателя и нажмите кнопку С текущей. Перезагрузите компьютер и снова запустите Internet Explorer. Если проблема не возникает повторно, пропустите последующие действия:
  4. Выполните «чистую» загрузку компьютера. Дополнительные сведения о «чистой» загрузке операционной системы см. в следующих статьях базы знаний Майкрософт:
    310353 Выполнение «чистой» загрузки в Windows XP
    281770 Использование «чистой» загрузки для устранения неполадок в Windows 2000
    267288 Выполнение «чистой» загрузки в Windows Millennium Edition
    192926 Использование «чистой» загрузки для устранения неполадок в Windows 98
    243039 Выполнение «чистой» загрузки в Windows 95 (Эта ссылка может указывать на содержимое полностью или частично на английском языке)
  5. Повторите действия 2 и 3.

    Отсутствие проблемы свидетельствует о том, что домашняя страница в Internet Explorer была изменена в результате установки программного обеспечения стороннего производителя или запуска неизвестного вируса. Проблему вызывает один из элементов группы автозапуска, которые не загружаются в процессе «чистой» загрузки. Это может быть любой элемент, который запускает программу Regedit.exe, или файл с расширением REG, HTA, VBS или JS. Отключив запуск таких элементов группы автозапуска и подозрительных программ сторонних производителей, перейдите к выполнению следующего действия.
  6. Нажмите кнопку Пуск и выберите команду Выполнить.
  7. В поле Открыть введите команду regedit и нажмите кнопку OK.
  8. В окне редактора реестра найдите следующий раздел (если он существует):
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel
  9. Если в нем есть параметры ResetWebSettings и HomePage, щелкните каждый из них правой кнопкой мыши и выберите команду Удалить.

    Примечание. Кроме того, проверьте адреса веб-страниц, присвоенные параметрам Default_Page_URL и Start Page, в следующих разделах реестра:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main


    HKEY_ LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main


    HKEY_USERS\Default\Software\Microsoft\Internet Explorer\Main
  10. В меню Правка выберите команду Удалить и нажмите кнопку Да для подтверждения.
  11. Чтобы закрыть редактор реестра, в меню Файл или Реестр выберите команду Выход.
  12. Повторите действия 2 и 3. Если проблема не возникает повторно, разрешите загрузку элементов меню автозапуска, отключенных на шаге 4, кроме тех, которые потенциально могут вызвать проблемы (например, запускающие программу Regedit.exe или файл с расширением REG, HTA, VBS или JS). Если после этого проблема возникает повторно, значит, на последнем этапе был разрешен запуск вызвавшего ее элемента. Повторите действия 4-11.

    Внимание! После устранения причины возникновения неполадок, чтобы избежать их повторения в будущем, следуйте приведенным ниже инструкциям.
    1. Не запускайте, не сохраняйте и не загружайте программы из неизвестного источника.
    2. Всегда используйте антивирусное программное обеспечение.
    3. Обновите Outlook 2000 и Outlook 98 до уровня Outlook 2000 с набором исправлений 2 (SR-2) или более поздним либо установите расширенное обновление системы почтовой безопасности для Outlook 2000 с набором исправлений 1 (SR-1). Чтобы установить это обновление, посетите веб-узел Майкрософт по следующему адресу:
      http://www.microsoft.com/downloads/details.aspx?displaylang=ru&FamilyID=96DF48A9-7638-429E-816E-35F16F6528CA(на английском языке)
    4. Обновите Outlook Express до версии 6 или более поздней. Убедитесь, что для сообщений электронной почты отключены активные сценарии, и заблокируйте вложения. Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
      291387 Использование функции блокирования вирусов в Outlook Express 6
    5. В случае непосредственного подключения к Интернету используйте брандмауэр. Дополнительные сведения о брандмауэрах см. на веб-узле Майкрософт по адресу:
      http://www.microsoft.com/rus/athome/security/viruses/fwbenefits.mspx(на английском языке)
    6. Если система подверглась атаке или в нее попал вирус, очистите содержимое папок Temporary Internet Files и Cookies, а также журнала обозревателя Internet Explorer. Дополнительные сведения см. в следующей статье базы знаний Майкрософт:
      260897 Очистка папки «Temporary Internet Files»
      278835 Удаление файлов «cookie»
      157729 Удаление записей в журнале Internet Explorer
      Кроме того, выполните поиск файлов на жестком диске, которые используются вирусом или программным кодом злоумышленника, и удалите их. Например, файлы с именем типа Rad*.ТМР (где * — произвольный набор букв и цифр), файлы, которые содержат термины regedit или REG (например, файл, в котором есть строка "C:\Windows\regedit.exe/s C\Windows\System\radB9819.tmp"), и файл Windows.vbs, как правило, имеют отношение к определенным вирусам.
    7. Регулярно устанавливайте важные обновления безопасности. Для этого обращайтесь на веб-узел корпорации Майкрософт по адресу:
      http://update.microsoft.com/windowsupdate/v6/default.aspx?ln=ru-ru
      Корпорация Microsoft больше не обеспечивает поддержку некоторых устаревших версий Windows и Internet Explorer. Поэтому обновления безопасности для этих продуктов больше не разрабатываются. Для получения сведений о поддержке продуктов обратитесь на веб-узел Майкрософт по адресу:
      http://support.microsoft.com/?pr=lifecycle(на английском языке)
      Если версия операционной системы или Internet Explorer не поддерживается, обновите продукты, чтобы иметь возможность регулярно получать последние обновления безопасности.

Дополнительная информация

Дополнительные сведения о подобной проблеме, возникающей при использовании функции поиска в Internet Explorer, см. в следующей статье базы знаний Майкрософт:
323869 При нажатии кнопки «Поиск» в веб-обозревателе отображается веб-страница с нежелательным содержимым
В данной статье упомянуты программные продукты независимых производителей. Корпорация Майкрософт не дает никаких гарантий и обязательств по корректной работе или надежности этих продуктов.

Свойства

Код статьи: 320159 - Последний отзыв: 22 декабря 2006 г. - Revision: 8.1
Информация в данной статье относится к следующим продуктам.
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
  • Microsoft Internet Explorer 6.0 на следующих платформах
    • Microsoft Windows XP Professional
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows NT 4.0
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
  • Microsoft Internet Explorer 5.5 на следующих платформах
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows NT 4.0
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.01 на следующих платформах
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows NT 4.0
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
  • Microsoft Internet Explorer 5.0 на следующих платформах
    • Microsoft Windows NT 4.0
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 95
Ключевые слова: 
kbprb KB320159

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com