El redirector de Windows puede cancelar una sesión durante una operación de bloqueo largo

Seleccione idioma Seleccione idioma
Id. de artículo: 320310 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

El redirector de Windows incorrectamente puede cancelar una sesión durante operaciones de bloqueo de larga duración. Este problema puede producirse en el siguiente escenario:
  • El cliente bloquea un archivo en el servidor de archivos.
  • Cliente B también intenta bloquear el mismo archivo llamando a la función LockFileEx(hFile,LOCKFILE_EXCLUSIVE_LOCK,...) .
  • El servidor de archivos nunca devuelve la llamada SMB a cliente B porque el cliente aún tiene bloqueado el archivo.
  • El redirector de B de cliente se agota el tiempo de espera y desconecta la sesión. (El período de tiempo de espera se controla mediante la configuración del registro de Sesstimeout ).

Causa

Si no se establece el indicador LOCKFILE_FAIL_IMMEDIATELY en la función LockFileEx , el servidor devuelve sólo cuando se ha bloqueado correctamente el archivo. Esto es así por diseño. Si esto supera el tiempo de espera de cliente, el redirector del cliente cancela la conexión.

Solución

Windows 2000

Para resolver este problema, obtenga el Service Pack más reciente de Windows 2000. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910Cómo obtener el Service Pack más reciente para Windows 2000

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Información de archivo

La versión en inglés de esta revisión debe tener los atributos de archivo siguientes o posteriores:
   Date         Time      Version        Size     File name
   ---------------------------------------------------------
   11-Mar-2002  13:14:40  5.0.2195.5059  370,480  Mrxsmb.sys
   07-Mar-2002  13:16:30  5.0.2195.5042  131,920  Rdbss.sys 
				

La corrección es tratar el comando de bloqueo y X de SMB como un SMB long-standing. Esto hace que procede el comando deltemporizador de Sesstimeout . El redirector esperará mientras debe.

Windows XP

Para resolver este problema, obtenga el Service Pack más reciente para Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el Windows XP Service Pack más reciente

Solución

Para evitar este problema, utilice LockFileEx(,,LOCKFILE_FAIL_IMMEDIATELY) en lugar de LOCKFILE_EXCLUSIVE_LOCK. El indicador LOCKFILE_FAIL_IMMEDIATELY devuelve un error adecuado si el archivo ya está en uso. El sistema mediante programación puede intentar bloquear el archivo de nuevo más tarde.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo. Este problema se corrigió primero en el Service Pack 3 (SP3) de Microsoft Windows 2000 y en el Service Pack 1 (SP1) de Microsoft Windows XP.

Más información

Para obtener información adicional acerca de cómo obtener un hotfix para Windows 2000 Datacenter Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
265173El programa Datacenter y el producto servidor de Windows 2000 Datacenter
Para obtener información adicional acerca de cómo instalar varias revisiones con sólo un reinicio, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
296861Utilizar QChain.exe para instalar varias revisiones con sólo un reinicio

Propiedades

Id. de artículo: 320310 - Última revisión: jueves, 22 de febrero de 2007 - Versión: 3.5
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows XP Professional
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kboswin2000fix kbwin2000presp3fix kbwin2000sp3fix kbwinxpsp1fix KB320310 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 320310

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com