Il Redirector Windows pu˛ Annulla una sessione durante un'operazione di blocco Long

Traduzione articoli Traduzione articoli
Identificativo articolo: 320310 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Il redirector di Windows in modo non corretto pu˛ annullare una sessione durante le operazioni di blocco lungo-durata. Questo problema pu˛ verificarsi nelle seguenti condizioni:
  • Il client blocca un file sul file server.
  • Client B tenta inoltre di bloccare lo stesso file chiamando la funzione LockFileEx(hFile,LOCKFILE_EXCLUSIVE_LOCK,...) .
  • Il file server non restituisce mai la chiamata SMB al client B perchÚ il client ha ancora il file Ŕ bloccato.
  • Il redirector di client B timeout e disconnetta la sessione. (Il periodo di timeout Ŕ controllato dall'impostazione del Registro di sistema Sesstimeout ).

Cause

Se non Ŕ impostato il flag LOCKFILE_FAIL_IMMEDIATELY nella funzione LockFileEx , il server restituisce solo quando il file Ŕ stato bloccato correttamente. Questo legato alla progettazione. Se questo richiede pi¨ tempo del timeout di sessione del lato client, il redirector del client Annulla la connessione.

Risoluzione

Windows 2000

Per risolvere questo problema Ŕ necessario ottenere la versione pi¨ recente del service pack per Windows 2000. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
260910Come ottenere Windows 2000 Service Pack pi¨ recente

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

Informazioni sui file

La versione inglese di questa correzione deve essere di avere i seguenti attributi di file o versioni successive:
   Date         Time      Version        Size     File name
   ---------------------------------------------------------
   11-Mar-2002  13:14:40  5.0.2195.5059  370,480  Mrxsmb.sys
   07-Mar-2002  13:16:30  5.0.2195.5042  131,920  Rdbss.sys 
				

La correzione consiste nel gestire il comando SMB lock & X come un tempo SMB. In questo modo il comando esenti daltimer Sesstimeout . Il redirector attenderÓ fino a quando Ŕ necessario.

Windows XP

Per risolvere il problema, procurarsi l'ultimo service pack per Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322389Come ottenere Windows XP Service Pack pi¨ recente

Workaround

Per risolvere questo problema, utilizzare LockFileEx(,,LOCKFILE_FAIL_IMMEDIATELY) invece di LOCKFILE_EXCLUSIVE_LOCK. Il flag LOCKFILE_FAIL_IMMEDIATELY restituisce un errore appropriato se il file Ŕ giÓ in uso. Il programma a livello di codice possibile provare a bloccare il file in un secondo momento.

Status

Microsoft ha confermato che questo problema riguarda i prodotti Microsoft elencati all'inizio di questo articolo. Questo problema Ŕ stato corretto per la prima volta nel Service Pack 3 (SP3) per Windows 2000 e nel Service Pack 1(SP1) per Windows XP.

Informazioni

Per ulteriori informazioni su come ottenere la correzione rapida per Windows 2000 Datacenter Server, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
265173Il programma Datacenter e il prodotto di Windows 2000 Datacenter Server
Per ulteriori informazioni sull'installazione di un gruppo di correzioni rapide con un solo riavvio, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
296861Utilizzare QChain.exe per installare numerose correzioni rapide con un solo riavvio

ProprietÓ

Identificativo articolo: 320310 - Ultima modifica: giovedý 22 febbraio 2007 - Revisione: 3.5
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows XP Professional
Chiavi:á
kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kboswin2000fix kbwin2000presp3fix kbwin2000sp3fix kbwinxpsp1fix KB320310 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 320310
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com