Help and Support

文書番号: 320397 - 最終更新日: 2007年4月23日 - リビジョン: 8.3

コンピュータの起動時に "NTLDR is missing" エラー メッセージが表示される

すべて展開する | すべて折りたたむ

現象

NTFS ファイル システムを使用するブート ボリュームのルート フォルダに多数のファイルをコピーすると、次にコンピュータを再起動したときに、次のエラー メッセージが表示されることがあります。
NTLDR is missing
Press CTRL+ALT+DEL to restart.
ルート フォルダにコピーしたファイルを削除しても、マスタ ファイル テーブル (MFT) の割り当てインデックスが元のサイズに戻りません。

原因

この問題は MFT ルート フォルダが著しく断片化されている場合に発生することがあります。MFT ルート フォルダに多数のファイルが格納されている場合、MFT が著しく断片化され、追加の割り当てインデックスが作成されることがあります。割り当てインデックス内で、ファイルはアルファベット順に割り当てられるため、NTLDR ファイルが 2 番目の割り当てインデックスに押し出されることがあります。この結果、この資料の「現象」に記載されたエラー メッセージが表示されます。

一般にファイルがルート フォルダに書き込まれることはありません。この状況は、プログラムがルート フォルダに一時ファイルを定期的に作成して削除する場合、または誤って多数のファイルをルート フォルダにコピーした場合に発生することがあります。

解決方法

この問題を解決するには、Microsoft Product Support Services に問い合わせて、Bcupdate2 ユーティリティを入手します。Microsoft Product Support Services への問い合わせ方法については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

回避策

この問題を回避するには、コンピュータを起動するための起動ディスクを作成します。
Microsoft Windows XP ベースのコンピュータ用のブート ディスクを作成する方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
305595? (http://support.microsoft.com/kb/305595/ ) [HOW TO] Windows XP を使用して、NTFS パーティションまたは FAT パーティションにブート ディスクを作成する方法

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。
この問題は、Microsoft Windows XP Service Pack 2 で修正済みです。
この問題は、Microsoft Windows 2000 Service Pack 4 で修正済みです。
: Windows XP Service Pack または Windows 2000 Service Pack をインストールしても、既存のボリュームに関する問題は解決されません。ユーティリティを実行して、ブート コードを個別に更新する必要があります。Service Pack のインストール時に行われるのは、新しいボリュームに対して適切なブート コードを記述することのみです。

詳細

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
318728? (http://support.microsoft.com/kb/318728/ ) Windows 2000 での "NTLDR Is Missing" エラー メッセージのトラブルシューティング方法

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
キーワード:?
kbwinxpsp2fix kbwin2ksp4fix kbbug kbfix kbwin2000sp3fix KB320397
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Related Support Centers