文書番号: 320397 - 最終更新日: 2009年10月15日 - リビジョン: 9.2

Windows が最新の状態ではなく、ルート フォルダーに多数のファイルがあると、Windows が起動せず、"NTLDR is missing" というエラー メッセージが表示される場合がある

すべて展開する | すべて折りたたむ

現象

NTFS ファイル システムを使用するブート ボリュームのルート フォルダーに多数のファイルをコピーすると、次にコンピューターを再起動したときに、次のエラー メッセージが表示されることがあります。
NTLDR is missing
Press CTRL+ALT+DEL to restart.
ルート フォルダーにコピーしたファイルを削除しても、マスター ファイル テーブル (MFT) の割り当てインデックスが元のサイズに戻りません。

Windows XP with Service Pack 2 (SP2) または Microsoft Windows 2000 Service Pack 4 (SP4) を使用している場合は、この問題は該当しません。類似の問題については、「詳細」セクションを参照してください。

原因

この問題は MFT ルート フォルダーが著しく断片化されている場合に発生することがあります。MFT ルート フォルダーに多数のファイルが格納されている場合、MFT が著しく断片化され、追加の割り当てインデックスが作成されることがあります。割り当てインデックス内で、ファイルはアルファベット順に割り当てられるため、NTLDR ファイルが 2 番目の割り当てインデックスに押し出されることがあります。この結果、「現象」に記載されたエラー メッセージが表示されます。

一般にファイルがルート フォルダーに書き込まれることはありません。この状況は、プログラムがルート フォルダーに一時ファイルを定期的に作成して削除する場合、または誤って多数のファイルをルート フォルダーにコピーした場合に発生することがあります。

解決方法

この問題を解決するには、次の手順を実行します。
  1. この問題を解決するには、Microsoft Customer Support Services に問い合わせて、Bcupdate2.exe ユーティリティを入手します。Microsoft Customer Support Services への問い合わせ方法については、次のマイクロソフト Web サイトを参照してください。
    http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
  2. コンピューターを起動するための起動ディスクを作成します。 Windows XP ベースのコンピューター用のブート ディスクを作成する方法の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
    305595? (http://support.microsoft.com/kb/305595/ ) [HOW TO] Windows XP を使用して、NTFS パーティションまたは FAT パーティションにブート ディスクを作成する方法
  3. コマンド プロンプトで次のコマンドを実行して、ソフトウェア更新プログラムから Bcupdate2.exe ユーティリティを抽出します。

    Expand drive_letter:\bcupdate2.ex_ drive_letter:\bcupdate2.exe
  4. コマンド プロンプトで次のコマンドを実行して、NTFS ブート セクターのブート コードを更新します。

    Bcupdate2.exe C: /F

    他のコマンド ライン パラメーターもサポートされています。
    /q - Quiet モード (このパラメーターを使用する場合は、/y も指定してください)。
    /y - 確認を求めません。
    /f - 使用中のボリュームを強制的に更新します。
    /t - 古いブート コードのテストのみを実行します。
  5. ボリュームを更新するかどうかを確認するメッセージが表示されたら、Y キーを押します。このユーティリティが正常に実行されると、次のメッセージが表示されます。
    The boot code was updated successfully (ブート コードは正常に更新されました).

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。
この問題は、Windows XP Service Pack 2 で修正済みです。
この問題は、Windows 2000 Service Pack 4 で修正済みです。 最新の Service Pack の入手方法の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
322389? (http://support.microsoft.com/kb/322389/ ) 最新の Windows XP Service Pack を入手する方法
260910? (http://support.microsoft.com/kb/260910/ ) 最新の Windows 2000 Service Pack の入手方法
: Windows XP Service Pack または Windows 2000 Service Pack をインストールしても、既存のボリュームに関する問題は解決されません。ユーティリティを実行して、ブート コードを個別に更新する必要があります。Service Pack のインストール時に行われるのは、新しいボリュームに対して適切なブート コードを記述することのみです。

詳細

関連するトピックを参照するには、以下のサポート技術情報番号をクリックしてください。
318728? (http://support.microsoft.com/kb/318728/ ) Windows 2000 での "NTLDR Is Missing" エラー メッセージのトラブルシューティング方法
886215? (http://support.microsoft.com/kb/886215/ ) Windows 98 ベースのコンピューターを Windows 2000 Professional にアップグレードすると、"NTLDR is missing press any key to restart" エラー メッセージが表示される場合がある
816793? (http://support.microsoft.com/kb/816793/ ) Windows Server 2003 での "NTLDR is missing" エラー メッセージのトラブルシューティング方法
842009? (http://support.microsoft.com/kb/842009/ ) Windows Server 2003 で自動システム回復を実行しようとすると "NTLDR is missing" エラーが発生する
883275? (http://support.microsoft.com/kb/883275/ ) Windows Server 2003、Windows XP または Windows 2000 でアクセス許可を変更した後コンピュータを起動できない
315261? (http://support.microsoft.com/kb/315261/ ) ディスク管理ツールを使用してアクティブなパーティションを変更すると、コンピュータが起動しなくなる
812492? (http://support.microsoft.com/kb/812492/ ) システム ディスクでないディスクを挿入してコンピュータを起動するとエラー メッセージが表示される
228004? (http://support.microsoft.com/kb/228004/ ) アクティブなパーティションを変更するとシステムを起動できない

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
キーワード:?
kbresolve kbwinxpsp2fix kbwin2ksp4fix kbbug kbfix kbwin2000sp3fix KB320397
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"
 

サポート技術情報の翻訳