Windows wird möglicherweise nicht gestartet und es wird die Fehlermeldung "NTLDR fehlt" angezeigt, wenn Windows nicht auf dem letzten Stand ist und sich zu viele Dateien im Stammordner befinden

Artikel-ID: 320397 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
320397 Windows may not start and you may receive an "NTLDR is missing" error message if Windows is not up-to-date and there are too many files in the root folder
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Wenn zu viele Dateien in den Stammordner eines Startvolumes kopiert wurden, das das NTFS-Dateisystem verwendet, wird möglicherweise beim nächsten Neustart des Computers folgende Fehlermeldung angezeigt:
NTLDR fehlt
Neustart mit Strg+Alt+Entf.
Wenn Sie die Dateien aus dem Stammordner entfernen, wird der MFT-Zuordnungsindex (MFT = Master File Table) nicht auf seine ursprüngliche Größe reduziert.

Hinweis: Die Ausführungen in diesem Artikel gelten nicht für den Fall, dass Sie Windows XP mit Service Pack 2 (SP2) oder Microsoft Windows 2000 mit Service Pack 4 (SP4) verwenden. Im Abschnitt "Weitere Informationen" finden Sie Hinweise zu ähnlichen Problemen.

Ursache

Dieses Problem kann auftreten, wenn der MFT-Stammordner schwer fragmentiert ist. Wenn der MFT-Stammordner viele Dateien enthält, wird die MFT möglicherweise so stark fragmentiert, dass ein zusätzlicher Zuordnungsindex erstellt wird. Da Dateien im Zuordnungsindex alphabetisch zugeordnet werden, wird die NTLDR-Datei unter Umständen in den zweiten Zuordnungsindex verschoben. Ist dies der Fall, wird die im Abschnitt "Problembeschreibung" genannte Fehlermeldung angezeigt.

Normalerweise werden Dateien nicht in den Stammordner geschrieben. Dies kann jedoch geschehen, wenn ein Programm regelmäßig temporäre Dateien im Stammordner erstellt und entfernt oder wenn viele Dateien versehentlich in den Stammordner kopiert werden.

Lösung

Gehen Sie folgendermaßen vor, um dieses Problem zu beheben:
  1. Wenden Sie sich an Microsoft Support Services, um das Dienstprogramm "Bcupdate2.exe" zu beziehen. Informationen dazu, wie Sie Kontakt mit Microsoft Support Services aufnehmen, finden Sie auf der folgenden Website von Microsoft:
    http://support.microsoft.com/default.aspx?scid=fh;DE;CNTACTMS
  2. Erstellen Sie eine Startdiskette, um den Computer zu starten. Weitere Informationen dazu, wie Sie eine Startdiskette für einen Microsoft Windows XP-Computer erstellen, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
    305595 SO WIRD'S GEMACHT: Erstellen einer Startdiskette für eine NTFS- oder FAT-Partition mit Windows XP
  3. Führen Sie den folgenden Befehl an einer Eingabeaufforderung aus, um das Dienstprogramm "Bcupdate2.exe" aus dem Softwareupdate zu extrahieren:

    Expand Laufwerkbuchstabe:\bcupdate2.ex_ Laufwerkbuchstabe:\bcupdate2.exe
  4. Führen Sie den folgenden Befehl an einer Eingabeaufforderung aus, um den Startcode des NTFS-Startsektors zu aktualisieren:

    Bcupdate2.exe C: /F

    Hinweis: Weitere unterstützte Befehlszeilenparameter:
    /q - Stiller Modus (muss /y enthalten)
    /y - Nicht bestätigen
    /f - Aktualisierung des verwendeten Volumes erzwingen
    /t - Nur auf alten Startcode prüfen
  5. Drücken Sie die Taste J, wenn Sie aufgefordert werden, die Aktualisierung des Volumes zu bestätigen. Nachdem Sie das Dienstprogramm erfolgreich ausgeführt haben, wird die folgende Meldung angezeigt:
    The boot code was updated successfully. (Der Startcode wurde erfolgreich aktualisiert.)

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.
Dieses Problem wurde erstmals in Windows XP Service Pack 2 behoben.
Dieses Problem wurde erstmals in Windows 2000 Service Pack 4 behoben. Weitere Informationen dazu, wie Sie die neuesten Service Packs erhalten, finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
322389 Wie Sie das neueste Service Pack für Windows XP erhalten
260910 Wie Sie das neueste Service Pack für Windows 2000 erhalten
Hinweis: Wenn Sie das Windows XP Service Pack oder Windows 2000 Service Pack installieren, können Sie Probleme mit einem vorhandenen Volume nicht beheben. Führen Sie das Dienstprogramm aus, um den Startcode separat zu aktualisieren. Das Service Pack schreibt nur den richtigen Startcode für neue Volumes.

Weitere Informationen

Weitere Informationen zu einem verwandten Thema finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
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Eigenschaften

Artikel-ID: 320397 - Geändert am: Donnerstag, 21. Februar 2008 - Version: 9.3
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
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