Dados do Excel não retém a respectiva formatação de operações de impressão em série no Word

Traduções de Artigos Traduções de Artigos
Artigo: 320473 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Se efectuar uma impressão em série no Microsoft Word e utilizar uma folha de cálculo do Microsoft Excel como origem de dados para a lista de destinatário, alguns dos dados numéricos podem reter não a formatação quando for intercalado.

Este comportamento aplica-se para percentagens formatadas, valores monetários e códigos postais, conforme mostrado na tabela seguinte:
   Format          In Excel data     In Word MergeField
   ----------------------------------------------------
   Percentage          50%                  .5
   Currency         $12.50                12.5
   Postal Code       07865                7895
				

Causa

Este comportamento ocorre porque os dados na lista de destinatários no Word são apresentados no formato nativo em que lojas Excel mesmo, sem a formatação ou seja aplicado às células da folha de cálculo que contêm os dados.

Resolução

Para resolver este comportamento, utilize um dos seguintes métodos.

Método 1

Utilize intercâmbio dinâmico de dados (DDE, Dynamic Data Exchange) para ligar à folha de cálculo da Excel que contém os dados que pretende utilizar. Para tal, siga estes passos.

O Word 2002 e Word 2003

  1. Inicie o Word e, em seguida, abra um novo documento em branco.
  2. No menu Ferramentas, clique em Opções e, em seguida, clique no separador Geral.
  3. Clique para seleccionar a caixa de verificação Confirmar conversão ao abrir e, em seguida, clique em OK.
  4. No menu Ferramentas, aponte para ' Cartas e mailings e, em seguida, clique em Assistente de impressão em série.
  5. Na painel de tarefas impressão em série, seleccione o tipo de documento que pretende trabalhar e, em seguida, clique em seguinte.
  6. Em Seleccionar o documento inicial, seleccione o documento inicial que pretende utilizar e, em seguida, clique em seguinte.
  7. Em Seleccionar destinatários, clique em utilizar uma lista existente e, em seguida, clique em Procurar.
  8. Na caixa de diálogo Seleccionar origem de dados, localize a pasta que contém o livro do Excel que pretende utilizar como origem de dados, seleccione o livro e, em seguida, clique em Abrir.
  9. Na caixa de diálogo Confirmar origem de dados, clique em folhas de cálculo do MS Excel via DDE (*.xls) e, em seguida, clique em OK.
  10. Na caixa de diálogo do Microsoft Excel, em com o nome ou intervalo de células, seleccione o intervalo de células ou folha de cálculo que contém os dados que pretende utilizar e clique em OK.
    Nota: os dados agora aparece na caixa de diálogo Destinatários da impressão em série com a mesma formatação que aparece no Excel folha de cálculo.

O Word 2007 e Word 2010

  1. Inicie o Word e, em seguida, abra um novo documento em branco.
  2. Vá para opções do Word
    • No Word 2007, clique no Botão do Office e, em seguida, clique em Opções do Word.
    • Em 2010 do Word, clique em ficheiro e, em seguida, clique em Opções.
  3. No separador Avançadas, consulte a secção Geral.
  4. Clique para seleccionar a caixa de verificação Confirmar conversão de formato de ficheiro ao abrir e, em seguida, clique em OK.
  5. No separador <a0>endereçamento</a0>, clique em Iniciar Impressão em série e, em seguida, seleccione o Assistente de impressão em série passo a passo.
  6. Na painel de tarefas impressão em série, seleccione o tipo de documento que pretende trabalhar e, em seguida, clique em seguinte.
  7. Em Seleccionar o documento inicial, seleccione o documento inicial que pretende utilizar e, em seguida, clique em seguinte.
  8. Em Seleccionar destinatários, clique em utilizar uma lista existente e, em seguida, clique em Procurar.
  9. Na caixa de diálogo Seleccionar origem de dados, localize a pasta que contém o livro do Excel que pretende utilizar como origem de dados, seleccione o livro e, em seguida, clique em Abrir.
  10. Na caixa de diálogo Confirmar origem de dados, clique para seleccionar a caixa de verificação <a0>Mostrar tudo. Clique em Folhas de cálculo do MS Excel via DDE (*.xls) e, em seguida, clique em ' OK '.
  11. Na caixa de diálogo do Microsoft Excel, em com o nome ou intervalo de células, seleccione o intervalo de células ou folha de cálculo que contém os dados que pretende utilizar e clique em OK.
    Nota: os dados agora aparece na caixa de diálogo Destinatários da impressão em série com a mesma formatação que aparece no Excel folha de cálculo.

Método 2

Formate o campo de Excel que contém o código postal/Código postal como texto. Para tal, siga estes passos.

O Word 2002 e Word 2003

  1. No Excel, seleccione a coluna que contém o campo de código postal/Código postal.
  2. No menu Formatar, clique em <a1>células</a1>.
  3. Clique no separador número.
  4. Em categoria, clique em texto e, em seguida, clique em OK.
  5. Guarde a origem de dados. Em seguida, continue com a operação de impressão em série no Word.

O Word 2007 e Word 2010

  1. No Excel, seleccione a coluna que contém o campo de código postal/Código postal.
  2. No separador base, vá para o grupo de células. Em seguida, clique em Formatar e, em seguida, clique em Formatar células.
  3. Clique no separador número.
  4. Em categoria, clique em texto e, em seguida, clique em OK.
  5. Guarde a origem de dados. Em seguida, continue com a operação de impressão em série no Word.

Referências

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
304387Data, número de telefone e campos de moeda são intercalados incorrectamente quando utiliza uma origem de dados do Access ou Excel no Word 2002 ou Word 2003

Propriedades

Artigo: 320473 - Última revisão: 3 de maio de 2010 - Revisão: 4.0
A informação contida neste artigo aplica-se a:
  • Microsoft Office Excel 2003
  • Microsoft Office Word 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Excel 2010
  • Microsoft Word 2010
  • Microsoft Office Excel 2007
  • Microsoft Office Word 2007
Palavras-chave: 
kbmt kbformat kbprb KB320473 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 320473

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com