Impossibile visualizzare l'errore di pagina a causa di un timeout del server proxy non valido

Avviso

L'applicazione desktop Internet Explorer 11, ritirata e fuori supporto, è stata disabilitata in modo permanente tramite un aggiornamento di Microsoft Edge su alcune versioni di Windows 10. Per altre informazioni, vedere Domande frequenti sul ritiro delle app desktop di Internet Explorer 11.

Microsoft ha identificato un problema relativo al modo in cui gli errori di connessione al server possono influire sull'uso del server proxy da parte del Web browser. È possibile che venga visualizzato un messaggio di errore Impossibile visualizzare la pagina in una rete aziendale. Questo articolo fornisce soluzioni alternative temporanee per ripristinare la connettività.

Versione originale del prodotto: Internet Explorer
Numero KB originale: 2551554

Sintomi

In rari scenari, alcuni errori in una connessione al server possono causare l'aggiunta inappropriata di server proxy all'elenco di server proxy non validi. Queste aggiunte inappropriate fanno sì che Internet Explorer ruoti l'elenco specificato di server proxy, fino a quando tutti i server proxy non vengono temporaneamente disabilitati. Internet Explorer visualizza quindi l'errore che indica che la pagina non può essere visualizzata. L'errore rimane fino a quando l'elenco proxy non valido non viene cancellato. L'elenco viene cancellato in 30 minuti, a meno che non sia stato eseguito l'override del valore predefinito.

Causa

In alcuni casi Internet Explorer non è in grado di stabilire una connessione a un determinato server proxy. In questo caso, il server viene aggiunto a un elenco di server proxy non validi. Questa aggiunta impedisce il riutilizzo del server proxy fino a quando non è trascorso un periodo di tempo. Il valore predefinito per questo periodo è 30 minuti.

Si supponga che uno script di configurazione proxy automatico restituisca un elenco PROXY che specifica più server proxy. In questo caso, viene tentata una connessione al proxy successivo nell'elenco. Il processo continua attraverso l'elenco fino a quando non viene stabilita una connessione o l'elenco non viene esaurito. L'utente riceve un messaggio di errore Pagina non visualizzabile in Internet Explorer se l'elenco è esaurito e non è stata stabilita alcuna connessione.

L'intero processo è progettato per migliorare le prestazioni complessive.

Soluzione alternativa

Per risolvere questo problema, riavviare Internet Explorer per cancellare l'elenco dei server proxy non validi.

È anche possibile impostare una chiave del Registro di sistema per impedire a Internet Explorer di aggiungere server proxy all'elenco proxy non valido.

Avviso

L'errata modifica del Registro di sistema tramite l'editor o un altro metodo può causare seri problemi. che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la soluzione di tali problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

  1. Impostare un intervallo di ripetizione dei tentativi personalizzato per i server proxy non validi nella chiave del Registro di sistema seguente:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

  2. Creare un valore DWORD in questa chiave denominata BadProxyExpiresTimee assegnare un valore pari a 0. Questo valore è espresso in secondi. L'impostazione di questo valore su 0 impedisce l'aggiunta di server proxy all'elenco di proxy non validi.

Ulteriori informazioni

La BadProxyExpiresTime chiave del Registro di sistema è stata introdotta con Internet Explorer 5.01, intorno ad aprile 2002. Per altre informazioni, vedere Internet Explorer non esegue un nuovo tentativo di server proxy non valido per 30 minuti.