Article ID: 320558 - Last Review: August 15, 2007 - Revision: 4.8

Dial-up modem or PPPoE option in New Connection Wizard is unavailable

This article was previously published under Q320558

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SYMPTOMS

If you use the New Connection Wizard to create a new dial-up modem or PPP over Ethernet (PPPoE) connection, you may experience any one or more of the following issues:
  • The Connect using a dial-up modem option in the New Connection Wizard is unavailable (appears dimmed).
  • The Connect using a broadband connection that requires a user name and password option in the New Connection Wizard is unavailable.
  • My Location does not appear in the Phone and Modem Options dialog box.
Therefore, you cannot create a dial-up modem connection or PPPoE connection to the Internet.

CAUSE

This issue may occur if both the following conditions are true:
  • You upgrade your computer to Microsoft Windows XP from Microsoft Windows 98 Second Edition or Microsoft Windows 98.
  • One or both of the following entries in the Windows registry are damaged or contain incorrect settings:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Telephony\Cards\NextID

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Telephony
For more information about other causes for this problem, click the following article number to view the article in the Microsoft Knowledge Base:
329441  (http://support.microsoft.com/kb/329441/ ) You cannot create a network connection after you restore Windows XP

RESOLUTION

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows


To resolve this issue, use the following methods in the order that they are presented.

Method 1

Delete the NextID value in the registry. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and click the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Telephony\Cards
  4. In the right pane of Registry Editor window, click NextID.
  5. On the Edit menu, click Delete.
  6. When you are prompted to confirm the deletion, click Yes.
  7. On the File menu, click Exit to quit Registry Editor.
  8. Restart the computer.
  9. Start the New Connection Wizard, and then create a new dial-up modem connection or PPPoE connection.

    If you can create a new dial-up modem connection or PPPoE connection, do not go to the next method. If the issue is not resolved, go to Method 2.

Method 2

Delete the Telephony key in the Windows registry, and then perform an in-place upgrade of Windows XP. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.
  3. Locate and click the following registry key:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Telephony
  4. On the Edit menu, click Delete.
  5. When you are prompted to confirm the deletion, click Yes.
  6. On the File menu, click Exit to quit Registry Editor.
  7. Perform an in-place upgrade of Windows XP.

Method 3: Create the area code and other desired settings in Control Panel

Create the area code and other desired settings in Control Panel. If the My Location item has not been created, the wizard should automatically appear on the computer. You may use the New Connection Wizard template to enter the area code and other settings. When you finish the wizard and restart the computer, the Connect using a dial-up modem option is available.

REFERENCES

For more information about how to perform and in-place upgrade of Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
315341  (http://support.microsoft.com/kb/315341/ ) How to perform an in-place upgrade (reinstallation) of Windows XP
For more information about how to create a dial-up modem connections in Windows XP, click the following article numbers to view the articles in the Microsoft Knowledge Base:
305549  (http://support.microsoft.com/kb/305549/ ) How to configure a connection to the Internet in Windows XP Professional
310410  (http://support.microsoft.com/kb/310410/ ) How to configure and use dial-up connections in Windows XP
For more information about how to create a PPPoE connection in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
283070  (http://support.microsoft.com/kb/283070/ ) How to create a PPPoE connection in Windows XP

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbregistry kbnetwork kbpubtypekc kbprb KB320558
 

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