Article ID: 320692 - Last Review: October 25, 2006 - Revision: 3.6

Transaction history files increase in size

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This article was previously published under Q320692

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SYMPTOMS

The transaction history file that is located in a site's SMS\Inboxes\Replmgr.box\History folder may become very large, and may continue to grow.

CAUSE

This problem was introduced with Systems Management Server (SMS) 2.0 Service Pack 3 (SP3). SMS Replication Manager incorrectly inserts the file path and unique file name that is associated with incoming site system status summarizer, component status summarizer, and advertisement status summarizer files, and inserts their associated transaction IDs.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
288239  (http://support.microsoft.com/kb/288239/ ) How to obtain the latest Systems Management Server 2.0 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The hotfix originally provided for the problem that is described in this Microsoft Knowledge Base article is no longer available. The hotfix for the following Microsoft Knowledge Base article now supercedes it. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
324204  (http://support.microsoft.com/kb/324204/ ) Collections that are based on complex queries do not update
If you want to resolve the problem that is described in this article, you must install the hotfix for Microsoft Knowledge Base article 324204.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.

MORE INFORMATION

How to install the hotfix

Apply this fix on all of the sites in the SMS hierarchy. To install the fix, use one of the following methods.

How to use the hotfix installer

Note You can use this method only on i386-based computers.
  1. Copy the hotfix folder structure to a local folder on your site server or to a share on your network. The I386 and Alpha subfolders are required; you must also download them from the Microsoft FTP site. It is important to keep the folder structure intact. The Q3320692.exe file is a Microsoft Windows Installer file that updates specific files on your site server.
  2. Log on to your site server by using an account with administrator permissions.
  3. On the site server, quit the SMS Administrator console.
  4. Run the Q320692.exe file and follow the instructions in the wizard. The Systems Management Server services are stopped and restarted as part of the installation process.

How to manually install the hotfix

  1. Copy the update program file (Q320692.exe) and platform folders to a new folder. The folder structure must be arranged so that the program file is located one folder "above" the platform folders.
  2. Quit the SMS Administrator console and stop all SMS services in Control Panel. If the SMS_SITE_BACKUP service is running, stop it also.
  3. Replace the Basesvr.dll file in the SMS\Bin\Platform folder with the version in the hotfix Platform folder.
  4. Replace the Baseutil.dll file in the SMS\Bin\Platform folder with the version in the hotfix Platform folder.
  5. Replace the Cmprov.dll file in the SMS\Bin\Platform folder with the version in the hotfix Platform folder.
  6. Replace the Colleval.dll file in the SMS\Bin\Platform folder with the version in the hotfix Platform folder.
  7. Replace the COMPMGR.EXE file in the SMS\Bin\Platform folder with the version in the hotfix Platform folder.
  8. Locate the Update.sql file in the I386 hotfix folder. In a SQL server tool such as ISQLW (SQL Query Analyzer), connect to the SMS database and verify that the DB box shows the correct SMS database name. This is typically SMS_sitecode (where sitecode is the three-digit site code for that site). Load the Update.sql script into ISQLW, and then run the script. If the script runs correctly, the Results pane shows a "The command(s) completed successfully" message.
  9. Examine the transaction history (.trs) files for the site in the SMS\Inboxes\Replmgr.box\History folder. Open each file in Notepad and then locate the [SMS_SITE_SYSTEM_STATUS_SUMMARIZER], [SMS_COMPONENT_STATUS_SUMMARIZER], and [SMS_OFFER_STATUS_SUMMARIZER] sections. In each of these sections, remove all references to X:\SMS\Inboxes\Summarizername.BOX\REPL\Uniquefilename.SUM=TransactionIDNumber. Save the .trs file.
  10. Restart the SMS site services.

APPLIES TO
  • Microsoft Systems Management Server 2.0 Service Pack 3
  • Microsoft Systems Management Server 2.0 Service Pack 4
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbsms200presp5fix kbmisctools kbbug kbfix kbsms200presp4fix KB320692
 

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