W przypadku procesorów szybszych niż 2,0 GHz programy 16-bitowe mogą nie aktualizować ekranu

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 320694 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Symptomy

Niektóre programy 16-bitowe, takie jak Edit.com i Debug.exe, nie aktualizują na czas ekranu w przypadku komputerów z procesorem o częstotliwości taktowania przekraczającej 2,0 GHz. Aktualizacja jest przeprowadzana po przesunięciu wskaźnika myszy na okno.

Przyczyna

Interwał czasomierza jest obliczany w sposób, który powoduje błąd w przypadku szybkich procesorów.

Rozwiązanie

Microsoft Windows 2000

Informacje o dodatku Service Pack

Aby rozwiązać ten problem, należy uzyskać najnowszy dodatek Service Pack dla systemu Microsoft Windows 2000. Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
260910 Jak uzyskać najnowszy dodatek Service Pack dla systemu Windows 2000

Informacje o poprawce

Firma Microsoft udostępniła obsługiwaną poprawkę. Jednak jest ona przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tę poprawkę należy stosować tylko w tych systemach, w których występuje opisany problem.

Jeśli poprawka jest dostępna do pobrania, na początku tego artykułu z bazy wiedzy Knowledge Base jest umieszczona sekcja „Poprawka dostępna do pobrania”. Jeśli nie ma tej sekcji, skontaktuj się z działem obsługi klienta i pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga W przypadku wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu może być wymagane utworzenie osobnego zlecenia usługi. Typowe opłaty za korzystanie z pomocy technicznej będą pobierane tylko w przypadku dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu tej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta i pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga Sekcja „Poprawka dostępna do pobrania” zawiera listę języków, dla których ta poprawka jest dostępna. Jeśli odpowiedni język nie jest widoczny, oznacza to, że ta poprawka nie jest dostępna dla tego języka.

Informacje o plikach

Wersja angielskojęzyczna tej poprawki powinna mieć następujące atrybuty plików (lub nowsze):
   Data        Godzina   Wersja         Rozmiar       Nazwa pliku
   -----------------------------------------------------
   17-kwi-2002  19:57  5.0.2195.5589  396 560  Ntvdm.exe
				

Windows XP

Informacje o dodatku Service Pack

Aby rozwiązać ten problem, należy uzyskać najnowszy dodatek Service Pack dla systemu Windows XP. Aby uzyskać więcej informacji, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322389 Jak uzyskać najnowszy dodatek Service Pack dla systemu Windows XP

Informacje o poprawce

Firma Microsoft udostępniła obsługiwaną poprawkę. Jednak jest ona przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Tę poprawkę należy stosować tylko w tych systemach, w których występuje opisany problem. Ta poprawka może być nadal w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, na początku tego artykułu z bazy wiedzy Knowledge Base jest umieszczona sekcja „Poprawka dostępna do pobrania”. Jeśli nie ma tej sekcji, skontaktuj się z działem obsługi klienta i pomocy technicznej firmy Microsoft w celu uzyskania poprawki.

Uwaga W przypadku wystąpienia dodatkowych błędów lub konieczności rozwiązania problemu może być wymagane utworzenie osobnego zlecenia usługi. Typowe opłaty za korzystanie z pomocy technicznej będą pobierane tylko w przypadku dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu tej poprawki. Aby uzyskać pełną listę numerów telefonów działu obsługi klienta i pomocy technicznej firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:
http://support.microsoft.com/contactus/?ws=support
Uwaga Sekcja „Poprawka dostępna do pobrania” zawiera listę języków, dla których ta poprawka jest dostępna. Jeśli odpowiedni język nie jest widoczny, oznacza to, że ta poprawka nie jest dostępna dla tego języka.

Informacje o plikach

Wersja angielskojęzyczna tej poprawki powinna mieć następujące atrybuty plików (lub nowsze):
   Data        Godzina   Wersja         Rozmiar       Nazwa pliku
   ---------------------------------------------------
   17-kwi-2002  17:25  5.1.2600.42  395 264  Ntvdm.exe   
				

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych na początku tego artykułu.

Tylko Windows XP

Ten problem został po raz pierwszy rozwiązany w dodatku Service Pack 1 dla systemu Windows XP.

Tylko Windows 2000

Ten problem został po raz pierwszy rozwiązany w dodatku Service Pack 4 dla systemu Microsoft Windows 2000.

Właściwości

Numer ID artykułu: 320694 - Ostatnia weryfikacja: 31 grudnia 2008 - Weryfikacja: 5.8
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Słowa kluczowe: 
kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kbappcompatibility kbbug kbfix kboswin2000fix kbwinxpsp1fix KB320694

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com