Artigo: 320705 - Última revisão: sábado, 28 de Outubro de 2006 - Revisão: 1.1

ID de evento 9175 é registado quando tenta reiniciar o serviço Microsoft Exchange Information Store

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Sintomas

Quando tenta reiniciar o serviço Microsoft Exchange Information Store, um evento de erro semelhante à seguinte é registado no registo de aplicações:

Tipo de evento: erro
Origem do evento: MSExchangeSA
Categoria do evento: (14)
ID do evento: 9175
Descrição: A chamada MAPI 'OpenMsgStore' falhou com o seguinte erro: O Microsoft Exchange Server computador não está disponível. Existem problemas na rede ou o Microsoft Exchange Server está desligado para manutenção. O fornecedor MAPI falhou. Arquivo de informações do Microsoft Exchange Server ID não: 8004011d-0526-00000000

Causa

Este problema ocorre porque o ficheiro de transmissão em sequência (.stm) para o arquivo do Exchange está danificado.

Resolução

Para resolver este problema, execute um restauro a partir da última cópia de segurança boa. Se uma cópia de segurança boa não estiver disponível, tem de eliminar e, em seguida, recriar o ficheiro .stm. Para o fazer, siga estes passos:
  1. Tente reiniciar o Microsoft Exchange Information Store service.
  2. Ver o registo aplicação para verificar se o evento 9175 ID é registado.
    • Se evento 9175 ID é registado e se uma cópia de segurança está disponível, restaure a partir da cópia de segurança.
    • Se é registado o evento 9175 ID e uma cópia de segurança não está disponível, copie o conteúdo da Drive: \Program Files\Exchsrvr\MDBDATA directório para uma localização segura.
  3. Verificar a consistência das bases de dados. Incluem todos os ficheiros privados e todos os ficheiros públicos.
  4. Execute o comando eseutil /r para tentar novamente as bases de dados num estado consistente.
  5. Se o comando eseutil /r falhar, execute o comando eseutil /p .

    Se receber um erro de "-1206", elimine o ficheiro .stm para a base de dados.
  6. Recrie o ficheiro .stm. Para efectuar este procedimento, execute o seguinte comando:
    eseutil /p %programfiles%\exchsrvr\mdbdata\priv1.edb /createstm
    Nota O caminho neste comando é o caminho predefinido do ficheiro de base de dados. Se a base de dados não estiver no caminho predefinido, altere o caminho do comando para o caminho correcto.
  7. Monte as bases de dados. Não inicie o Microsoft Exchange MTA Stacks ou o serviço protocolo simples de transporte de correio.

    Não pretender iniciar estes serviços porque tem que intercalar os dados para um ficheiro .pst. Por conseguinte, não pretende receber mensagens de correio electrónico ser entregue, ainda, as caixas de correio.
  8. Utilize a ferramenta Exmerge.exe para intercalar os dados para um ficheiro .pst. Em seguida, crie uma base de dados em branco.
  9. Reinicie o serviço System Attendant do Microsoft Exchange e o serviço Microsoft Exchange Information Store. Em seguida, Monte as bases de dados.
  10. Execute novamente a ferramenta Exmerge.exe e, em seguida, importar os ficheiros .pst para a nova base de dados.
  11. Execute o seguinte comando:
    %ProgramFiles%\exchsrvr\Bin isinteg -s NomeServidor - fix - testar alltests
    Nota A ferramenta Isinteg.exe executa um teste em todas as áreas de cada base de dados. Esta ferramenta apresenta resultados e tenta corrigir quaisquer problemas que a ferramenta encontrar.
  12. Execute o seguinte comando:
    eseutil /mh %programfiles%\exchsrvr\mdbdata\priv1.edb
    Nota Este comando verifica a consistência das bases de dados. Se uma base de dados for consistente, o comando gera um "estado = encerramento correcto" mensagem. Este estado indica que todos os ficheiros de registo ter sido consolidados no arquivo do Exchange. Se o comando gera um "estado = encerramento incorrecto" mensagem, a base de dados não for consistente.
  13. Pare e reinicie o serviço System Attendant do Microsoft Exchange e o serviço de Microsoft Exchange Information Store para garantir que os registos actuais estão consolidados.
  14. Teste as caixas de correio para verificar que as caixas de correio contêm os dados correctos e para verificar o fluxo de correio correcto está a ocorrer.
  15. Inicie o resto dos serviços do Exchange. Cópia de bases de dados assim que possível.

Mais Informação

Para obter mais informações, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
174197  (http://support.microsoft.com/kb/174197/ ) Informações do Microsoft Exchange Mailbox enviar a impressão em série programa (Exmerge.exe)
317014  (http://support.microsoft.com/kb/317014/ ) Parâmetros da linha de comandos Eseutil do Exchange 2000 Server
327346  (http://support.microsoft.com/kb/327346/ ) Ficheiros de base de dados STM estão inconsistentes depois de executar o comando de /p Eseutil
313184  (http://support.microsoft.com/kb/313184/ ) Como recuperar o arquivo de informações no Exchange 2000 num único local

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Palavras-chave: 
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