ID do artigo: 320705 - Última revisão: sábado, 28 de outubro de 2006 - Revisão: 1.1

IDENTIFICAÇÃO de evento 9175 é registrada quando você tenta reiniciar o serviço Microsoft Exchange Information Store

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Sintomas

Ao tentar reiniciar o serviço Microsoft Exchange Information Store, um evento de erro semelhante à seguinte é registrado no log do aplicativo:

Tipo de evento: erro
Origem do evento: MSExchangeSA
Categoria do evento: (14)
IDENTIFICAÇÃO de evento: 9175
Descrição: A chamada MAPI 'OpenMsgStore' falhou com o seguinte erro: O Microsoft Exchange Server computador não está disponível. Ou há algum problema de rede ou o Microsoft Exchange Server está desativado para manutenção. O provedor MAPI não pôde. ID de armazenamento de informações do Microsoft Exchange Server não: 8004011d-0526-00000000

Causa

Esse problema ocorre porque o arquivo de fluxo contínuo (.stm) para o armazenamento do Exchange está danificado.

Resolução

Para resolver esse problema, execute uma restauração desde o último backup boa. Se um bom backup não estiver disponível, você deve excluir e recrie o arquivo .stm. Para fazer isso, execute as seguintes etapas:
  1. Tente reiniciar o Microsoft Exchange Information Store service.
  2. Exiba o log Application para ver se o evento 9175 ID está conectado.
    • Se o evento 9175 ID é registrada e se um backup está disponível, restaurar do backup.
    • Se o evento 9175 ID é registrado e se um backup não está disponível, copiar o conteúdo da Drive: \Program Files\Exchsrvr\MDBDATA diretório para um local seguro.
  3. Verificar a consistência dos bancos de dados. Incluir todos os os arquivos particulares e todos os arquivos públicos.
  4. Execute o comando eseutil /r para tentar retornar os bancos de dados para um estado consistente.
  5. Se o comando eseutil /r falhar, execute o comando eseutil /p .

    Se você receber uma mensagem de erro "-1206", exclua o arquivo STM para o banco de dados.
  6. Recrie o arquivo .stm. Para fazer isso, execute o seguinte comando:
    eseutil /p %programfiles%\exchsrvr\mdbdata\priv1.edb /createstm
    Observação O caminho neste comando é o caminho padrão do arquivo de banco de dados. Se o banco de dados não estiver no caminho padrão, altere o caminho no comando para o caminho correto.
  7. Monte os bancos de dados. Não inicie o Microsoft Exchange MTA Stacks serviço ou o serviço SMTP.

    Deseja iniciar esses serviços, porque você tem que mesclar os dados para um arquivo .pst. Portanto, você não deseja as mensagens de email de entrada a ser enviadas para as caixas de correio ainda.
  8. Use a ferramenta ExMerge.exe para mesclar os dados para um arquivo .pst. Em seguida, crie um banco de dados em branco.
  9. Reinicie o serviço Microsoft Exchange System Attendant e o serviço Microsoft Exchange Information Store. Em seguida, monte os bancos de dados.
  10. Execute a ferramenta ExMerge.exe novamente e, em seguida, importar os arquivos .pst para o novo banco de dados.
  11. Execute o seguinte comando:
    %ProgramFiles%\exchsrvr\Bin isinteg -s servername - corrigir - teste alltests
    Observação A ferramenta Isinteg.exe executa um teste em todas as áreas de cada banco de dados. Essa ferramenta relata os resultados e tenta corrigir quaisquer problemas que a ferramenta encontrar.
  12. Execute o seguinte comando:
    eseutil /mh %programfiles%\exchsrvr\mdbdata\priv1.edb
    Observação Esse comando verifica a consistência dos bancos de dados. Se um banco de dados estiver consistente, o comando gera um "estado = desligamento normal" mensagem. Este estado indica que todos os arquivos de log foram confirmados para o armazenamento do Exchange. Se o comando gera um "estado = desligamento anormal" mensagem, o banco de dados não é consistente.
  13. Pare e reinicie o serviço Microsoft Exchange System Attendant e o serviço Microsoft Exchange Information Store para se certificar que os logs atuais estão confirmados.
  14. Teste as caixas de correio para verificar se as caixas de correio contêm os dados corretos e para verificar se o fluxo de email correto está ocorrendo.
  15. Inicie o restante dos serviços do Exchange. Backup de bancos de dados assim que possível.

Mais Informações

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
174197  (http://support.microsoft.com/kb/174197/ ) Informações do Microsoft Exchange Mailbox Merge Program (Exmerge.exe)
317014  (http://support.microsoft.com/kb/317014/ ) Opções de linha de comando Eseutil do Exchange 2000 Server
327346  (http://support.microsoft.com/kb/327346/ ) Arquivos de banco de dados STM são inconsistentes após executar o Eseutil /p comando
313184  (http://support.microsoft.com/kb/313184/ ) Como recuperar o armazenamento de informações no Exchange 2000 em um único site

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Palavras-chave: 
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Clique aqui para ver a versão em Inglês deste artigo: 320705  (http://support.microsoft.com/kb/320705/en-us/ )