ID do artigo: 320757 - Última revisão: sexta-feira, 16 de março de 2007 - Revisão: 2.13

Você recebe uma mensagem de erro 1919 quando você inicia o Outlook 2000 ou instala o Office 2000

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registro. Antes de modificar o registro, certifique-se de backup e certifique-se que você saiba como restaurar o registro se ocorrer um problema. Para obter informações sobre como fazer backup, restaurar e editar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Quando você inicia o Microsoft Outlook ou instalar o Microsoft Office, você receberá a seguinte mensagem de erro:
Mensagem de erro Erro 1919. Erro ao configurar fonte de dados ODBC: Microsoft Access Database; erro ODBC. 6: Componente não encontrado no registro. Verifique se os arquivos de banco de dados Microsoft Access arquivo existe e você pode acessá-lo.

Causa

Esse comportamento pode ocorrer se ambas as condições a seguir forem verdadeiras:
  • Corel WordPerfect Office 2002 é instalado e em seguida, removido do computador.
  • O procedimento de remoção do Corel WordPerfect Office 2002 remove drivers de ODBC (Open Database Connectivity) do computador.
Como resultado, as chaves ODBC são ausentes do registro do Microsoft Windows. Esse é um problema conhecido no Corel WordPerfect Office 2002.

Resolução

Método 1

Instale o Microsoft Data Access Components (MDAC) 2.8. Para obter o MDAC 2.8, visite o seguinte site da MSDN:
http://msdn2.microsoft.com/en-us/data/aa937712.aspx (http://msdn2.microsoft.com/en-us/data/aa937712.aspx)
Para obter informações adicionais sobre o MDAC 2.8, visite o seguinte site:
http://msdn2.microsoft.com/en-us/library/ms810805.aspx (http://msdn2.microsoft.com/en-us/library/ms810805.aspx)

Método 2

Etapa 1: Exportar chaves do Registro ODBC

Aviso Se você usar o Editor do Registro incorretamente, você pode causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você pode resolver problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do registro por sua própria conta e risco.
Observação Como existem várias versões do Microsoft Windows, as seguintes etapas podem ser diferentes no seu computador. Se estiverem, consulte a documentação do produto para concluir estas etapas. Observação O computador que você está importando registro chaves de devem usar a mesma versão do Microsoft Windows e ser semelhante ao ou uma duplicata do computador que está apresentando o comportamento descrito na seção "Sintomas".
  1. Insira um disquete na unidade de disquete do computador cujas chaves do Registro ODBC você está exportando.
  2. Clique em Iniciar e, em seguida, clique em Executar .
  3. Na caixa Abrir , digite regedit e, em seguida, clique em OK .
  4. Localize e clique nas seguintes chaves do Registro:
    HKEY_LOCAL_MACHINE\Software\ODBC

    HKEY_CURRENT_USER\Software\ODBC
  5. Siga estas etapas para exportar cada chave de registro localizado na etapa 4:
    1. No menu arquivo , clique em Exportar .
    2. Na caixa Salvar em da caixa de diálogo Exportar arquivo do Registro , clique em disquete de 3½ (a:) , digite um nome para o arquivo no nome do arquivo da caixa e, em seguida, clique em Salvar .

      Observação Certifique-se de que usar um nome diferente para cada arquivo .reg.
  6. Feche o Editor do Registro.

Etapa 2: Importar as chaves de Registro ODBC

  1. Insira o disquete que contenha os arquivos .reg na unidade de disquete do computador que está apresentando o comportamento descrito na seção "Sintomas".
  2. Inicie o Microsoft Windows Explorer e localize a unidade de disquete.
  3. Clique duas vezes em cada arquivo .reg que você criou e salvou no disquete na "etapa 1: Exportar chaves do Registro ODBC" seção.
  4. Clique em Sim quando perguntado para adicionar informações ao registro.
  5. Clique em OK quando você receber a mensagem informando que as informações com êxito são inseridas no registro.

Etapa 3: Reinstalar o Office

  1. Reinicie o computador.
  2. Insira o CD-ROM do Office na unidade de CD-ROM ou DVD-ROM e, em seguida, executar a instalação do Microsoft Office.
  3. Clique em R epair Office , clique em Reinstalar o Office ou clique em Reparar erros na minha Office instalação e em seguida, clique em Concluir .
.

Mais Informações

Para obter mais informações sobre como solucionar mensagens de erro Erro 1919 no Office 2000, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
292448  (http://support.microsoft.com/kb/292448/ ) Mensagens de erro ao instalar um produto do Office ou iniciar o Word
324520  (http://support.microsoft.com/kb/324520/ ) "Erro 1919. Mensagem de erro Erro configurar fonte de dados ODBC"ao tentar instalar o Office XP ou um programa do Office XP
Para obter mais informações, visite o seguinte site da Corel Corporation:
http://apps.corel.com/support/index.htm (http://apps.corel.com/support/index.htm)
Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.
A Microsoft fornece terceiros informações de contatos para ajudá-lo a encontrar suporte técnico. Essa informações de contatos podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão dessas informações contatos de terceiros.

A informação contida neste artigo aplica-se a:
  • Microsoft Outlook 2000
  • Microsoft Office 2000 Premium Edition
  • Microsoft Office 2000 Professional Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Developer Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2000 Standard Edition
Palavras-chave: 
kbmt kbregistry kberrmsg kbprb KB320757 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 320757  (http://support.microsoft.com/kb/320757/en-us/ )