Article ID: 320797 - Last Review: October 25, 2006 - Revision: 4.5

SMS: Windows 98 Client Hangs When the Wuser32.exe SMS Remote Control Agent Starts

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This article was previously published under Q320797

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SYMPTOMS

When the Wuser32.exe Systems Management Server (SMS) Remote Control client agent starts on a Microsoft Windows 98-based computer, the client may cause the computer to stop responding (hang). When this occurs, only the mouse pointer continues to work.

CAUSE

This issue occurs if you are using the Intel 82830M video adapter driver (Ialmdrv.drv) with the SMS Remote Control feature. Dell Latitude C400 laptop computers (among others) use this driver. The SMS client was not updated to work properly with all multiple-monitor-aware Windows 98 video adapter drivers.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Systems Management Server 2.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
288239  (http://support.microsoft.com/kb/288239/EN-US/ ) How to Obtain the Latest Systems Management Server 2.0 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English-language version of this fix for SMS 2.0 Service Pack 3 (SP3) sites should have the following file attributes or later:
Date         Time   Version         Size       File name       Platform
-----------------------------------------------------------------------
01-Mar-2001  18:55  2.00.1493.3259     23,520  Coexist.dll         I386
01-Mar-2001  18:55                         67  Compverremctrl.ini  I386
01-Mar-2001  18:55  2.0.92.09         740,363  Remc16.exe          I386
01-Mar-2001  18:55  2.0.92.09       1,360,348  Remctrl.exe         I386
					
NOTE: Because of file dependencies, the most recent hotfix or feature that contains the above files may also contain additional files.

WORKAROUND

Do not use the Ialmdrv.drv video adapter driver on Windows 98-based clients with the SMS Remote Control agent installed.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Systems Management Server 2.0 Service Pack 5.

MORE INFORMATION

To install the hotfix, use the appropriate method.

Use the Hotfix Installer

NOTE: This method is only for Intel-based computers.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the update file (Q320797.exe) and platform folders to the new folder. The folder structure must be arranged so that the update file is located one folder "above" the platform folders.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  4. Quit the SMS Administrator console, if it is running.
  5. Run Q320797.exe, and then follow the instructions in the wizard.

Manual Installation

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the platform folders that contain the hotfix files to the new folder.
  3. From each of the primary and secondary SMS site servers in your environment, log on to your site server by using an account with administrator permissions.
  4. Quit the SMS Administrator console, if it is running.
  5. Stop all SMS services.
  6. Replace the Remc16.exe file in the Sms_root_folder\Inboxes\Clicomp.src\Remctrl\Platform folder with the version from the hotfix.
  7. Replace the Remctrl.exe file in the Sms_root_folder\Inboxes\Clicomp.src\Remctrl\Platform folder with the version from the hotfix.
  8. Replace the Compver.ini file in the Sms_root_folder\Inboxes\Clicomp.src\Remctrl folder with the Compverremctrl.ini file from the hotfix. Note that you must rename the Compverremctrl.ini file to Compver.ini.
  9. Restart all SMS services.

APPLIES TO
  • Microsoft Systems Management Server 2.0 Standard Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhardware kbsms200presp5fix kbbug kbfix KB320797
 

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