ID do artigo: 320872 - Última revisão: quinta-feira, 1 de fevereiro de 2007 - Revisão: 2.2

Os clientes da Web recebe um erro "Não é possível executar as extensões de servidor FrontPage nesta página" mensagem quando eles enviarem um formulário de comentários no FrontPage

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Os clientes da Web receber uma mensagem de erro semelhante ao exemplo a seguir ao tentar enviar um formulário de comentários que esteja em sua página da Web:
Não é possível executar as extensões de servidor do FrontPage nesta página:
"http://www.example.com/subfolder/feedback.htm"

Causa

Esse problema ocorre se você criar uma página no Microsoft Office FrontPage 2003 ou no Microsoft FrontPage 2002 usando o formulário de comentários modelo e, em seguida, salve a página para uma subpasta em vez de salvá-lo para a pasta raiz do site. Quando um cliente envia o formulário, o FrontPage salvar resultados componente tenta salvar os resultados para o local errado. Por exemplo, se você salvou a página de comentários em uma subpasta chamada Test, salvar resultados componente tenta salvar os resultados para a pasta Test/_private, que não existe.

Resolução

Para resolver esse problema, execute essas etapas:
  1. Abra sua Web no FrontPage.
  2. Na lista de pastas, expanda a pasta _private que está na raiz do seu site da Web.
  3. Localize o arquivo Feedback.txt . Se você não pode localizar esse arquivo, execute estas etapas:
    1. No menu arquivo , clique em novo e, em seguida, clique em página ou Web .

      O painel de tarefas é aberto.
    2. Em Novo com base em modelo , clique em Modelos de página .
    3. Na guia Geral , clique em Página Normal e, em seguida, clique em OK .
    4. Alterne para o modo de exibição em HTML e exclua todas as HTMLS código.
    5. No menu arquivo , clique em Salvar .
    6. Localize e, em seguida, clique duas vezes a pasta _private , que está na raiz da sua Web.
    7. Na caixa Salvar como tipo , clique em todos os arquivos (*. *) .
    8. Na caixa nome do arquivo , digite Feedback.txt .
    9. Clique em Salvar .
  4. Abra a página que contém o formulário de comentários.
  5. Clique com o botão direito do formulário e clique em Propriedades do formulário .

    Observe que o campo nome do arquivo mostra que os resultados serão salvas para o caminho relativo do _private/Feedback.txt, que não existe. (Por exemplo, se você salvou a página de comentários em uma subpasta chamada teste na raiz do seu site da Web, esse caminho é /Test/_private/Feedback.txt.)
  6. Clique em Procurar .
  7. Localize e, em seguida, clique duas vezes a pasta _private , que está na raiz da sua Web.
  8. Clique no arquivo Feedback.txt e, em seguida, clique em OK .
  9. Salve a página de formulário.

Mais Informações

Por padrão, o componente Salvar resultados no formulário de comentários modelo salva os resultados em um arquivo de texto chamado _private/Feedback.txt na raiz da sua Web. Por padrão, se você salvar a página de comentários em uma subpasta, o componente Salvar resultados aponta para uma _private pasta relativa para a subpasta--uma pasta _private que não existe--em vez de para a pasta _private na raiz da sua Web.

A informação contida neste artigo aplica-se a:
  • Microsoft Office FrontPage 2003
  • Microsoft FrontPage 2002 Standard Edition
Palavras-chave: 
kbmt kbforms kbsavefile kberrmsg kbprb KB320872 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 320872  (http://support.microsoft.com/kb/320872/en-us/ )