Проблемы с обновлением драйвера печати пользовательского режима с использованием программы указания и печати

Переводы статьи Переводы статьи
Код статьи: 320914 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

При использовании клиентом программы указания и печати для подключения к сетевому принтеру клиент не получает информации об обновлении драйвера, если на сервере был заменен драйвер принтера. То есть, если на сервере был заменен драйвер совместно используемого принтера, у клиента этот драйвер не заменяется.

Причина

Эта проблема возникает потому, что код Localspl обнаруживает, что драйвер был изменен и может некорректно удалять данные из реестра.

Решение

Windows XP

Чтобы решить эту проблему, получите последний пакет обновления для Windows XP. За дополнительной информацией обратитесь к следующей статье Microsoft Knowledge Base:
322389 Как получить последний пакет обновления для Windows XP
Можно также загрузить отдельные обновления, устраняющие эту проблему, с веб-узла центра загрузки Microsoft.

Windows XP Home Edition, Windows XP Professional
Свернуть это изображениеРазвернуть это изображение
Загрузить
Загрузить пакет Q320914
Windows XP (64-разрядная версия)
Свернуть это изображениеРазвернуть это изображение
Загрузить
Загрузить пакет Q320914
Дата выпуска: 16 октября 2002 г.

За дополнительной информацией о загрузке файлов с узла технической поддержки корпорации Microsoft обратитесь к следующей статье Microsoft Knowledge Base:
119591 Как загрузить файлы поддержки Microsoft из Интернета
Корпорация Microsoft проверила этот файл на наличие вирусов. Корпорация Microsoft использует последние версии антивирусного программного обеспечения на момент публикации файла для проверки его на наличие вирусов. Файл хранится на закрытом сервере, предотвращающем его несанкционированное изменение. Английская версия данного исправления содержит версии файлов, приведенные в следующей таблице, или более поздние. Дата и время для файлов указаны в формате универсального глобального времени (по Гринвичу). При просмотре сведений о файле в системе происходит перевод соответствующих значений в местное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, следует использовать вкладку Часовой пояс элемента панели управления «Дата и время».
   Дата         Время  Версия        Размер  Имя файла      Платформа
   ----------------------------------------------------------------------
   02-авг-2002  17:30  5.1.2600.46  284 160  Localspl.dll   i386
   02-авг-2002  17:30  5.1.2600.49   86 528  Win32spl.dll   i386

   02-авг-2002  17:30  5.1.2600.46  946 688  Localspl.dll   Itanium 64-bit
   02-авг-2002  17:30  5.1.2600.49  264 192  Win32spl.dll   Itanium 64-bit
   28-май-2002  21:38  5.1.2600.46  284 160  Wlocalspl.dll  Itanium 64-bit

   24-июл-2002  05:43  5.1.2600.49   86 528  Wwin32spl.dll  Itanium 64-bit
				

Windows 2000

Сведения о пакете обновления

Для решения этой проблемы необходимо получить последний пакет обновления для Microsoft Windows 2000. За дополнительной информацией обратитесь к следующей статье Microsoft Knowledge Base:
260910 Как получить последний пакет исправлений для Microsoft Windows 2000

Сведения об исправлениях

Данная проблема может быть решена с помощью исправления, выпущенного корпорацией Microsoft. Предлагаемое исправление должно применяться исключительно в системах, где наблюдается описанная выше проблема. Данное исправление находится на стадии дополнительного тестирования. По этой причине Microsoft рекомендует во всех случаях, когда проблема не представляет особой важности, отложить ее решение до выхода ближайшего пакета обновления Windows 2000, в который будет включено решение описанной проблемы.

Для немедленного решения этой проблемы загрузите исправления, нажав приведенную ниже ссылку, или обратитесь в службу технической поддержки Microsoft. Полный список телефонов служб поддержки, а также информацию по условиям обслуживания см. на веб-узле Microsoft по адресу:
http://support.microsoft.com/default.aspx?scid=fh;RU;CNTACTMS
Примечание. В отдельных случаях, если специалистом службы технической поддержки Microsoft будет определено, что решением проблемы является специально выпущенное исправление, оплата, предусмотренная за обращение в службы технической поддержки, может быть отменена. Дополнительные вопросы, не связанные с данным исправлением, решаются в соответствии со стандартными условиями.

Загрузите следующий файл с узла центра загрузки Microsoft:
Свернуть это изображениеРазвернуть это изображение
Загрузить
Загрузить пакет Q320914
Дата выпуска: 16 октября 2002 г.

За дополнительной информацией о загрузке файлов с узла технической поддержки корпорации Microsoft обратитесь к следующей статье Microsoft Knowledge Base:
119591 Как загрузить файлы поддержки Microsoft из Интернета
Корпорация Microsoft проверила этот файл на наличие вирусов. Корпорация Microsoft использует последние версии антивирусного программного обеспечения на момент публикации файла для проверки его на наличие вирусов. Файл хранится на закрытом сервере, предотвращающем его несанкционированное изменение. Английская версия данного исправления содержит версии файлов, приведенные в следующей таблице, или более поздние. Дата и время для файлов указаны в формате универсального глобального времени (по Гринвичу). При просмотре сведений о файле в системе происходит перевод соответствующих значений в местное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, следует использовать вкладку Часовой пояс элемента панели управления «Дата и время».
   Дата         Время  Версия         Размер   Имя файла
   --------------------------------------------------------
   30-апр-2002  09:37  5.0.2195.5709  249 616  Localspl.dll
				

Windows NT 4.0

Данная проблема может быть решена с помощью исправления, выпущенного корпорацией Microsoft. Предлагаемое исправление должно применяться исключительно в системах, где наблюдается описанная выше проблема.

Для немедленного решения этой проблемы загрузите исправления, нажав приведенную ниже ссылку, или обратитесь в службу технической поддержки Microsoft. Полный список телефонов служб поддержки, а также информацию по условиям обслуживания см. на веб-узле Microsoft по адресу:
http://support.microsoft.com/default.aspx?scid=fh;RU;CNTACTMS
Примечание. В отдельных случаях, если специалистом службы технической поддержки Microsoft будет определено, что решением проблемы является специально выпущенное исправление, оплата, предусмотренная за обращение в службы технической поддержки, может быть отменена. Дополнительные вопросы, не связанные с данным исправлением, решаются в соответствии со стандартными условиями.

Загрузите следующий файл с узла центра загрузки Microsoft:
Свернуть это изображениеРазвернуть это изображение
Загрузить
Загрузить пакет Q320914
Дата выпуска: 16 октября 2002 г.

За дополнительной информацией о загрузке файлов с узла технической поддержки корпорации Microsoft обратитесь к следующей статье Microsoft Knowledge Base:
119591 Как загрузить файлы поддержки Microsoft из Интернета
Корпорация Microsoft проверила этот файл на наличие вирусов. Корпорация Microsoft использует последние версии антивирусного программного обеспечения на момент публикации файла для проверки его на наличие вирусов. Файл хранится на закрытом сервере, предотвращающем его несанкционированное изменение. Английская версия данного исправления содержит следующие или более поздние версии файлов.
   Дата         Время  Размер   Имя файла     Платформа
   ---------------------------------------------------
   30-апр-2002  10:46  140 560  Localspl.dll  i386
				

Статус

Данное поведение является подтвержденной ошибкой продуктов Microsoft, перечисленных в начале данной статьи. Первое исправление этой проблемы появилось в пакете обновления 1 (SP1) для Windows XP. Впервые эта ошибка была исправлена в пакете обновления 4 (SP4) для Microsoft Windows 2000.

Дополнительная информация

За дополнительной информацией о получении исправления для Windows 2000 Datacenter Server обратитесь к следующей статье Microsoft Knowledge Base:
265173 Описание программы Windows Datacenter Program и Microsoft Windows 2000 Datacenter Server

Свойства

Код статьи: 320914 - Последний отзыв: 1 декабря 2007 г. - Revision: 4.3
Информация в данной статье относится к следующим продуктам.
  • операционная система Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Операционная система Microsoft Windows 2000 Professional
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT 4.0 Service Pack 6a
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Ключевые слова: 
kbbug kbfix kbwin2000presp4fix kbprint kbqfe kbwinxpsp1fix kbwin2ksp4fix kbhotfixserver KB320914

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com