PRB: 1394 Devices Stop Responding During Isochronous Transfer Operations

Traduzione articoli Traduzione articoli
Identificativo articolo: 320949 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato archiviato. L?articolo, quindi, viene offerto ?così come è? e non verrà più aggiornato.
Espandi tutto | Chiudi tutto

Sintomi

When a 1394 device performs an isochronous transfer, this operation may be unsuccessful if certain non-page aligned data buffers are used.

Cause

If a 1394 device driver passes non-page aligned data buffers at REQUEST_ISOCH_ATTACH_BUFFERS time and uses the DESCRIPTOR_SYNCH_ON_SY flag in the attached isoch descriptors, you may receive an error message on a blue screen. Note that not all non-page aligned buffers cause this behavior. This behavior occurs if Ohci1394.sys does not correctly map the ScatterGather DMA array.

Risoluzione

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to Obtain the Latest Windows XP Service Pack
The English-language version of this fix should have the following file attributes or later:
Date         Time   Version        Size    File name     Operating system
-------------------------------------------------------------------------
07-Mar-2002  10:51  5.0.2195.5040  37,712  OHCI1394.SYS  Windows 2000
11-Mar-2002  12:18  5.1.2600.34    55,552  OHCI1394.SYS  Windows XP
					

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a..." di questo articolo. This problem was first corrected in Microsoft Windows 2000 Service Pack 3 (SP3) and Microsoft Windows XP Service Pack 1 (SP1).

Proprietà

Identificativo articolo: 320949 - Ultima modifica: mercoledì 26 febbraio 2014 - Revisione: 3.1
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 2000 Standard Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Chiavi: 
kbnosurvey kbarchive kbqfe kbhotfixserver kbappcompatibility kbbug kbfix kboswin2000fix kbwin2000sp3fix kbwinxpsp1fix KB320949
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com