ID události 11 v protokolu systémových řadičů domény

Překlady článku Překlady článku
ID článku: 321044 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

V systémovém protokolu na jeden nebo více řadičů domény mohou být zaznamenány následující události:

Typ události: Chyba
Zdroj události: KDC
Kategorie události: žádný
ID události: 11
Datum: 4/1/2002
Čas: 1:40:14 PM
Uživatel: není k dispozici
Počítač:Název_počítače
Popis: Existuje více účtů s názvem host/mycomputer.mydomain.com typu 10.

Typ události: Chyba
Zdroj události: KDC
Kategorie události: žádný
ID události: 11
Datum: 8/17/2004
Čas: 1:30:00 PM
Uživatel: není k dispozici
Počítač:Název_počítače
Popis: Existuje více účtů s názvem hostitele/nazev_pocitace typu DS_SERVICE_PRINCIPAL_NAME.

Typ události: Chyba
Zdroj události: protokol Kerberos
Kategorie události: žádný
ID události: 4
Datum: 8/17/2004
Čas: 1:30:00 PM
Uživatel: není k dispozici
Počítač:Název_počítače
Popis: Klient služby kerberos obdržel chybu KRB_AP_ERR_MODIFIED ze serveru host/machinename.childdomain.rootdomain.com. Použit cílový název byl cifs/machinename.domain.com. To znamená, že heslo použité k šifrování lístku služby kerberos je jiný než na cílovém serveru. Obvykle je to způsobeno účty stejně pojmenované počítače v cílové sféry (childdomain.rootdomain.COM) a sféře klienta. Obraťte se na vašeho správce systému.

Tato událost může rovněž vztahuje na další hlavní názvy služeb. Například této události také použít k hostiteli neboNetBIOSComputerName.

Příčina

Tomuto problému dochází, protože dvě nebo více účtů počítače mají stejný hlavní název služby (SPN) registrován. Centrum distribuce klíčů (KDC) přijme požadavek na lístek a související SPN existuje více než jednou při kontrole na globální katalog (GC) pro ověření forestwide, je zaprotokolována událost s ID 11.

Řešení

Chcete-li tento problém vyřešit, vyhledejte účty počítače, které mají duplicitní názvy SPN. Při vyhledání počítačů, které mají duplicitní názvy SPN, můžete odstranit účet počítače z domény, disjoin a znovu připojit počítač k doméně, nebo můžete použít nástroj ADSIEdit opravit SPN v počítači, který má nesprávný název SPN.

Chcete-li vyhledat účty počítače, které mají duplicitní názvy SPN, použijte jednu z následujících metod.

Metoda 1: Použití nástroje LDP podpory

Poznámka: Pokud jste nainstalovali nástroje podpory systému Windows 2000, je nainstalujte z disku CD-ROM systému Windows 2000 před pokračováním. Spustitelný soubor instalace nástrojů podpory je umístěn na disku CD-ROM ve složce Support\Tools. Instalace nevyžaduje restartování počítače. Však budete muset restartovat počítač, aby aktualizace proměnných prostředí.
  1. Klepněte na tlačítko Spustit, klepněte na tlačítko Spustit, typ NÁSTROJ LDPa klepněte na tlačítko OK.
  2. Klepněte na tlačítko Připojenía klepněte na tlačítko Připojit.
  3. Zachovejte výchozí nastavení a klepněte na tlačítko OK.

    Poznámka: Pokud neobdržíte očekávaný výsledek, zkuste jiné hledání pomocí portu globální katalog (3268) namísto výchozího nastavení (389).
  4. Klepněte na tlačítko Připojenía klepněte na tlačítko BIND.
  5. Zachovejte výchozí nastavení a klepněte na tlačítko OK.
  6. Klepněte na tlačítko Zobrazenía klepněte na tlačítko Strom.
  7. V Stromové zobrazení Dialogové okno, typ DC =DoménaDC = com v Základní pole, kde Doména je vaší domény.
  8. Klepněte na tlačítko Procházeta klepněte na tlačítko Hledání.
  9. V Hledání Dialogové okno Zadejte DC =DoménaDC = com v Základní pole.
  10. V Hledání Dialogové okno, typ (ServicePrincipalName= HOSTITEL /MyComputer.mydomain.com)v Filtr pole. Pokud hlavní název služby, podle chyby v systémovém protokolu se liší od příkladu, zadejte hlavní název služby, na které se vztahuje k chybě.

    Poznámka: Pokud neobdržíte očekávaných výsledků, zkuste hledat "HOST /" jako protiklad k vyhledání pouze přesný název SPN událostí ID.
  11. Ve skupinovém rámečku Oblast působnosti, klepněte na tlačítko Podstrom.
  12. Klepněte na tlačítko Spustit.

Metoda 2: Použití nástroje Ldifde

Pomocí nástroje Ldifde výpis SPN doménové struktury:
  1. Z řadiče domény spusťte příkazový řádek a zadejte následující řetězec:
    ldifde -f check_SPN.txt -t 3268 -d "" -l servicePrincipalName - r "(servicePrincipalName = HOST/mycomputer *)" -p subtree
    (Poznámka: Protože pomocí parametru -t 3268 určit, že je globální katalog (GC) server použit v dotazu a nepoužijete parametr -d zadat explicitní rozlišující název (DN), kořenovou DN se používá k hostiteli / mycomputer * parametr. Proto můžete vyhledat všechny názvy SPN, které obsahuje tento řetězec.
  2. V programu Poznámkový blok otevřete soubor check_SPN.txt a vyhledejte název SPN, který je hlášen v protokolu událostí.
  3. Poznámka: uživatelské účty a účty počítačů, ve kterých je umístěn hlavní název služby.

Metoda 3:

Pomocí skriptu querySpn.vbs v následujícím článku znalostní báze Microsoft TechNet. Skript použít, zkopírujte kód, vložte jej do programu Poznámkový blok a uložte skript jako querySpn.vbs.
http://www.microsoft.com/technet/scriptcenter/Solutions/spnquery.mspx
Spusťte skript pomocí následujícího příkazu:
cscript spnquery.vbs HOST / mycomputer * > check_SPN.txt
Poznámka: Check_SPN.txt soubor získané výstup ze skriptu v metodě 3 lze použít stejným způsobem popsaným v metodě 2.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Vlastnosti

ID článku: 321044 - Poslední aktualizace: 19. května 2011 - Revize: 8.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
Klíčová slova: 
kbenv kberrmsg kbprb kbmt KB321044 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:321044

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com