Los cuadros "Buscar en" y "Guardar como" de los cuadros de diálogo comunes funcionan despacio

Seleccione idioma Seleccione idioma
Id. de artículo: 321126 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Si tiene conexiones persistentes a unidades de red (por ejemplo, para la unidad Z) que son inaccesibles por algún motivo, cuando hace clic en Abrir en el menú archivo y, a continuación, haga clic en el cuadro Buscar en la flecha de lista desplegable, puede tardar varios minutos antes de que despliega realmente las listas. El mismo retraso largo puede producir con el cuadro de lista desplegable Guardar en , en los cuadros de diálogo Guardar o Guardar como .

El retraso puede ocurrir si una unidad remota es inaccesible. Por ejemplo, el retraso puede producirse cuando se trabaja sin conexión con ninguna conexión de red después de desconectar el cable de red del equipo o si problemas de enrutamiento u otros problemas de red causa problemas de comunicación con equipos remotos.

Programas (como el Bloc de notas) que utilizan cuadros de diálogo comunes se ven afectados. Otros programas (como los programas de Microsoft Office) que utilizan listas desplegable similares en sus cuadros de diálogo también pueden verse afectados.

Durante el retardo, el programa no responde y no muestra un puntero de reloj de arena. El programa puede parecer que deja de responder (se bloquea) durante varios minutos, aunque el programa finalmente responde.

Causa

Código fue agregado en Windows 2000 para mejorar la presentación de Buscar (y similares) cuadros desplegables. Sin embargo, el nuevo código genera varias consultas para cada conexión memorizada a una unidad de red remota. Si las unidades de red son inaccesibles, el código realiza varios intentos de conexión a la unidad remota. Cada intento tarda varios segundos hasta agotar el tiempo de espera.

Si tiene muchas conexiones de unidad de red persistentes, puede agregar el retraso acumulado de todos los intentos de conexión agotado a varios minutos.

Solución

Información de Service Pack

Para resolver este problema, consiga el Service Pack más reciente para Microsoft Windows 2000. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910Cómo obtener el Service Pack más reciente para Windows 2000

Información de instalación de Service Packs

Después de instalar este service pack, debe agregar la siguiente subclave del registro y entrada para activar la funcionalidad de esta revisión:
Subclave:
HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\SCAPI

Entrada: indicadores
Tipo: DWORD
Valor: 0x100C02

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   03-Jun-2002  08:44  5.0.3502.5846  2,351,888  Shell32.dll 

Información de instalación de revisión

Después de aplicar este hotfix, debe agregar la siguiente subclave del registro y entrada para activar la funcionalidad de esta revisión:
Subclave:
HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\SCAPI

Entrada: indicadores
Tipo: DWORD
Valor: 0x100C02

Solución

En lugar de conectar una unidad de red (como la unidad Z:) a una ubicación de red (\\ server \ sharename), agregue la ubicación de red a Mis sitios de red. Mis sitios de red aparece en la parte inferior de Buscar (y similares) enumera. Puede expandir Mis sitios de red sin generar tráfico de red adicional.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo. Este problema se corrigió por primera vez en el Service Pack 4 de Microsoft Windows 2000.

Más información

Para obtener información adicional acerca de cómo obtener un hotfix para Windows 2000 Datacenter Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
265173El programa Datacenter y el producto servidor de Windows 2000 Datacenter
Para obtener información adicional acerca de cómo instalar varias revisiones con sólo un reinicio, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
296861Utilizar QChain.exe para instalar varias revisiones con sólo un reinicio

Propiedades

Id. de artículo: 321126 - Última revisión: jueves, 22 de febrero de 2007 - Versión: 4.6
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server SP1
  • Service Pack 3 de Microsoft Windows 2000
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Service Pack 3 de Microsoft Windows 2000
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbshell kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix KB321126 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 321126

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com