El equipo se bloquea si llama a LockWorkstation() mientras hay un protector de pantalla en ejecución

Seleccione idioma Seleccione idioma
Id. de artículo: 321343 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Síntomas

Si llama a la LockWorkstation función desde un protector de pantalla (o mientras se está ejecutando un protector de pantalla), los bloqueos de equipo como se esperaba. Sin embargo, el equipo ya no responde a la combinación de teclas CTRL + ALT + SUPR. Cuando se produce este problema, debe restablecer el equipo.

Causa

Este problema se produce porque Winlogon entra en un estado en que no se procesan secuencias clave de atención segura (SAS) de la secuencia. Seguirán ejecutando otros procesos en el equipo y el equipo continúa ser accesibles a través de la red.

Solución

Información de Service Pack

Para resolver este problema, consiga el Service Pack más reciente para Microsoft Windows 2000. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910Cómo obtener el Service Pack más reciente para Windows 2000

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.La versión en inglés de esta revisión debe tener los atributos de archivo siguientes o posteriores:
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   03-May-2002  11:46  5.0.2195.5265     42,256  Basesrv.dll
   03-May-2002  11:46  5.0.2195.5684    222,480  Gdi32.dll
   03-May-2002  11:46  5.0.2195.4928    708,880  Kernel32.dll
   25-Jun-2001  19:17  3.10.0.103        47,808  User.exe
   03-May-2002  11:46  5.0.2195.4314    402,192  User32.dll
   03-May-2002  11:46  5.0.2195.5644    369,936  Userenv.dll
   25-Apr-2002  09:16  5.0.2195.5673  1,641,968  Win32k.sys
   03-May-2002  11:31  5.0.2195.5731    178,960  Winlogon.exe
   03-May-2002  11:46  5.0.2195.4602    243,472  Winsrv.dll
   03-May-2002  11:46  5.0.2195.4928    708,880  Kernel32.dll
   03-May-2002  11:46  5.0.2195.5673  1,641,968  Win32k.sys
   03-May-2002  11:46  5.0.2195.4602    243,472  Winsrv.dll
				

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo. Este problema se corrigió por primera vez en el Service Pack 4 de Microsoft Windows 2000.

Más información

Para obtener información adicional acerca de cómo obtener un hotfix para Windows 2000 Datacenter Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
265173El programa Datacenter y el producto servidor de Windows 2000 Datacenter
Para obtener información adicional acerca de cómo instalar varias revisiones con sólo un reinicio, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
296861Utilizar QChain.exe para instalar varias revisiones con sólo un reinicio

Propiedades

Id. de artículo: 321343 - Última revisión: viernes, 07 de febrero de 2014 - Versión: 2.10
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbsecurity kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix KB321343 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 321343

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com