"Stop error code 0x0000000A" error in nt!ExpBoostOwnerThread() on Windows 2000 Server

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Article ID: 321613
This article was previously published under Q321613
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SYMPTOMS

A Windows 2000-based computer under heavy stress may stop unexpectedly with the following error message:
STOP : 0x0000000a (0x00000063, 0x0000001c, 0x00000000, 0x80415026)
This problem was initially seen with Terminal Server installations, but it may occur on any Windows 2000 Server-based computer, under stress. The first argument is typically a low address (for example, 0 + 0x63 = 0x63). The fourth argument is always an address in the nt!ExpBoostOwnerThread() function.

The error may occur about one or two times every week for a production Terminal server. In the few minutes before the computer stops unexpectedly, the computer appears to be very slow for the Terminal server users.

CAUSE

The problem occurs in the following scenario:
  1. A redirector thread tries to acquire a file control block (FCB) resource that is owned by another thread. The thread is blocked for a while.
  2. Several Terminal server users may be blocked in this way. The users report that the Terminal server is very slow.
  3. The CPU starvation avoidance mechanism is triggered to give the owner thread an opportunity to free that resource.
  4. The computer tries to increase the priority of the owner thread; however, it stops unexpectedly (0x0a) in the nt!ExpBoostOwnerThread() function because the owner thread has already exited.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time    Version        Size     File name 
  ---------------------------------------------------------- 
  05-Nov-2002  14:35   5.0.2195.6114  371,536  Mrxsmb.sys 
  05-Nov-2002  14:35   5.0.2195.6114  132,944  Rdbss.sys


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

This problem has also been reported on Windows 2000-based servers (for example, servers that are running Internet Information Services [IIS]) that have Terminal Services turned off. Although this problem does not originate with Terminal Services, it is most likely to occur when Terminal Services is turned on.

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the following article number to view the article in the Microsoft Knowledge Base:
296861 How to Install Multiple Windows Updates or Hotfixes with Only One Reboot

Properties

Article ID: 321613 - Last Review: February 24, 2012 - Revision: 5.0
Keywords: 
kbautohotfix kbhotfixserver kbqfe kboswin2000fix kbwin2ksp4fix kbbug kbfix kbwin2000presp4fix KB321613

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