Aparece el mensaje de error "Error en la escritura demorada" al escribir un archivo en un servidor desde un equipo con Windows XP o con Windows 2000

Id. de artículo: 321733 - Ver los productos a los que se aplica este artículo
Importante: este artículo contiene información sobre cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad de él y de que sabe cómo restaurarlo si ocurre algún problema. Para obtener información sobre cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986 Definición del Registro de Microsoft Windows
Aviso
El problema descrito en la sección "Síntomas" puede producirse en otras versiones de Windows y está documentado en otros artículos de Microsoft Knowledge Base. Para solucionar otros problemas similares, vea la sección "Problemas similares y soluciones".
Expandir todo | Contraer todo

En esta página

Síntomas

Mientras un cliente escribe un archivo en un servidor a través de la red, puede aparecer el siguiente mensaje de error:
{Error en la escritura demorada}
Windows no pudo guardar todos los datos del archivo x.
Se han perdido los datos.
Este error puede estar causado por una avería de hardware o por un error en la conexión de red del equipo. Intente guardar este archivo en otra ubicación.
Para determinar si el cliente experimenta el problema descrito en este artículo, revise el registro de eventos. El registro de eventos debe contener el identificador de suceso 50 con un origen MrxSMB. El suceso contiene el mismo texto que el mensaje de error pero también el estado del error en la sección de datos. Haga doble clic en el suceso y haga clic en Words para el tipo de datos; la última palabra contiene el estado. Si el código de estado es c0000022 (que significa STATUS_ACCESS_DENIED), aplique la revisión descrito en este artículo.

Causa

Este problema se produce porque el redirector del cliente no calcula la firma SMB de forma apropiada.

Nota: aplique el parche en el equipo que recibe el mensaje de error de escritura demorada, el equipo cliente.

Solución

Windows 2000

Información del Service Pack

Para resolver este problema, consiga el Service Pack más reciente para Microsoft Windows 2000. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910 Cómo obtener el Service Pack más reciente para Windows 2000

Información de la revisión

Hay disponible una revisión para la que Microsoft proporciona soporte técnico. Sin embargo, se diseñó para corregir el problema descrito en este artículo. Aplíquela solamente en los sistemas que experimenten este problema específico. Este revisión puede ser sometido a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, le recomendamos que espere al próximo Service Pack de Windows Server 2000 que contenga esta revisión.

Para resolver este problema inmediatamente, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtener la revisión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico de Microsoft, así como información acerca de los costos de soporte técnico, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Nota: en casos especiales, los costos derivados de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Se aplicarán los costos habituales de soporte a las consultas y temas de soporte técnico adicionales que no guarden relación con la actualización en cuestión.

Requisitos previos

Debe tener instalado Windows Server 2000 Service Pack 1 para poder aplicar esta revisión.

Requisito de reinicio

No es necesario reiniciar el equipo una vez aplicada esta revisión.

Información de reemplazo de la revisión

Esta revisión no sustituye a ninguna otra.

Información sobre los archivos

La versión en inglés de este revisión tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran según la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
08-may-0211:105.0.2195.5754371.344Mrxsmb.sys
04-abr-0216:475.0.2195.5535131.984Rdbss.sys

Windows XP

Información del Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Windows XP. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389 Cómo obtener el Service Pack más reciente para Windows XP

Requisitos previos

Para aplicar esta revisión, debe tener instalado Windows XP Service Pack 1.

Requisito de reinicio

No es necesario reiniciar el equipo una vez aplicada esta revisión.

Información de reemplazo de la revisión

Esta revisión no sustituye a ninguna otra.

Información sobre los archivos

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran según la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
06-mar-0314:335.1.2600.1181154.880Rdbss.sys
06-mar-0314:335.1.2600.1181401.792Mrxsmb.sys

Solución

Advertencia: la utilización incorrecta del Editor del Registro puede provocar problemas graves que hagan necesario volver a instalar el sistema operativo. Microsoft no garantiza que pueda solucionar problemas que resulten del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.
Para evitar este problema, desactive la firma SMB en el servidor.
  1. Inicie el Editor del Registro.
  2. Busque el valor enablesecuritysignature y haga clic en él en la siguiente clave del Registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Lanmanserver\Parameters
  3. En el menú Edición, haga clic en Modificar.
  4. En el cuadro Información del valor: escriba 0 y, después, haga clic en Aceptar.
  5. Salga del Editor del Registro.
  6. Detenga el servicio del servidor y reinícielo, o bien detenga y vuelva a iniciar el equipo.

Estado

Windows 2000

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en Microsoft Windows 2000 Service Pack 4.

Windows XP

Este problema se corrigió por primera vez en Windows XP Service Pack 2.

Más información

Para obtener información adicional acerca de cómo obtener una revisión para Windows 2000 Datacenter Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
265173 El programa Datacenter y el producto Windows 2000 Datacenter Server
Para obtener información adicional acerca de cómo instalar múltiples revisiones con un único reinicio, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
296861 Cómo instalar varias actualizaciones o revisiones con un único reinicio

Problemas similares y soluciones

Para obtener más información acerca de otros problemas similares y sus soluciones, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
330174 Aparece el mensaje de error "Error en la escritura demorada" cuando administra archivos en Windows XP
818788 "{Delayed Write Failed}" error message when you unplug a USB 2.0 storage device
831594 Aparece el mensaje "Error en la escritura demorada" cuando intenta guardar un archivo o salir de OneNote 2007 o de OneNote 2003
843515 Se puede restablecer la conexión de red cuando intenta realizar una operación de archivo en un equipo remoto basado en Windows Server 2003
870894 Recibe un mensaje de error "Error en la escritura demorada" en Windows XP Service Pack 2 o en Windows XP Tablet PC Edition 2005
885464 La unidad SBP-2 deja de responder cuando intenta escribir datos en Windows XP
885688 Los Id. de suceso 57, 55 y 50 se pueden registrar cuando usa Windows Cluster en Windows Server 2003
890352 Un programa puede dejar de responder, y se registran los sucesos 50 y 26, cuando el programa intenta escribir datos en un punto de montaje del volumen en un equipo con Windows Server 2003
891194 Se produce el Id. de suceso 26 cuando cierra sesión en un servidor que tiene habilitado Servicios de Terminal Server en Windows Server 2003 S891194
912593 Se registra el Id. de suceso 50, 26 ó 57 cuando utiliza HP SecurePath en un equipo que está ejecutando Windows Server 2003 Service Pack 1 o una edición x64 de Windows
925269 Aparece el mensaje de error "Error en la escritura demorada de Windows" cuando desconecta un dispositivo de almacenamiento extraíble como una tarjeta SD de un equipo con Windows XP
927912 Se graban mensajes de error y sucesos en el registro del sistema cuando intenta comprimir un archivo grande en un volumen NTFS en Windows XP, Windows 2000 o Windows Server 2003: "Error en la escritura demorada"
Si estos artículos de Microsoft Knowledge Base no le ayudan a resolver el problema, o si experimenta síntomas distintos de los que se describen en la sección "Síntomas", busque más información en Microsoft Knowledge Base. Para buscar en Microsoft Knowledge Base, siga estos pasos:
  1. Visite el siguiente sitio web de Microsoft:
    http://support.microsoft.com/spain/
  2. Escriba el texto del mensaje de error que recibió o escriba una descripción del problema en el cuadro de texto Buscar en y presione Entrar.

Propiedades

Id. de artículo: 321733 - Última revisión: miércoles, 13 de febrero de 2008 - Versión: 10.1
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Palabras clave: 
kbbug kbfix kbwin2000presp4fix kbqfe kboswin2000fix kbwin2ksp4fix kbhotfixserver kbresolve KB321733

Enviar comentarios