Windows XP ベースまたは Windows 2000 ベースのコンピュータからサーバーにファイルを書き込むときにエラー メッセージ "遅延書き込みデータの紛失" が表示される

文書翻訳 文書翻訳
文書番号: 321733 - 対象製品
この記事は、以前は次の ID で公開されていました: JP321733
Notice
「現象」で説明されている問題は他のバージョンの Windows で発生する可能性があり、またこの問題は他の「サポート技術情報」 (Microsoft Knowledge Base) 資料に記載されています。類似した問題のトラブルシューティングを行うには、「類似した問題と解決方法」を参照してください。
すべて展開する | すべて折りたたむ

目次

現象

クライアントからネットワーク経由でサーバーにファイルを書き込んでいるとき、次のエラー メッセージが表示されることがあります。
{遅延書き込みデータの紛失}
ファイル x のためのデータを一部保存できませんでした。
データを損失しました。
このエラーは、コンピュータのハードウェアまたはネットワーク接続の障害によって発生した可能性があります。このファイルをどこか別の所に保存してください。
この資料に記載されている問題が発生しているのかどうかを特定するには、イベント ログを確認します。この問題が発生している場合、イベント ログに、ソースが MrxSMB のイベント ID 50 が出力されています。このイベントには、エラー メッセージと同じテキストが含まれ、データ セクションにはエラー状態の情報も含まれています。イベントをダブルクリックし、[データ] の [ワード] をクリックします。最後のワードに状態が含まれています。状態コードが c0000022 (STATUS_ACCESS_DENIED) の場合は、この資料で説明する修正プログラムを適用してください。

原因

この問題は、クライアント リダイレクタによる SMB 署名の計算が正しくないことが原因で発生します。

: 修正プログラムは、"遅延書き込みデータの紛失" のエラー メッセージが表示されるコンピュータ、つまりクライアント コンピュータに適用します。

解決方法

Windows 2000 の場合

Service Pack の情報

この問題を解決するには、Microsoft Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法

修正プログラムの情報

マイクロソフトでは、この問題を修正する修正プログラムを提供しています。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この修正プログラムは、ここで説明する問題が発生しているシステムにのみ適用してください。

修正プログラムをダウンロードできる場合は、この「サポート技術情報」 (Microsoft Knowledge Base) の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、Microsoft Customer Service and Support にリクエストを送信し、修正プログラムを入手してください。

: 別の問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストを作成することが必要になる場合があります。特定の修正プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。Microsoft Customer Service and Support の電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
:「ダウンロード」フォームには、修正プログラムを入手できる言語が表示されます。使用している言語が表示されない場合は、その言語の修正プログラムが存在しないことになります。

必要条件

この修正プログラムを適用するには、Windows 2000 Server Service Pack 1 がインストールされている必要があります。

再起動の必要性

この修正プログラムの適用後、コンピュータを再起動する必要はありません。

修正プログラムの置き換えに関する情報

この修正プログラムを適用しても、他の修正プログラムが置き換えられることはありません。

ファイル情報

修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。これらのファイルの日付と時刻は世界協定時刻 (UTC) で表示されます。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
日付           時刻    バージョン           サイズ     ファイル名
   ------------------------------------------------------
08-May-2002  11:10  5.0.2195.5754  371,344  Mrxsmb.sys
04-Apr-2002  16:47  5.0.2195.5535  131,984  Rdbss.sys
				

Windows XP

Service Pack の情報

この問題を解決するには、Windows XP の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322389 最新の Windows XP Service Pack を入手する方法

必要条件

この修正プログラムを適用するには、Windows XP Service Pack 1 がインストールされている必要があります。

再起動の必要性

この修正プログラムの適用後、コンピュータを再起動する必要はありません。

修正プログラムの置き換えに関する情報

この修正プログラムを適用しても、他の修正プログラムが置き換えられることはありません。

ファイル情報

修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。これらのファイルの日付と時刻は世界協定時刻 (UTC) で表示されます。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
日付         時刻   バージョン        サイズ     ファイル名 ------------------------------------------------------ 06-Mar-2003  14:33  5.1.2600.1181  154,880  Rdbss.sys 06-Mar-2003  14:33  5.1.2600.1181  401,792  Mrxsmb.sys

回避策

重要 : このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを変更する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしてください。問題が発生した場合でも、レジストリを復元できます。レジストリのバックアップ方法および復元方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法

この問題を回避するには、サーバーで SMB 署名を無効にします。
  1. レジストリ エディタを起動します。
  2. レジストリで、以下のキーにある enablesecuritysignature という値を見つけてクリックします。
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Lanmanserver\Parameters
  3. [編集] メニューの [修正] または [変更] をクリックします。
  4. [値のデータ] ボックスに「0」と入力し、[OK] をクリックします。
  5. レジストリ エディタを終了します。
  6. サービスをいったん停止して再度開始するか、コンピュータを再起動します。

状況

Windows 2000

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。 この問題は、Microsoft Windows 2000 Service Pack 4 で修正済みです。

Windows XP

この問題は、Windows XP Service Pack 2 で修正済みです。

詳細

Windows 2000 Datacenter Server 用の修正プログラムの入手方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
265173 Windows Datacenter プログラムおよび Windows 2000 Datacenter Server
複数の修正プログラムのインストールを 1 回の再起動のみで行う方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
296861 複数の Windows 更新プログラムまたは修正プログラムを同時にインストールし、再起動を 1 回で済ませる方法

類似した問題と解決方法

類似した問題とその解決方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
330174 Windows XP でファイルを管理時のエラー メッセージ "遅延書き込みデータの紛失"
818788 USB 2.0 記憶装置を取り外すとエラー メッセージ "{遅延書き込みデータの紛失}" が表示される (英語)
831594 ファイルの保存時または OneNote 2003 の終了時に "遅延書き込みデータの紛失" エラー メッセージが表示される
843515 Windows Server 2003 ベースのリモート コンピュータでファイル操作を実行しようとするとネットワーク接続がリセットされることがある (英語)
870894 Windows XP Service Pack 2 または Windows XP Tablet PC Edition 2005 で "遅延書き込みデータの紛失" というエラー メッセージが表示される
885464 Windows XP でデータの書き込み時に SBP-2 ドライブが応答を停止する (英語)
885688 Windows Server 2003 で Windows クラスタを使用するとイベント ID 57、イベント ID 55 およびイベント ID 50 が出力されることがある
890352 Windows Server 2003 ベースのコンピュータで、プログラムを使用してボリューム マウント ポイントにデータを書き込もうとすると、プログラムが応答を停止することがあり、イベント 50 およびイベント 26 が記録される (英語)
891194 イベント ID: 26 が Windows Server 2003 SP1 で有効になっている Terminal Server を搭載したサーバーからログオフするときに発生しました。
912593 Windows Server 2003 Service Pack 1 または x64 エディションの Windows を実行しているコンピュータで HP SecurePath を使用すると、イベント ID 50、26、または 57 がログに出力される (英語)
925269 SD カードなどのリムーバブル ストレージ デバイス、Windows XP ベースのコンピュータから切断すると、エラー メッセージ:"Windows 遅延書き込みデータの紛失"
927912 Windows XP、Windows 2000、または Windows Server 2003 の NTFS ボリューム上で大きなファイルを圧縮しようとすると、エラー メッセージ "遅延書き込みデータの紛失" が表示され、システム ログに記録される
上記の「サポート技術情報」 (Microsoft Knowledge Base) で問題が解決しなかった場合、または、「現象」に記載されている現象とは異なる現象が発生する場合は、詳細について「サポート技術情報」 (Microsoft Knowledge Base) を検索してください。「サポート技術情報」 (Microsoft Knowledge Base) で検索を実行するには、次の手順を実行します。
  1. 次のマイクロソフト Web サイトにアクセスします。
    http://support.microsoft.com
  2. テキスト ボックスに、表示されるエラー メッセージを入力するか、問題の詳細を入力し、[検索] ボタンをクリックします。

プロパティ

文書番号: 321733 - 最終更新日: 2008年9月18日 - リビジョン: 10.3
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server
キーワード:?
kbautohotfix kbresolve kbhotfixserver kbqfe kbwin2ksp4fix kboswin2000fix kbbug kbfix kbwin2000presp4fix KB321733
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com