Um perfil de utilizador itinerante não a enviar com êxito e evento ID 1000 é registado no registo de aplicações no Windows 2000

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Sintomas

Quando um cliente termina de um servidor baseado no Microsoft Windows 2000, um perfil de utilizador guardado no servidor não pode enviar com êxito e eventos 1000 poderão ser registado no registo de aplicações. Quando visualiza o registo utilizando o Visualizador de eventos, poderá ver um evento semelhante ao seguinte:

Origem: Userenv
Categoria: nenhum
Tipo: erro
ID do evento: 1000

Windows não consegue copiar ficheiro C:\Documents and Settings\TestUser\Favorites\Travel Planning\Traffic.url para \\PROFILESERVER\Userdata\TestUser\Profile\Favorites\Travel Planning\Traffic.url de localização. Contacte o administrador da rede. DETALHE - O processo não é possível aceder ao ficheiro porque está a ser utilizado por outro processo.

Se tiver activado o registo USERENV, quando este problema ocorre, texto semelhante à seguinte é registado no registo USERENV:
USERENV(9010.8bc8) 13:16:22:346 ReconcileFile: Falha ao mudar o nome de ficheiro < \\PROFILESERVER\Userdata\TestUser\Profile\Favorites\Travel Planning\prf146.tmp > para < \\PROFILESERVER\Userdata\TestUser\Profile\Favorites\Travel Planning\Traffic.url > com o erro = 32

Causa

Este problema ocorre porque quando o sistema de gestão de memória tenta mudar o nome do ficheiro temporário no perfil de servidor ao respectivo nome pretendido, ocorre uma violação de partilha.

Para Colocação em cache e aumentar o desempenho, o sistema operativo poderá temporariamente manter secções de memória que descrevem um ficheiro. O redireccionador não envia uma operação de fecho para o servidor de destino até secções de memória que descrevem o ficheiro estão fechadas. Neste cenário, uma operação de mudança de nome é emitida para um ficheiro enquanto o sistema operativo ainda em cache objectos de secção para o ficheiro. Uma vez que a operação de fecho ainda não foi enviada, o ficheiro está ainda em utilização e ocorre uma violação de partilha.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentada, submeta um pedido para o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisito de reinício

Tem de reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time     Version        Size      File name
   ---------------------------------------------------------
   09-Apr-2004  18:05   5.0.2195.6923   408,752   Mrxsmb.sys
   09-Apr-2004  18:05   5.0.2195.6923   169,936   Rdbss.sys
Depois de aplica esta correcção, quando ocorre o cenário descrito na secção "Causa", o redireccionador forçosamente fecha todas as secções de memória que descrevem o ficheiro de problema e, em seguida, repete a operação. No entanto, uma correcção relacionada abrange o caso em que uma secção de memória nunca é fechada devido uma combinação única de recursos de baixo. Por conseguinte, para resolver esta causa possível do problema, também se aplicam a correcção descrita no seguinte artigo da base de dados de conhecimento da Microsoft:
839919Um início de sessão deixa de responder no Windows Server 2000

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Por vezes, o servidor de ficheiro de destino mostra que o perfil de ainda ser utilizado até que o servidor de terminais é reiniciado. Pode verificar se é este o caso, escrevendo o seguinte comando numa linha de comandos:
net files
A correcção descrita na secção "Resolução" endereços de violação de partilha é mencionada na secção "Causa". No entanto, existem muitas outras causas de erros de envio/transferência de perfil itinerante. Para obter informações adicionais sobre o processo de cópia do perfil e sobre os problemas que poderão ocorrer quando os perfis são copiados, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
328607Perfil guardado no servidor acumula ficheiros .tmp extra

Referências



Para obter informações adicionais sobre o novo esquema de atribuição de nomes ficheiro for Microsoft Windows software update packages, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
816915Novo esquema de atribuição de nomes de ficheiro para pacotes de actualização de software do Microsoft Windows do
Para obter informações adicionais sobre a terminologia utilizada neste artigo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Propriedades

Artigo: 321936 - Última revisão: 13 de fevereiro de 2014 - Revisão: 4.8
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbwin2000presp5fix kbbug kbfix KB321936 KbMtpt
Tradução automática
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