Um perfil de usuário móvel não carrega com êxito e identificação de evento 1000 é registrada no log do aplicativo no Windows 2000

Traduções deste artigo Traduções deste artigo
ID do artigo: 321936 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando um cliente efetua logoff de um servidor baseado no Microsoft Windows 2000, um perfil de usuário móvel não pode carregar com êxito e evento 1000 pode ser registrado no log do aplicativo. Quando você exibir o log usando Visualizar eventos, você poderá ver um evento que é semelhante à seguinte:

Fonte: Userenv
Categoria: nenhum
Tipo: erro
IDENTIFICAÇÃO de evento: 1000

O Windows não pode copiar o arquivo C:\Documents and Settings\TestUser\Favorites\Travel Planning\Traffic.url para \\PROFILESERVER\Userdata\TestUser\Profile\Favorites\Travel Planning\Traffic.url local. Contate o administrador da rede. DETALHE - O processo não é possível acessar o arquivo porque ele está sendo usado por outro processo.

Se você tiver ativado o log de Userenv, quando esse problema ocorre, o texto que é semelhante à seguinte é registrado no log Userenv:
USERENV(9010.8bc8) 13:16:22:346 ReconcileFile: Falha ao renomear arquivo < \\PROFILESERVER\Userdata\TestUser\Profile\Favorites\Travel Planning\prf146.tmp > para < \\PROFILESERVER\Userdata\TestUser\Profile\Favorites\Travel Planning\Traffic.url > com erro = 32

Causa

Esse problema ocorre porque quando o sistema de gerenciamento de memória tenta renomear o arquivo temporário no servidor de perfil para seu nome pretendido, ocorre uma violação de compartilhamento.

Para armazenamento em cache e melhorar o desempenho, o sistema operacional pode temporariamente manter seções de memória que descrevem um arquivo. O redirecionador não envia uma operação de fechamento para o servidor de destino até que seções de memória que descrevem o arquivo estiverem fechadas. Nesse cenário, uma operação de renomeação é emitida em relação a um arquivo enquanto o sistema operacional ainda é cache de objetos de seção para o arquivo. Como a operação de fechamento ainda não foi enviada, o arquivo ainda está em uso e ocorre uma violação de compartilhamento.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibido, envie uma solicitação para suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time     Version        Size      File name
   ---------------------------------------------------------
   09-Apr-2004  18:05   5.0.2195.6923   408,752   Mrxsmb.sys
   09-Apr-2004  18:05   5.0.2195.6923   169,936   Rdbss.sys
Depois que esse hotfix é aplicado, quando ocorre o cenário descrito na seção "Causa", o redirecionador forçosamente fecha todas as seções de memória que descrevem o arquivo com problema e, em seguida, repete a operação. No entanto, um hotfix relacionado aborda o caso em que uma seção de memória é fechada nunca por causa de uma combinação exclusiva de recursos de pool baixa. Portanto, para resolver esse possível causa do problema, também aplicar o hotfix descrito no seguinte artigo da Base de dados de Conhecimento Microsoft:
839919Um logon pára de responder no Windows Server 2000

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Às vezes, o servidor de arquivo de destino mostra que o perfil ainda em uso até que o Terminal server é reiniciado. Você pode verificar se é esse o caso, digitando o seguinte comando em um prompt de comando:
NET files
O hotfix descrito na seção "Resolução" aborda a violação de compartilhamento mencionado na seção "Causa". No entanto, há muitas outras causas de erros de carregamento/download do perfil móvel. Para obter informações adicionais sobre o processo de cópia de perfil e sobre os problemas que podem ocorrer quando os perfis são copiados, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
328607Perfil móvel acumula arquivos .tmp extras

Referências



Para obter informações adicionais sobre o novo arquivo de esquema para nomeação pacotes de atualização de software do Microsoft Windows para, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
816915Novo esquema de nomeação de arquivo para pacotes de atualização de software do Microsoft Windows
Para obter informações adicionais sobre a terminologia usada neste artigo, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 321936 - Última revisão: quinta-feira, 24 de outubro de 2013 - Revisão: 4.8
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbwin2000presp5fix kbbug kbfix KB321936 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 321936

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com