Entfernen des Clients für Microsoft-Netzwerke hat Entfernung anderer Dienste zur Folge

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Artikel-ID: 322267 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
322267 Removing Client for Microsoft Networks Removes Other Services
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986 Beschreibung der Microsoft Windows-Registrierung
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Wenn Sie den Client für Microsoft-Netzwerke als Fehlerbehebungsmaßnahme oder versehentlich entfernen und die Komponente anschließend neu installieren, treten unter Umständen die folgenden Symptome auf:
  • Sie können sich nicht über das Netzwerk anmelden. Vorgänge, die Active Directory benötigen, lösen folgende Fehlermeldung aus:
    Es konnten aufgrund des folgenden Problems keine Namensinformationen gefunden werden:
    Der Arbeitsstationstreiber ist nicht installiert.
    Wenden Sie sich an den Systemadministrator, um sicher zu stellen, dass Ihre Domäne richtig konfiguriert und online ist.
  • Im Ereignisprotokoll der Verzeichnisdienste werden folgende Einträge angezeigt:
    Ereignis 1168
    Quelle: NTDS General
    Kategorie: Interne Verarbeitung
    Beschreibung:
    Es ist der Fehler 1747(6d3) aufgetreten (Interne ID 3160242). Wenden Sie sich an Microsoft Product Support Services.

    Ereignis 1126
    Quelle: NTDS General
    Kategorie: Globaler Katalog
    Beschreibung:
    Die Verbindung mit dem globalen Katalog konnte nicht erstellt werden.
  • Falls Sie den Client für Microsoft-Netzwerke nicht erneut installiert haben, wird möglicherweise folgender Eintrag im Systemereignisprotokoll angezeigt:
    Ereignis 7003
    Quelle: Dienststeuerungs-Manager
    Kategorie: Keine
    Beschreibung:
    <Fehlgeschlagener Dienst> ist von folgendem, nicht vorhandenen Dienst abhängig: <Dienstname>
    Dabei kann der <Fehlgeschlagene Dienst> und <Dienstname> je nach spezifischem Ereignis und den installierten Diensten variieren. Möglicherweise sind mehrere Ereignis-IDs 7003 aufgeführt.

  • Wegen RPC-Problemen werden viele Ereignis-IDs 1003, 2003, 13528 und weitere leistungsrelevante Ereignisse im Ereignisprotokoll der Anwendung aufgezeichnet.

Ursache

Bei der Komponente "Client für Microsoft-Netzwerke" handelt es sich eigentlich um einen Arbeitsstationsdienst. Wenn Sie diesen Dienst entfernen, werden die Dienste "Netlogon" und "RPC-Locater" ebenfalls entfernt. Bei der erneuten Installation der Komponente "Client für Microsoft-Netzwerke" werden die Dienste "Netlogon" und "RPC-Locater" ebenfalls erneut installiert, aber der Netlogon-Dienst ist nicht so konfiguriert, dass er beim Starten des Computers vom Serverdienst abhängig ist.

Lösung

Warnung: Die unkorrekte Verwendung des Registrierungs-Editors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungs-Editors herrühren, behoben werden können. Benutzen Sie den Registrierungs-Editor auf eigene Verantwortung.

  1. Falls Sie die Komponente "Client für Microsoft-Netzwerke" nicht erneut installiert haben, gehen Sie folgendermaßen vor:
    1. In SBS 2000 klicken Sie auf dem Desktop mit der rechten Maustaste auf Netzwerkumgebung, und klicken Sie dann auf Eigenschaften. In SBS 2003 öffnen Sie die Systemsteuerung und doppelklicken dann auf Netzwerkverbindungen.
    2. Klicken Sie mit der rechten Maustaste auf die interne Netzwerkverbindung, und klicken Sie auf Eigenschaften.
    3. Klicken Sie auf Installieren, auf Client und dann auf Hinzufügen.
    4. Klicken Sie auf Client für Microsoft-Netzwerke und anschließend auf OK.
    5. Klicken Sie in allen Dialogfeldern auf OK, bis alle Netzwerkeigenschaften geschlossen sind. Starten Sie anschließend den Small Business Server (SBS) 2000-Server neu.
  2. Melden Sie sich bei dem Computer an. Ignorieren Sie mögliche Warnungen, dass Dienste nicht gestartet werden können. Schließen Sie das Programm "Dienste".
  3. Stellen Sie sicher, dass der Starttyp für den RPC Locator-Dienst auf Automatisch eingestellt ist. Starten Sie dann den Dienst.
  4. Stellen Sie sicher, dass der Starttyp für den Netlogon-Dienst auf Automatisch eingestellt ist. Starten Sie den Netlogon-Dienst aber noch nicht.
  5. Konfigurieren Sie den Netlogon-Dienst so, dass er vom Server-Dienst abhängig ist.
    1. Starten Sie den Registrierungs-Editor ("Regedt32.exe").
    2. Klicken Sie unter folgendem Registrierungsschlüssel auf den Wert DependOnService:
      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon
    3. Klicken Sie im Menü Bearbeiten auf Mehrteilige Zeichenfolgen, geben Sie LanmanServer in einer eigenen Zeile ein, und klicken Sie dann auf OK.
    4. Beenden Sie den Registrierungs-Editor.
  6. Starten Sie im Dienstprogramm "Dienste" den Netlogon-Dienst.
  7. Vergewissern Sie sich, dass Sie Active Directory verwenden können, indem Sie über ein Programm wie Active Directory-Benutzer und -Computer Active Directory-Einstellungen anzeigen oder modifizieren.
  8. Starten Sie den Server neu.
  9. Wenn der Server sehr lange für den Neustart braucht oder Sie Warnungen erhalten, dass Dienste nicht gestartet werden können, verwenden Sie das Programm "Dienste" und vergewissern Sie sich, dass der Netlogon-Dienst auf Automatisch eingestellt ist und gestartet wurde. Sie müssen den Starttyp eventuell zweimal einstellen.

Status

Es handelt sich hierbei um ein beabsichtigtes Verhalten.

Eigenschaften

Artikel-ID: 322267 - Geändert am: Montag, 25. Februar 2008 - Version: 1.6
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Small Business Server 2000 Standard Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
Keywords: 
kbenv kbnetwork kbprb KB322267
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