Logical Disk Partitions Are Lost or Damaged After You Upgrade from Windows NT 4.0 to Windows 2000

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Article ID: 323231 - View products that this article applies to.
This article was previously published under Q323231
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SYMPTOMS

When you use Windows 2000 Disk Management to try to create or delete a logical drive in an extended partition after you upgrade from Microsoft Windows NT 4.0 to Windows 2000, you may receive the following error message:
The Server Threw an Exception
After you receive this error message, logical disk partitions on the extended partition may be lost or damaged. This problem only occurs if one of the following conditions exists:
  • Drive translation is turned off in the controller BIOS.
  • The drive is moved to a position on the controller (typically upper SCSI IDs) where drive translation is not performed. Note that on some computers or controllers, drive translation options are not available.

CAUSE

This problem may occur because Windows 2000 does drive translation differently than Windows NT 4.0. Windows 2000 typically obtains disk geometry information for SCSI disks from the BIOS of the SCSI adapter for the disk. If the SCSI adapter BIOS is not turned on, Windows 2000 cannot obtain geometry information in this way and assumes that there are 255 heads and 63 sectors for each track.

Windows NT 4.0 performs the same kind of computation when geometry information is not available, but uses smaller default values for the number of heads (64) and sectors for each track (32).

The differences in disk geometry causes problems because Disk Management must modify several partition tables when it adds and removes logical drives.

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size      File name
   --------------------------------------------------------
   Jul-25-2002  13:33  5.0.2195.5912  34,384    Claspnp.sys
   Jul-30-2002  14:26  5.0.2195.5986  30,288    Disk.sys
				
Apply this hotfix before you add or delete logical drives on the Windows 2000-based computer.


NOTE: To help recover the missing or damaged partition tables, you must contact Microsoft Product Support Services (PSS). For information about how to contact PSS, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=supportquestion.asp

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:
296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot

Properties

Article ID: 323231 - Last Review: February 27, 2014 - Revision: 3.9
APPLIES TO
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbsysadmin kbwin2ksp4fix kbbug kbenv kbfix kbui kbwin2000presp4fix KB323231

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