I download di file con Internet Explorer su una connessione SSL non funzionano con le intestazioni di controllo della cache

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Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986 Descrizione del Registro di sistema di Microsoft Windows
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Sintomi

Quando si tenta di aprire un documento di Microsoft Office o un file PDF digitando l'URL HTTPS relativo al documento nella barra degli indirizzi di Internet Explorer 6 Service Pack 1 (SP1), potrebbe essere visualizzato un messaggio di errore analogo al seguente:
Impossibile effettuare il download.

Impossibile aprire il sito Internet. Sito non disponibile o non trovato. Riprovare.

Cause

Questo problema si verifica se il server invia un'intestazione "Cache-control:no-store" o "Cache-control:no-cache".

Risoluzione

Avviso L'errato utilizzo dell'editor del Registro di sistema può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. I rischi correlati all'utilizzo dell'editor del Registro di sistema sono di esclusiva responsabilità dell'utente.

Importante Poiché tutti i pacchetti di installazione degli aggiornamenti rapidi (hotfix) utilizzano lo stesso programma di installazione (Q323308.exe), assicurarsi che l'aggiornamento rapido (hotfix) corrisponda esattamente alla versione di Internet Explorer in uso.

Internet Explorer 5.01

È disponibile un aggiornamento rapido (hotfix) supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo aggiornamento rapido (hotfix) vengano eseguiti ulteriori test. Se pertanto questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva del service pack di Windows 2000 contenente tale aggiornamento rapido.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'aggiornamento rapido (hotfix). Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data        Ora    Versione      Dimensione  Nome file
   --------------------------------------------------------
   06/06/2002  15.43  5.0.3506.600  461.072     Wininet.dll
				
Per ignorare l'istruzione "no-cache" per Internet Explorer 5.01, attenersi alla procedura seguente:
  1. Avviare l'editor del Registro di sistema.
  2. Per ogni utente, individuare la seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    Per ogni computer, individuare la seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  3. Scegliere Aggiungi valore dal menu Modifica e aggiungere i seguenti valori:
    "BypassSSLNoCacheCheck"=Dword:00000001
  4. Chiudere l'editor del Registro di sistema.

Internet Explorer 5.5

È disponibile un aggiornamento rapido (hotfix) supportato da Microsoft, che è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico. È possibile che su questo aggiornamento rapido (hotfix) vengano eseguiti ulteriori test. Se il problema in questione non costituisce una seria minaccia per il sistema, si consiglia pertanto di attendere il rilascio del prossimo service pack di Internet Explorer 5.5 contenente l'aggiornamento rapido.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'aggiornamento rapido (hotfix). Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data            Ora    Versione Dimensione  Nome file
   -------------------------------------------------------
   06/06/2002  13:42  5.50.4918.600     481,040  Wininet.dll
				
Per ignorare l'istruzione "no-cache" per Internet Explorer 5.5 SP2, attenersi alla procedura seguente:
  1. Avviare l'editor del Registro di sistema.
  2. Per ogni utente, individuare la seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    Per ogni computer, individuare la seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  3. Scegliere Aggiungi valore dal menu Modifica e aggiungere i seguenti valori:
    "BypassSSLNoCacheCheck"=Dword:00000001
  4. Chiudere l'editor del Registro di sistema.

Internet Explorer 6

È disponibile un aggiornamento rapido (hotfix) supportato da Microsoft, destinato esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico.

Per risolvere il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'aggiornamento rapido (hotfix). Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data            Ora    Versione Dimensione  Nome file
   -------------------------------------------------------
   28/05/2002  13.32  6.0.2717.2800  583.168  Wininet.dll
				
Per ignorare l'istruzione "no-cache" per Internet Explorer 5.5 SP2, attenersi alla procedura seguente:
  1. Avviare l'editor del Registro di sistema.
  2. Per ogni utente, individuare la seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    Per ogni computer, individuare la seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  3. Scegliere Aggiungi valore dal menu Modifica e aggiungere i seguenti valori:
    "BypassSSLNoCacheCheck"=Dword:00000001
  4. Chiudere l'editor del Registro di sistema.

Internet Explorer 6 SP1

È disponibile un aggiornamento rapido (hotfix) supportato da Microsoft, destinato esclusivamente alla correzione del problema descritto in questo articolo. Utilizzarlo solo nei sistemi in cui si verifica questo problema specifico.

Per risolvere il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere l'aggiornamento rapido (hotfix). Per un elenco completo di numeri di telefono del Servizio Supporto Tecnico Clienti Microsoft e per informazioni sui costi dell'assistenza, visitare il sito Web Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
Nota In casi particolari, le spese normalmente addebitate per le chiamate al Servizio Supporto Tecnico Clienti Microsoft potrebbero essere annullate qualora un addetto del Servizio Supporto Tecnico Clienti Microsoft dovesse determinare che uno specifico aggiornamento risolverà il problema. I normali costi del Servizio Supporto Tecnico Clienti Microsoft verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico aggiornamento in questione.

La versione in lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file elencati nella tabella seguente (o attributi successivi). Date e ore elencate di seguito sono espresse in UTC. Quando si visualizzano le informazioni sul file, l'ora viene convertita in ora locale. Per calcolare la differenza tra l'ora UTC e quella locale, utilizzare la scheda Fuso orario dello strumento Data e ora del Pannello di controllo.
   Data            Ora    Versione Dimensione  Nome file
   -------------------------------------------------------
   23/09/2002  14.50  6.0.2800.1121  588.288  Wininet.dll
				
Per ignorare l'istruzione "no-cache" per Internet Explorer 6 SP1, attenersi alla procedura seguente:
  1. Avviare l'editor del Registro di sistema.
  2. Per ogni utente, individuare la seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    Per ogni computer, individuare la seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  3. Scegliere Aggiungi valore dal menu Modifica e aggiungere i seguenti valori:
    "SSLPragmaNoCache"=Dword:00000001
  4. Chiudere l'editor del Registro di sistema.
Per ignorare l'istruzione "no-cache" per Internet Explorer 6 SP1 dopo aver installato MS04-004, attenersi alla procedura seguente:
  1. Avviare l'editor del Registro di sistema.
  2. Per ogni utente, individuare la seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
    Per ogni computer, individuare la seguente chiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings
  3. Scegliere Aggiungi valore dal menu Modifica.
  4. Per ignorare l'istruzione per le connessioni HTTPS, aggiungere il seguente valore:
    "BypassSSLNoCacheCheck"=Dword:00000001
    Per ignorare l'istruzione per le connessioni HTTP, aggiungere il seguente valore:
    "BypassHTTPNoCacheCheck"=Dword:00000001
  5. Chiudere l'editor del Registro di sistema.

Workaround

Per ovviare a questo problema, utilizzare un riferimento ipertestuale (HREF) per caricare il documento.

Nota Questa soluzione funziona solo se il server utilizza l'intestazione "cache-control:no-store".

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati nella sezione "Si applica a" del presente articolo.
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
815313 INFO: Come impedire la memorizzazione temporanea nella cache quando si scaricano documenti attivi su connessioni SSL

Proprietà

Identificativo articolo: 323308 - Ultima modifica: venerdì 31 marzo 2006 - Revisione: 10.12
Le informazioni in questo articolo si applicano a
  • Microsoft Internet Explorer 6.0 alle seguenti piattaforme
    • Microsoft Windows XP Professional
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows NT 4.0
    • Microsoft Windows 98 Second Edition
  • Microsoft Internet Explorer 5.5 alle seguenti piattaforme
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows NT 4.0
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
  • Microsoft Internet Explorer 5.01 Service Pack 1 alle seguenti piattaforme
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows NT 4.0
    • Microsoft Windows 98 Second Edition
  • Microsoft Internet Explorer 5.01 Service Pack 2 alle seguenti piattaforme
    • Microsoft Windows 2000 Standard Edition
    • Microsoft Windows NT 4.0
    • Microsoft Windows 98 Second Edition
Chiavi: 
kberrmsg kbbug kbfix kbie600presp2fix kbqfe kbenv kbie600sp1fix kbie550presp3fix kbhotfixserver KB323308
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