Chybová zpráva "" Šifrování dat"součást protokolu RDP zjistila chybu..."

Překlady článku Překlady článku
ID článku: 323497 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Po instalaci systému Windows 2000 Security Rollup Package 1 (SRP1), nemusí být možné připojit se k terminálu klienty služby Terminal Services Server služby. Tento problém může nastat také při použití vzdáleného Webové připojení ke ploše v počítači se systémem Windows XP Professional se připojit k Server Terminálové služby. Dojde-li k tomuto problému, je zaznamenána událost s ID 50 v Protokol událostí systému:
Typ události: Chyba
Událost Zdroj: TermDD
ID události: 50
Popis:
Protokol RDP "Šifrování" zjistila chybu v protokolu a má odpojení klienta.
Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
307454MS01-052: Neplatná data protokolu RDP mohou způsobit selhání Terminálové služby
Klient Terminálové služby se mohou zobrazit také chybová zpráva při pokusu o připojení:
Na Terminálový Server ukončil připojení.

Příčina

Možný spor mezi Icaapi.dll a Rdpwsx.dll dynamických knihoven (DLL) může způsobit, že soukromý klíč certifikátu na Terminálové služby serveru nejsou synchronizovány.

Řešení

Chcete-li nám můžete opravit tento problém, přejděte "Oprava"oddíl. Pokud dáváte přednost tyto potíže vyřešit sami, přejděte "Opravit sám"oddíl.

Oprava



Chcete-li tento problém vyřešit automaticky, klepněteOpravatlačítko nebo odkaz. VStažení souboruDialogové okno, klepněte na tlačítkoSpustita potom postupujte podle pokynů v opravě, průvodce.


Tento problém odstranit
Microsoft Fix it 50643


Poznámky
  • Tento průvodce může být pouze v angličtině. Automatická oprava však také pracuje pro ostatní jazykové verze systému Windows.
  • Pokud nejste v počítači, který má daný problém, uložit oprava je řešení na jednotku USB flash nebo disk CD a spusťte jej v počítači, který má potíže.

Přejděte "To byl vyřešen?"oddíl.



Opravit sám

DůležitéTento oddíl, metoda nebo úkol obsahuje kroky, které informace o úpravě registru. Však mohou nastat závažné problémy při nesprávných úpravách registru. Proto se ujistěte, opatrně postupujte takto. Pro zvýšení ochrany před úpravami je nutné zálohujte registr. Můžete pak obnovení registru v případě, že dojde k potížím. Další informace o zálohování a obnovení registru získáte článku znalostní báze Microsoft Knowledge Base:
322756Postup při zálohování a obnovení registru v systému Windows

Chcete-li tento problém vyřešit, postupujte takto:
  1. Spusťte Editor registru.
  2. Vyhledejte a klepněte na následující podklíč registru:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TermService\Parameters
  3. V tomto podklíči registru odstraňte následující hodnoty:
    • Certifikát
    • Certifikát x 509
    • X 509 Certificate ID
  4. Ukončete Editor registru a restartujte Server.

To byl vyřešen?

  • Zkontrolujte, zda je problém vyřešen. Pokud je problém vyřešen, jste hotovi s tímto oddílem. Pokud problém nebyl vyřešen, můžeteObraťte se na podporu.
  • Uvítáme vaše názory. Sdělit svůj názor nebo nahlásit potíže s tímto řešením, uveďte poznámky v "Oprava"blogu nebo nám odešletee-mailuzpráva.

Prohlášení

Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro".

Vlastnosti

ID článku: 323497 - Poslední aktualizace: 28. března 2011 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
Klíčová slova: 
kbenv kbprb kbfixme kbmsifixme kbmt KB323497 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:323497

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com