Komunikat o błędzie „Składnik protokołu RDP SZYFROWANIE DANYCH wykrył błąd”

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 323497 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
WAŻNE: Ten artykuł zawiera informacje na temat modyfikowania rejestru. Przed zmodyfikowaniem rejestru utwórz jego kopię zapasową i upewnij się, że wiesz, jak przywrócić rejestr w przypadku pojawienia się problemu. Aby uzyskać informacje dotyczące wykonywania kopii zapasowej, przywracania i edytowania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
256986 Opis Rejestru systemu Microsoft Windows
Rozwiń wszystko | Zwiń wszystko

Symptomy

Po zainstalowaniu pakietu zbiorczego aktualizacji zabezpieczeń dla systemu Windows 2000 (SRP1) klienci usług terminalowych nie mogą połączyć się z serwerem usług terminalowych. Ten problem może również występować wówczas, gdy Podłączanie pulpitu zdalnego w sieci Web na komputerze z systemem Windows XP Professional jest używane do ustanowienia połączenia z serwerem usług terminalowych. Jeżeli ten problem wystąpi, w dzienniku zdarzeń systemowych rejestrowane jest zdarzenie o identyfikatorze 50:
Typ zdarzenia: Błąd
Źródło zdarzenia: TermDD
Identyfikator zdarzenia: 50
Opis:
Składnik protokołu RDP „SZYFROWANIE DANYCH” wykrył błąd w strumieniu protokołu i rozłączył klienta.
Aby uzyskać dodatkowe informacje, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
307454 MS01-052: Nieprawidłowe dane połączenia RDP mogą spowodować awarię usług terminalowych
Na komputerze klienckim usług terminalowych może zostać również wyświetlony następujący komunikat o błędzie podczas próby ustanowienia połączenia:
Serwer terminali zakończył połączenie.

Przyczyna

Możliwość wystąpienia wyścigu między bibliotekami dołączanymi dynamicznie (DLL) Icaapi.dll i Rdpwsx.dll może stać się przyczyną niezsynchronizowania klucza certyfikatu prywatnego na serwerze usług terminalowych.

Rozwiązanie

OSTRZEŻENIE: Nieprawidłowe korzystanie z Edytora rejestru może stać się przyczyną poważnych problemów, które spowodują, że konieczna będzie ponowna instalacja systemu operacyjnego. Firma Microsoft nie może zagwarantować, że rozwiązanie problemów spowodowanych niepoprawnym użyciem Edytora rejestru będzie możliwe. Możesz używać Edytora rejestru na własną odpowiedzialność.

Aby rozwiązać ten problem, wykonaj następujące kroki:
  1. Uruchom Edytor rejestru.
  2. Zlokalizuj, a następnie kliknij następujący podklucz rejestru:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TermService\Parameters
  3. W tym podkluczu rejestru usuń następujące wartości:
    • Certificate
    • X509 Certificate
    • X509 Certificate ID
  4. Zamknij Edytor Rejestru, a następnie ponownie uruchom serwer.

Stan

Firma Microsoft potwierdziła, że jest to usterka występująca w produktach firmy Microsoft wymienionych w sekcji „Informacje zawarte w tym artykule dotyczą”.

Właściwości

Numer ID artykułu: 323497 - Ostatnia weryfikacja: 19 września 2005 - Weryfikacja: 6.1
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
Słowa kluczowe: 
kbenv kbprb KB323497

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com