ข้อความแสดงข้อผิดพลาด "คอมโพเนนต์ของโพรโทคอล RDP "เข้ารหัสลับข้อมูล"ตรวจพบข้อผิดพลาด..."

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 323497 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

หลังจากที่คุณติดตั้ง Windows 2000 ความปลอดภัย Rollup 1 แพคเกจ (SRP1), ไคลเอ็นต์บริการเทอร์มินัลอาจไม่สามารถเชื่อมต่อกับเทอร์มินัล บริการเซิร์ฟเวอร์ คุณอาจพบปัญหานี้เมื่อคุณใช้รีโมท เดสก์ท็อปเดสก์ท็อปเว็บบนคอมพิวเตอร์ที่ใช้ Windows XP Professional เพื่อเชื่อมต่อไปยัง เซิร์ฟเวอร์บริการเทอร์มินัล เมื่อปัญหานี้เกิดขึ้น รหัสเหตุการณ์ 50 ถูกบันทึกใน บันทึกเหตุการณ์ของระบบ:
ชนิดเหตุการณ์: ข้อผิดพลาด
เหตุการณ์ แหล่งที่มา: TermDD
รหัสเหตุการณ์: 50
คำอธิบาย:
โพรโทคอล RDP คอมโพเนนต์ "เข้ารหัสลับข้อมูล" ตรวจพบข้อผิดพลาดในกระแสข้อมูลของโพรโทคอล และมี ยกเลิกการเชื่อมต่อไคลเอ็นต์
สำหรับข้อมูลเพิ่มเติม ให้คลิกบทความต่อไปนี้ หมายเลขเพื่อดูบทความใน Microsoft Knowledge Base:
307454MS01-052: ข้อมูล RDP ไม่ถูกต้องอาจก่อให้เกิดความล้มเหลวของบริการเทอร์มินัล
ไคลเอ็นต์บริการเทอร์มินัลอาจได้รับการ ต่อไปนี้ข้อผิดพลาดในระหว่างความพยายามในการเชื่อมต่อ:
ที่ เทอร์มินัลเซิร์ฟได้ยุติการเชื่อมต่อ

สาเหตุ

แย่งอาจเกิดขึ้นระหว่าง Icaapi.dll และ ไลบรารีการเชื่อมโยงแบบ Rdpwsx.dll (Dll) อาจทำให้คีย์ใบรับรองส่วนตัว บนเซิร์ฟเวอร์บริการเทอร์มินัลไม่ให้การซิงโครนัส

การแก้ไข

เมื่อต้องการให้เราแก้ไขปัญหานี้ให้คุณ ไป "แก้ไขปัญหาให้กับฉัน"ส่วน หากคุณต้องการแก้ไขปัญหานี้ได้ด้วยตัวคุณเอง ให้ไป "ให้ฉันแก้ไขด้วยตนเอง"ส่วน

แก้ไขปัญหาให้กับฉัน



เมื่อต้องแก้ไขปัญหานี้ให้โดยอัตโนมัติ คลิกการแก้ไขปัญหาดังกล่าวปุ่มหรือการเชื่อมโยง ในการดาวน์โหลดแฟ้มกล่องโต้ตอบ คลิกเรียกใช้แล้ว ให้ทำตามขั้นตอนในการแก้ไขอัตโนมัตินั้นตัวช่วยสร้าง


แก้ไขปัญหานี้
Microsoft Fix it 50643


บันทึกย่อ
  • ตัวช่วยสร้างนี้อาจได้เป็นภาษาอังกฤษเท่านั้น อย่างไรก็ตาม แก้ไขอัตโนมัติสามารถใช้สำหรับรุ่นภาษาอื่น ๆ ของ Windows
  • หากคุณไม่ได้บนคอมพิวเตอร์ที่มีปัญหา บันทึกการแก้ไขอัตโนมัติได้แก้ไขปัญหาในแฟลชไดรฟ์หรือซีดี และเรียกใช้บนคอมพิวเตอร์ที่มีปัญหา

แล้ว ไป "ซึ่งวิธีแก้ไขปัญหาได้หรือไม่"ส่วน



ให้ฉันแก้ไขด้วยตนเอง

สิ่งสำคัญนี้ส่วน วิธีการ หรืองานประกอบด้วยขั้นตอนที่บอกให้คุณทราบวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง ดังนั้น ให้แน่ใจว่า คุณทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม สำรองรีจิสทรีก่อนที่คุณแก้ไข แล้ว คุณสามารถคืนค่ารีจิสทรีหากเกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรอง และคืนค่ารีจิสทรี คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:
322756วิธีการสำรอง และคืนค่ารีจิสทรีใน Windows

เมื่อต้องการแก้ไขปัญหานี้ ให้ทำตามขั้นตอนเหล่านี้:
  1. เริ่มตัวแก้ไขรีจิสทรี
  2. ค้นหา และคลิ กที่คีย์ย่อยของรีจิสทรีต่อไปนี้:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TermService\Parameters
  3. ภายใต้คีย์ย่อยรีจิสทรีนี้ ลบค่าต่าง ๆ ต่อไปนี้:
    • ใบรับรอง
    • X ใบรับรองที่ 509
    • X หมายเลขใบรับรอง 509
  4. ออกจาก Registry Editor แล้ว รีสตาร์ทเครื่อง เซิร์ฟเวอร์

ซึ่งวิธีแก้ไขปัญหาได้หรือไม่

  • ตรวจสอบว่า ได้รับการแก้ไขปัญหา ถ้าได้รับการแก้ไขปัญหา คุณก็จบความในหัวข้อนี้ ถ้าปัญหาไม่มีแก้ไข คุณสามารถติดต่อฝ่ายสนับสนุน.
  • เราขอบคุณคำติชมของคุณ เมื่อต้อง การแสดงความคิดเห็น หรือรายงานปัญหาใด ๆ เกี่ยวกับการแก้ไขปัญหานี้ กรุณาฝากข้อคิดเห็นในการ "แก้ไขปัญหาให้กับฉัน"บัน หรือส่งให้เรามีอีเมลข้อความ

สถานะ

Microsoft ยืนยันว่า ปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ ในส่วน"ใช้งาน"

คุณสมบัติ

หมายเลขบทความ (Article ID): 323497 - รีวิวครั้งสุดท้าย: 28 มีนาคม 2554 - Revision: 6.0
ใช้กับ
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Web Edition
Keywords: 
kbenv kbprb kbfixme kbmsifixme kbmt KB323497 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:323497

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com