Oprava: Aplikace STI reagovat při odemknutí zařízení pomocí UnLockDevice()

Překlady článku Překlady článku
ID článku: 323571 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

V určitých případech Still Image Architecture (STI) aplikace, která byla úspěšně uzamčena zařízení přestat reagovat (zablokuje se) po neomezenou dobu při pokusu o odemčení zařízení pomocí metody UnLockDevice.

Příčina

K tomuto problému dochází, protože služba obrázků (WIA) zablokovány v tomto okamžiku a nemůže zpracovat žádné další WIA nebo STI požadavky.

Řešení

Problém vyřešíte instalací nejnovější aktualizace Service Pack pro systém Windows XP. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
322389získání nejnovější aktualizace Service Pack pro systém Windows XP

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

INFORMACE O SOUBORECH

Anglická verze této opravy má následující atributy souborů (nebo novější). Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time    Version        Size    File Name
   -----------------------------------------------------
   11-Jun-2002  10:29   5.2.2.8        3,584   Spmsg.dll
   19-Jun-2002  15:48   5.1.2600.48   61,952   Sti.dll
   11-Jun-2002  15:50   5.1.2600.48  314,368   Wiaservc.dll
				

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o chybu v produktech společnosti uvedených na začátku tohoto článku. Tento problém byl poprvé opraven aktualizací Windows XP Service Pack 1.

Další informace

K tomuto problému dochází z důvodu chybné předpokladů, o kterém ID podprocesu uzamčení náleží. Služba WIA IDENTIFIKÁTOR podprocesu klienta používá ID podprocesu volání vzdálené procedury (RPC). Protože RPC používá fondu podprocesů, může být zpracována příchozí požadavky na různých podprocesů, které způsobí neshoda ID podprocesu.

Vlastnosti

ID článku: 323571 - Poslední aktualizace: 27. září 2005 - Revize: 1.4
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbshell kbwinxpsp1fix KB323571 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:323571

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com