Chyba Net3101 na serveru OS/2 z důvodu SessionSetup SMB

Překlady článku Překlady článku
ID článku: 323582 - Produkty, které se vztahují k tomuto článku.
Důležité: Tento článek obsahuje informace o úpravě registru. Před úpravou registru, nezapomeňte vytvořit zálohu a ujistěte se, že víte, jak registr obnovit v případě, že dojde k potížím. Informace o zálohování, obnovení a úpravách registru získáte následujícím článku znalostní báze Microsoft:
256986Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Klient, který má přístup ke sdílené položce na serveru OS/2, může zabrat všechny relace NetBIOS na serveru. Server může způsobit síťové 3101 sestavu, která označuje, zda byl spuštěn server nedostatek prostředků.

Příčina

Při zahájení nové relace odešle přesměrovač SMB SessionSetup, který se sadou VC číslo 0. To znamená, že to je novou relaci a vymaže všechny předchozí relace.

Protože SMB systému OS/2 servery nedojde k ukončení předchozí relace, relace NetBIOS na straně serveru jsou vyčerpané. To vede k síťové chybě 3101 na serveru OS/2.

Řešení

Systém Windows XP

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro systém Windows XP. Další informace získáte následujícím článku báze Microsoft Knowledge Base:
322389Jak získat nejnovější aktualizaci Windows XP Service Pack

Informace o opravě hotfix

Podporovaná oprava hotfix k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze k odstranění problému popsaného v tomto článku. Tuto opravu hotfix použijte pouze v systémech, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud je přísně neohrožuje tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, je oddíl "K dispozici oprava Hotfix stahování" v horní části tohoto článku znalostní báze Knowledge Base. Pokud v této části se nezobrazí, obraťte se na služby Microsoft a podporu získat opravu hotfix.

Poznámka: Pokud vyskytnout další problémy nebo řešení potíží je vyžadován, pravděpodobně budete muset vytvořit požadavek na samostatnou službu. Výdaje na podporu se obvykle týkají dalších otázek a problémů, které se netýkají této zvláštní opravy hotfix. Úplný seznam telefonních čísel služby Microsoft a podpora nebo vytvořit zvláštní požadavek na službu na následujícím webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "K dispozici oprava Hotfix stahování" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Informace o souboru

Anglická verze této opravy atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy těchto souborů jsou uvedeny v čase univerzální koordinovaný (čas UTC). Při zobrazení informací o souboru, bude převedena na na místní čas. Rozdíl mezi místním časem a UTC časem kartě časové pásmo v panelu Datum a čas v Ovládacích panelech.
   Date         Time   Version      Size     File name
   ----------------------------------------------------
   10-Jul-2002  16:36  5.1.2600.49  391,808  Mrxsmb.sys
   10-Jul-2002  16:36  5.1.2600.49  152,832  Rdbss.sys
				

Systém Windows 2000

Informace o aktualizaci Service Pack

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro systém Microsoft Windows 2000. Další informace získáte následujícím článku báze Microsoft Knowledge Base:
260910Jak získat nejnovější aktualizaci Service Pack pro systém Windows 2000

Informace o opravě hotfix

Podporovaná oprava hotfix k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze k odstranění problému popsaného v tomto článku. Tuto opravu hotfix použijte pouze v systémech, ve kterých dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, je oddíl "K dispozici oprava Hotfix stahování" v horní části tohoto článku znalostní báze Knowledge Base. Pokud se nezobrazí v této části, podat žádost služby Microsoft a odbornou pomoc, můžete tuto opravu hotfix získat.

Poznámka: Pokud vyskytnout další problémy nebo řešení potíží je vyžadován, pravděpodobně budete muset vytvořit požadavek na samostatnou službu. Výdaje na podporu se obvykle týkají dalších otázek a problémů, které se netýkají této zvláštní opravy hotfix. Úplný seznam telefonních čísel služby Microsoft a podpora nebo vytvořit zvláštní požadavek na službu na následujícím webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "K dispozici oprava Hotfix stahování" formulář zobrazí jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Informace o souboru

Anglická verze této opravy atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy těchto souborů jsou uvedeny v čase univerzální koordinovaný (čas UTC). Při zobrazení informací o souboru, bude převedena na na místní čas. Rozdíl mezi místním časem a UTC časem kartě časové pásmo v panelu Datum a čas v Ovládacích panelech.
   Date         Time   Version           Size     File name
   ----------------------------------------------------
   19-Jul-2002  13:04  5.00.2195.5955    371,248  MRXSMB.SYS
   19-Jul-2002  13:04  5.00.2195.5955    132,048  RDBSS.SYS
				

Nastavit hodnotu registru na předchozí relaci výslovně ukončit

Upozornění: Pokud použijete Editor registru nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalaci operačního systému. Společnost Microsoft nemůže zaručit, že budete schopni vyřešit problémy, ke kterým dojde v důsledku nesprávného použití Editoru registru. Editor registru používáte na vlastní nebezpečí.
Byl přidán nový klíč registru odeslat SMB odhlášení & X, který explicitně ukončení předchozí relace.

Poznámka: protože nezpracovává tomto protokolu SMB také odesílání odhlášení & X SMB ovlivňuje připojení k serveru SAMBA.

Postupujte následujícím způsobem a pak ukončete Editor registru:
  1. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz regedit a pak klepněte na tlačítko OK.
  2. Vyhledejte a klepněte na následující klíč registru:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters
  3. V nabídce Úpravy přejděte na příkaz Nový a klepněte na položku DWORD.
  4. Zadejte EnableDownLevelLogOff a stiskněte klávesu ENTER.
  5. V nabídce Úpravy klepněte na příkaz změnit.
  6. Zadejte hodnotu 1 a klepněte na tlačítko OK.

Prohlášení

Systém Windows XP

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku. Tento problém byl opraven v aktualizaci Service Pack 1.

Systém Windows 2000

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny na začátku tohoto článku. Tento problém byl poprvé opraven v aktualizaci Service Pack 4 pro systém Windows 2000.

Další informace

Poznámka: Výchozí hodnota pro klíč registru
EnableDownLevelLogOff
je 0 (nula). To zůstane true po instalaci systému Windows 2000 Service Pack 4. Další informace o získání opravy hotfix pro systém Windows 2000 Datacenter Server získáte v článku znalostní báze Microsoft Knowledge Base:
265173Datacenter Program a systém Windows 2000 Datacenter Server

Vlastnosti

ID článku: 323582 - Poslední aktualizace: 27. října 2006 - Revize: 4.6
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kbbug kbenv kbfix kboswin2000fix kbwin2000presp4fix kbwinxpsp1fix KB323582 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:323582

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com