Numéro d'article: 323597 - Dernière mise à jour: vendredi 12 août 2005 - Version: 2.0

Les clients Windows XP ne peuvent pas se connecter à un serveur Terminal Server Windows 2000

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Ancien nº de publication de cet article : F323597
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256986  (http://support.microsoft.com/kb/256986/ ) Description du Registre de Microsoft Windows

Sommaire

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Symptômes

Lorsque vous essayez de vous connecter à partir d'un client Windows XP à un serveur des services Terminal Server Windows 2000, la connexion peut échouer et le message d'erreur suivant peut s'afficher :
Le client n'a pas pu se connecter à l'ordinateur distant car une erreur de sécurité s'est produite. Vérifiez que vous êtes connecté au réseau, et essayez de vous reconnecter.
Ce message d'erreur peut se produire lorsque vous essayez de vous connecter à partir d'un client Windows XP à certains ou tous les serveurs des services Terminal Server Windows 2000 de votre organisation ; ou bien, le message d'erreur peut ne pas se produire du tout.

Lorsque vous essayez de vous connecter à partir d'un client Windows 2000 à un serveur Terminal Server Windows 2000, l'erreur suivante peut être enregistrée sur le serveur :
ID de l'événement : 1003
Source : TermService
Type : Informations
Le client du service Terminal Server a fourni une licence non valide.

Cause

Ce message d'erreur est provoqué par une modification des certificats utilisés par le serveur Microsoft Clearinghouse pour autoriser les serveurs de licences des services Terminal Server.

Résolution

AVERTISSEMENT : toute utilisation incorrecte de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.

Pour résoudre ce problème, suivez les étapes présentées dans la section ci-dessous sur les serveurs Terminal Server Windows 2000 affectés et sur les clients Windows XP.

Sur le serveur Terminal Server

  1. Démarrez l'Éditeur du Registre (Regedit.exe ou Regedt32.exe).
  2. Recherchez la clé suivante dans le Registre et cliquez dessus :
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TermService\Parameters
  3. Dans cette clé de Registre, supprimez les valeurs suivantes :
    Certificate
    X 509 Certificate
    X 509 Certificate ID
  4. Fermez l'Éditeur du Registre, puis redémarrez le serveur.

Sur le client Windows XP

  1. Démarrez l'Éditeur du Registre (Regedit.exe).
  2. Recherchez la clé suivante dans le Registre et cliquez dessus :
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing
  3. Supprimez la clé MSLicensing entière du Registre.
  4. Quittez l'Éditeur du Registre.
  5. Connectez-vous au serveur Terminal Server.
REMARQUE : si le problème persiste, vous devrez désactiver puis réactiver le serveur de licences des services Terminal Server. Pour cela, appelez la banque centrale de licences Microsoft Clearinghouse au 1-888-571-2048.

Statut

Microsoft a confirmé l'existence de ce problème dans Windows 2000.

Plus d'informations

Étant donné que les clients Windows XP Professionnel ont une licence d'accès client Terminal Server intégrée pour accéder aux serveurs Terminal Server Windows 2000, la suppression de la clé MSLicensing sur le client n'affecte pas l'allocation de licences dans l'organisation.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professionnel
Mots-clés : 
kbenv kberrmsg kbprb KB323597
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