ID do artigo: 323597 - Última revisão: terça-feira, 14 de junho de 2005 - Revisão: 2.0

Clientes com Windows XP não conseguem se conectar a um Servidor de serviços de terminal do Windows 2000

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
IMPORTANTE: Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e verifique se você sabe como restaurá-lo caso ocorra algum problema. Para obter informações adicionais sobre como fazer backup, restaurar e editar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft.
256986  (http://support.microsoft.com/kb/256986/PT-BR/ ) Descrição do Registro do Microsoft Windows

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Sintomas

Quando tentar se conectar de um cliente com base em Windows XP a um servidor de serviços de terminal com base em Windows 2000, a conexão pode falhar e a seguinte mensagem de erro pode ser exibida:
Devido a um erro de segurança, o cliente não pôde se conectar ao servidor do terminal. Depois de verificar se fez o logon na rede, tente conectar-se ao servidor novamente.
Essa mensagem de erro pode ser exibida ao tentar se conectar de um cliente com base em Windows XP com um ou todos os servidores de serviços de terminal com Windows 2000 na sua empresa, ou a mensagem de erro pode não ocorrer.

Quando tentar se conectar de um cliente com Windows 2000 a um servidor de serviços de terminal com base em Windows 2000, o seguinte erro pode ser registrado no Windows 2000 Terminal Server:
Identificação do evento: 1003
Fonte: TermService
Tipo: Informações
O cliente dos serviços de terminal forneceu uma licença inválida.

Causa

Essa mensagem de erro é exibida devido a uma alteração nos certificados usados pela Microsoft Clearinghouse para autorizar os servidores de Licenciamento de serviços de terminal.

Resolução

AVISO: O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. O uso do Editor do Registro é de sua responsabilidade.

Para resolver esse problema, execute as etapas na seguinte seção sobre os servidores de serviços de terminal com Windows 2000 afetados e os clientes com Windows XP.

No servidor de serviços de terminal

  1. Inicie o Editor de Registro (Regedit.exe ou Regedt32.exe).
  2. Localize e clique na seguinte chave no Registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TermService\Parameters
  3. Nesta chave de Registro, exclua os seguintes valores:
    Certificate
    X 509 Certificate
    X 509 Certificate ID
  4. Encerre o Editor do Registro e reinicie o servidor.

No cliente com base em Windows XP

  1. Inicie o Editor do Registro (Regedit.exe).
  2. Localize e clique na seguinte chave no Registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSLicensing
  3. Exclua a chave MSLicensing inteira do Registro.
  4. Feche o Editor do Registro.
  5. Conecte-se ao servidor der serviços de terminal.
OBSERVAÇÃO: Se essas etapas não resolverem o problema, você deve desativar e depois reativar o servidor de licenciamento dos serviços de terminal. Para fazer isso, ligue para a Câmera de compensação da Microsoft: 1-888-571-2048.

Situação

A Microsoft confirmou que esse é um problema no Windows 2000.

Mais Informações

Como os clientes com Windows XP Professional têm uma Licença de acesso de cliente a serviços de terminal interna (CAL) para acessar servidores de serviços de terminal com Windows 2000, a exclusão da chave MSLicensing no cliente não afeta adversamente a alocação de licença em uma organização.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows XP Professional Edition
Palavras-chave: 
kbenv kberrmsg kbprb KB323597