Messaggio di errore quando si accede a un dispositivo di archiviazione USB dopo la ripresa dalla sospensione

Questo articolo fornisce una soluzione a un errore che si verifica quando si accede a un dispositivo di archiviazione USB dopo la ripresa dalla sospensione.

Si applica a: Windows 10 - tutte le edizioni
Numero KB originale: 323754

Sintomi

Se si tenta di usare un dispositivo di archiviazione USB (Universal Serial Bus) immediatamente dopo aver ripreso il computer dalla sospensione, è possibile che venga visualizzato il messaggio di errore seguente:

X :\ l'unità non è accessibile. Impossibile eseguire la richiesta a causa di un errore del dispositivo di I/O.

Si continua a ricevere il messaggio di errore quando si tenta di usare il dispositivo di archiviazione USB fino a quando non si rimuove e si ricollega il dispositivo o si riavvia il computer. Questo problema può verificarsi con qualsiasi dispositivo di archiviazione USB, ad esempio unità disco floppy, dischi rigidi o unità CD-ROM.

Causa

Questo problema si verifica con alcuni dispositivi di archiviazione USB 1.x collegati a un controller USB 2.0 in Windows 2000 con l'aggiornamento USB 2.0 installato.

Risoluzione

Per risolvere il problema, ottenere e installare il file Usbhub.sys aggiornato dall'hotfix.

Soluzione alternativa

Per risolvere questo problema, attendere circa 10 secondi dopo aver ripreso il computer prima di provare a usare il dispositivo di archiviazione USB 1.x.

Se non si usano dispositivi USB 2.0 nel computer, un'altra soluzione alternativa consiste nel disattivare il controller USB 2.0 in Gestione dispositivi. Dopo aver disattivato il controller USB 2.0, il problema descritto in precedenza in questo articolo con i dispositivi USB 1.x non si verifica.

Stato

Microsoft ha confermato che si tratta di un problema nei prodotti Microsoft elencati all'inizio di questo articolo.

Ulteriori informazioni

Dopo aver applicato l'hotfix menzionato in precedenza in questo articolo, i comportamenti seguenti cambiano:

  • Se si tenta di usare un dispositivo di archiviazione USB 1.x subito dopo la ripresa del computer, il problema potrebbe comunque verificarsi. Tuttavia, il problema non si verifica se si tenta di usare nuovamente il dispositivo di archiviazione in pochi secondi.

  • Poco dopo aver ripreso il computer, è possibile che venga visualizzato un messaggio Rimozione non sicura del dispositivo che menziona il dispositivo USB 1.x. È possibile chiudere questa casella in modo sicuro. Questo messaggio si verifica a causa di un problema di temporizzazione di Windows che comporta l'alimentazione dello stack di driver del controller complementare USB e dello stack EHCI (Enhanced Host Controller Interface) dopo la ripresa dalla sospensione.

    Se il driver dell'hub radice del controller complementare si accende per primo, i dispositivi USB 1.x collegati alle porte dell'hub radice quando il computer immesso sospendo non sono più collegati. Pertanto, il driver informa Plug and Play che il dispositivo è stato rimosso. Ciò si verifica perché i dispositivi sono stati indirizzati al controller EHCI quando è stato impostato il flag di configurazione, ma non sono attualmente collegati al controller complementare.

    Quando il driver dell'hub radice del controller EHCI (per USB 2.0) si accende in un secondo momento, le porte dell'hub radice vengono reimpostate e i dispositivi USB 1.x vengono instradati ai controller complementari. L'hub controller complementare enumera quindi di nuovo i dispositivi. Vengono quindi rilevati e diventano funzionali.

    Questo non influisce sui dispositivi USB 2.0 perché rimangono sempre collegati al controller EHCI.

Raccolta dei dati

Se è necessaria l'assistenza del supporto tecnico Microsoft, si consiglia di raccogliere le informazioni seguendo i passaggi indicati in Raccogliere informazioni utilizzando TSS per le questioni relative alla distribuzione.