File Download Dialog Box Appears After You Turn Off File Downloads

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Article ID: 324098 - View products that this article applies to.
This article was previously published under Q324098
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SYMPTOMS

A File Download dialog box that prompts you to save or open a file from your local computer may appear if you open a Universal Resource Identifier (URI). For example, if you click a link on a Web page, you may be prompted to save or open Cmd.exe from C:\Winnt\System32.

This issue may occur even if you have turned off the File Downloads functionality in either the Web content zone of the URI that you are opening or for the Web page in which you clicked the link.

CAUSE

This problem may occur if the URI that you open points to an executable file on your local computer (either directly or by a redirect operation). Files on your local computer are in the My Computer zone. The File Downloads functionality is turned on for the My Computer zone, and you cannot configure this zone by using the Internet Explorer user interface.

RESOLUTION

To resolve this issue, obtain and install the latest service pack for Internet Explorer 6. To resolve this problem, obtain the latest service pack for Internet Explorer 6. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
328548 How to obtain the latest service pack for Internet Explorer 6

WORKAROUND

To work around this issue, turn off the File Downloads functionality for the My Computer zone by using the appropriate method that is described in this section.

IMPORTANT: If you are an administrator, Microsoft recommends that you use this workaround to prevent limited users from running files on the local computer in secure configurations (for example, a public kiosk).

Method 1: Turn Off My Computer File Downloads for All Users

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following value in the registry:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0\1803
  3. On the Edit menu, click Modify.
  4. Type 3, and then press ENTER.
  5. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings
  6. On the Edit menu, point to New, and then click DWORD Value.
  7. Type Security_HKLM_only, and then press ENTER.
  8. On the Edit menu, click Modify.
  9. Type 1, and then click OK.
  10. Quit Registry Editor.
NOTE: You must create the Current Version key and the Internet Settings keys if they do not already exist.

Method 2: Turn Off My Computer File Downloads for the Current User Only

Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following value in the registry:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0\1803
  3. On the Edit menu, click Modify.
  4. Type 3, and then press ENTER.
After you use either of the methods that are described in this section, you receive the following error message if a Web site tries to open local files:
Security Alert
Your current security settings do not allow this file to be downloaded.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 5 and 6. This problem was corrected in Internet Explorer 6 Service Pack 1 (SP1).

Properties

Article ID: 324098 - Last Review: May 10, 2007 - Revision: 4.7
APPLIES TO
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows XP Professional x64 Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
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