DCOM プロキシがバインド ハンドルを探す際にサーバー スタブから切り離される

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文書番号: 324102 - 対象製品
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目次

現象

分散コンポーネント オブジェクト モデル (DCOM) のクライアントとサーバー アプリケーションを使用した一部の環境で、クライアント プロキシのサーバー スタブへの接続が失われることがあります。この状況が発生すると、DCOM ガベージ コレクションは孤立したサーバー スタブを約 8 分後に停止します。サーバー コンピュータを再起動しても、クライアント プロキシを機能させることはできません。

原因

クライアントが、サーバー スタブに対してリモート プロシージャ コール (RPC) バインド ハンドルを作成しようとした場合、バインド オブジェクトはバインド状態を確認せずに初期化済みとマークされます。そのため、バインド処理が失敗した場合、バインド オブジェクトは NULL バインド文字列を持ち、DCOM ガベージ コレクションはサーバー スタブを再利用するため、クライアント プロキシが再びサーバーに接続することはありません。

解決方法

Service Pack について

この問題を解決するには、Microsoft Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 How to Obtain the Latest Windows 2000 Service Pack
260910 最新の Windows 2000 Service Pack の入手方法

修正プログラムについて

この問題を解決するには、Microsoft COM+ ロールアップ修正プログラム 20.2 を入手します。 関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
324034 INFO: Availability of Windows 2000 Post-Service Pack 2 COM+ Hotfix Rollup Package 20.2
324034 [INFO] Windows 2000 Service Pack 2 以降の COM+ 修正プログラム ロールアップ パッケージ 20.2 について
マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを受ける場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows 2000 Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次の Web ページを参照してください。
http://support.microsoft.com/contactus/
: Microsoft Support Professional が、特定のアップデートを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定のアップデートの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。


状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。

この問題を解決するためのモジュールは、Windows 2000 日本語版 Service Pack 4 以降に含まれております。
Windows 2000 日本語版の最新 Service Pack については、以下の Web サイトから入手できます。
http://www.microsoft.com/japan/windows2000/downloads/servicepacks/sp4/default.asp

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 324102 (最終更新日 2003-06-05) を基に作成したものです。

プロパティ

文書番号: 324102 - 最終更新日: 2014年2月24日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Microsoft COM+ 1.0?を以下の環境でお使いの場合
    • Microsoft Windows 2000 Standard Edition
キーワード:?
kbnosurvey kbarchive kbwin2ksp4fix kbbug kbdcom kbfix kbwin2000presp3fix kbwin2000sp3fix KB324102
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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