Violação de Spoolsv.exe GDI32 de acesso! IcmInitIcmInfo no Windows 2000

Traduções de Artigos Traduções de Artigos
Artigo: 324183 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

O serviço spooler poderá deixar de responder (não reagir) quando ocorre uma violação de acesso e o evento seguinte poderá ser registado:
Tipo de evento: erro
Origem do evento: Gestor de controlo de serviços
Categoria do evento: nenhum
ID do evento: 7031
Utilizador: N/d
Computador: print server name
Descrição: O serviço de spooler de impressão terminou inesperadamente.
O registo do Dr. Watson pode mostrar que a violação de acesso ocorreu na ferramenta Spoolsv.exe no gdi32! IcmInitIcmInfo .

Causa

Este problema poderá ocorrer se for submetida a uma tarefa de impressão que contém uma estrutura DEVMODE versão 3 mais antiga que não contém informações de ICM. Quando o spooler tenta fazer referência a dados, faz com que a violação de acesso.

Resolução

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente para o Microsoft Windows 2000. Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
260910Como obter o Service Pack mais recente do Windows 2000

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentada, submeta um pedido para o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.A versão inglesa desta correcção tem os atributos de ficheiro (ou posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Version         Size     File name
   ------------------------------------------------------
   11-Jun-2002  09:48  5.00.2195.5878  222,992  Gdi32.dll       
				

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no início deste artigo. Este problema foi corrigido pela primeira vez no Microsoft Windows 2000 Service Pack 4.

Mais Informação

Depois de aplicar esta correcção, a estrutura DEVMODE é verificada antes ICM dados podem ser utilizados. Se for detectado um DEVMODE não é válido, poderá ser registado o seguinte erro pelo spooler:
Tipo de evento: erro
Origem do evento: imprimir
Categoria do evento: nenhum
ID do evento: 45
Utilizador: user name
Computador: print server name
Descrição: O documento não conseguiu imprimir devido a erro do controlador/GDI na composição.
Este trabalho de impressão poderão não imprimir com êxito, mas já não bloqueia o serviço Spooler.

Para obter informações adicionais sobre como obter uma correcção para o Windows 2000 Datacenter Server, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
265173O programa Datacenter e o produto do Windows 2000 Datacenter Server
Para obter informações adicionais sobre como instalar várias correcções com apenas um reinício, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft:
296861Utilizar o QChain.exe para instalar múltiplas correcções com um reinício do computador
Uma tarefa de impressão que não é válida pode ser gerada a partir de um programa ou um controlador de impressora mais antigo.

Propriedades

Artigo: 324183 - Última revisão: 24 de fevereiro de 2014 - Revisão: 3.7
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows 2000 Service Pack 3
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbprint kbwin2ksp4fix kbbug kbenv kberrmsg kbfix kbqfe kbwin2000presp4fix KB324183 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 324183

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com