Puede que una tarjeta PC Card de interfaz de audio digital no funcione correctamente

Seleccione idioma Seleccione idioma
Id. de artículo: 324415 - Ver los productos a los que se aplica este artículo
Este artículo se publicó anteriormente con el número E324415
Expandir todo | Contraer todo

Síntomas

Puede que una tarjeta PC Card de interfaz de audio digital no reproduzca archivos de audio.

Causa

Este problema se produce debido a un error en el controlador Pcmcia.sys.

El problema consiste en que el controlador de bus PCMCIA no interpreta correctamente el campo TPCC_RMSK de la tupla CISTPL_CONFIG. Esto puede provocar un problema de configuración de una tarjeta PC Card en la siguiente situación:
  • Una tarjeta PC Card puede implementar sólo el registro de opciones de configuración (COR) y la tarjeta establece correctamente el campo TPCC_RMSK con el valor 1, lo que indica que la tarjeta PC Card sólo está implementando el registro de opciones de configuración.
  • Sin embargo, el controlador de bus PCMCIA no reconoce este valor y escribe tanto el registro de opciones de configuración como el siguiente, que es el registro de estado de configuración (CSR).
  • La tarjeta PC Card no examina el desplazamiento (no se le pide), por lo que con la segunda escritura del controlador de bus se sobrescribe el registro de opciones de configuración, lo que provoca una configuración incorrecta de la tarjeta PC Card.
El resultado es que no se reproducen los archivos de audio.

Solución

Ahora hay disponible una revisión admitida por Microsoft, pero sólo se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Para resolver el problema, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtener la revisión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico de Microsoft, así como información acerca de los costos de soporte técnico, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;ES-ES;CNTACTMS
NOTA: en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas y temas de soporte técnico adicionales que no reúnan las condiciones necesarias para la actualización en cuestión.

La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según el Horario universal coordinado (UTC). Cuando vea la información de archivo, se convertirá a la hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.
 Fecha             Hora     Versión        Tamaño    Nombre de archivo
 ----------------------------------------------
 19-JUN-2002    19:12    5.1.2600.48    115.584    pcmcia.sys
NOTA: para ver la versión del archivo, haga clic con el botón secundario del mouse (ratón) en el archivo en el Explorador de Windows, haga clic en Propiedades y, a continuación, haga clic en la ficha Versión.

Ahora hay disponible una revisión admitida por Microsoft, pero sólo se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico. Es posible que se realicen más pruebas de esta revisión. Por tanto, si no se ve muy afectado por este problema, Microsoft recomienda que espere al próximo Service Pack de Windows 2000 que contenga esta revisión.

Para resolver este problema inmediatamente, póngase en contacto con los Servicios de soporte técnico de Microsoft con el fin de obtener la revisión. Para obtener una lista completa de los números de teléfono de los Servicios de soporte técnico de Microsoft, así como información acerca de los costos de soporte técnico, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;ES-ES;CNTACTMS
NOTA: en casos especiales, los costos derivados normalmente de las llamadas al soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas y temas de soporte técnico adicionales que no reúnan las condiciones necesarias para la actualización en cuestión.

La versión en inglés de esta revisión tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y las horas de estos archivos se muestran según el Horario universal coordinado (UTC). Cuando vea la información de archivo, se convertirá a la hora local. Para averiguar la diferencia entre la hora UTC y la hora local: en Panel de control, haga doble clic en Fecha y hora y, a continuación haga clic en la ficha Zona horaria.
 Fecha             Hora      Versión           Tamaño     Nombre de archivo
 -----------------------------------------------------------
 28-AGO-2001    14:33                        4.772       ntdetect.com
 26-NOV-2001    19:39    5.0.2195.4689     59.216      pci.sys
 19-JUN-2002    09:20    5.0.2195.5896    109.520      pcmcia.sys 

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información en este artículo se refiere a:" de este artículo.

Más información

Para obtener información adicional acerca de cómo obtener una revisión para Windows 2000 Datacenter Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
265173 Datacenter Program and Windows 2000 Datacenter Server Product
Para obtener información adicional acerca de cómo instalar múltiples revisiones con un único reinicio, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
296861 Utilizar QChain.exe para instalar varias revisiones con sólo un reinicio

Propiedades

Id. de artículo: 324415 - Última revisión: miércoles, 29 de marzo de 2006 - Versión: 4.3
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Palabras clave: 
kbqfe kbhotfixserver kbddk kbgrpdsntddk kbprb kbwin2000presp4fix KB324415

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com