Une carte PC d'interface audio numérique peut ne pas fonctionner correctement

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Numéro d'article: 324415 - Voir les produits auxquels s'applique cet article
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Symptômes

Une carte PC d'interface audio numérique peut ne pas lire les fichiers audio.

Cause

Ce problème se produit à cause d'un bogue dans le pilote Pcmcia.sys.

Le problème vient du fait que le pilote de bus PCMCIA n'interprète pas correctement le champ TPCC_RMSK du tuple CISTPL_CONFIG. Cela peut entraîner un problème de configuration d'une carte PC dans le scénario suivant :
  • Une carte PC peut n'implémenter que le Registre d'options de configuration, et la carte définit correctement le champ TPCC_RMSK sur 1, ce qui indique que la carte PC n'implémente que le Registre d'options de configuration.
  • Le pilote de bus PCMCIA, toutefois, ne reconnaît pas cette valeur et écrit à la fois sur le Registre d'options de configuration et le registre suivant, c'est-à-dire le Registre de statut de configuration.
  • La carte PC ne recherche pas le décalage (elle n'est pas sensée le faire), par conséquent, la seconde fois, le pilote de bus écrit sur le Registre d'options de configuration en l'écrasant, ce qui provoque une configuration incorrecte de la carte PC.
De ce fait, les fichiers audio ne sont pas lus.

Résolution

Pour résoudre ce problème, procurez-vous le dernier Service Pack de Windows XP. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322389 Comment obtenir le dernier Service Pack de Windows XP
Un correctif est désormais disponible auprès de Microsoft, mais est conçu uniquement pour corriger le problème décrit dans cet article. Il ne doit être appliqué qu'aux ordinateurs rencontrant ce problème spécifique.

Pour résoudre ce problème, procurez-vous ce correctif auprès des services de Support technique Microsoft. Pour obtenir une liste complète des numéros de téléphone des services de support technique Microsoft, ainsi que des informations relatives aux frais de support technique, consultez le site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
REMARQUE : dans certains cas, aucun frais de support technique par téléphone ne vous sera facturé si un technicien du Support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s'appliqueront aux questions supplémentaires et aux problèmes non traités par la mise à jour en question.

La version anglaise de ce correctif dispose des attributs de fichier répertoriés dans le tableau suivant ou ceux d'une version ultérieure. Les dates et heures de création de ces fichiers sont indiquées par rapport à l'heure universelle (GMT). Lorsque vous affichez les informations des fichiers, les données sont converties à l'heure locale. Pour connaître le décalage entre l'heure GMT et l'heure locale, utilisez l'onglet Fuseau horaire dans l'utilitaire Date et heure du Panneau de configuration.
   Date      Heure   Version         Taille   Nom du fichier
   -----------------------------------------------------------
   19/06/02  19:12   5.1.2600.48    115 584   pcmcia.sys

				
REMARQUE : pour afficher la version du fichier, cliquez dessus avec le bouton droit dans l'Explorateur Windows, cliquez sur Propriétés, puis sur l'onglet Version.

Un correctif est désormais disponible auprès de Microsoft, mais est conçu uniquement pour corriger le problème décrit dans cet article. Il ne doit être appliqué qu'aux ordinateurs rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, Microsoft vous recommande d'attendre la prochaine version du Service Pack Windows 2000 qui contiendra ce correctif.

Pour résoudre ce problème dès à présent, procurez-vous ce correctif auprès des services de Support technique Microsoft. Pour obtenir une liste complète des numéros de téléphone des services de support technique Microsoft, ainsi que des informations relatives aux frais de support technique, consultez le site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS
REMARQUE : dans certains cas, aucun frais de support technique par téléphone ne vous sera facturé si un technicien du Support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts normaux du support technique s'appliqueront aux questions supplémentaires et aux problèmes non traités par la mise à jour en question.

La version anglaise de ce correctif dispose des attributs de fichier répertoriés dans le tableau suivant ou ceux d'une version ultérieure. Les dates et heures de création de ces fichiers sont indiquées par rapport à l'heure universelle (GMT). Lorsque vous affichez les informations des fichiers, les données sont converties à l'heure locale. Pour trouver la différence entre l'heure universelle (GMT) et l'heure locale : dans le Panneau de configuration, double-cliquez sur Date et heure, puis cliquez sur l'onglet Fuseau horaire.
   Date      Heure   Version         Taille    Nom du fichier
   -----------------------------------------------------------
   28/08/01  14:33                   34 772    ntdetect.com
   26/11/01  19:39   5.0.2195.4689   59 216    pci.sys
   19/06/02  09:20   5.0.2195.5896  109 520    pcmcia.sys   
				

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "Liste des produits concernés par cet article". Ce problème a été corrigé dans le Service Pack 1 Microsoft Windows XP.

Plus d'informations

Pour plus d'informations sur la procédure à suivre pour obtenir un correctif pour Windows 2000 Datacenter Server, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
265173 Programme Datacenter et Windows 2000 Datacenter Server
Pour plus d'informations sur l'installation de plusieurs correctifs en un seul redémarrage, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
296861Utilisation du fichier QChain.exe pour installer plusieurs correctifs en un seul redémarrage

Propriétés

Numéro d'article: 324415 - Dernière mise à jour: mercredi 29 mars 2006 - Version: 5.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professionel
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professionnel
Mots-clés : 
kbqfe kbhotfixserver kbbug kbfix kboswin2000fix kbwin2000presp4fix kbwinxpsp1fix KB324415
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