Artigo: 324500 - Última revisão: quinta-feira, 1 de Fevereiro de 2007 - Revisão: 4.2

PRJ2000: Mensagem de erro "Erro 1933" quando instala o Microsoft Office 2000

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando instalar o Microsoft Project ou o Microsoft Office num computador baseado no Windows XP, poderá receber uma mensagem de erro semelhante a um dos seguintes procedimentos:
Erro 1933 - protecção de ficheiro do Windows
Ficheiros do Windows tem de estar instalados para a instalação continuar.
Erro 1933. O serviço Windows Installer não consegue actualizar um ou mais ficheiros de windows protegido.
Em seguida, pode ser indicado para inserir o CD-ROM do Windows XP Professional num unidade de CD-ROM do computador ou de DVD-ROM. Pode ser indicado para o fazer mesmo se o sistema operativo do seu computador for Windows XP Home Edition.

Causa

Este comportamento ocorre porque o ficheiro Fpencode.dll que o programa de configuração tenta copiar para o disco rígido está protegido pela protecção de ficheiros do Windows. Isto pode ocorrer quando instala o Microsoft Project ou o Office num computador que está a executar uma versão de fabricante de equipamento original (OEM) do Windows XP Professional ou Windows XP Home Edition.

Resolução

Para resolver este problema, copie o ficheiro Fpencode.dll do Microsoft Project ou CD-ROM do Microsoft Office para a pasta Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Bin no disco rígido. Para o fazer, siga estes passos:
  1. Insira o Microsoft Project ou o CD-ROM do Office na unidade de CD-ROM ou DVD-ROM do computador. Prima e mantenha premida a tecla SHIFT quando inserir o CD-ROM para impedir que este seja iniciado automaticamente.
  2. Inicie o Explorador do Windows e, em seguida, navegue para a seguinte pasta (em que drive é unidade de CD-ROM ou DVD-ROM do computador que contém o Microsoft Project ou o CD-ROM do Office):
    drive: \Pfiles\Common\Msshared\Websrvex\40\Bin
  3. Localize e clique com o botão direito do rato no ficheiro Fpencode.dll e, em seguida, clique em Copiar .
  4. No Explorador do Windows, navegue para e clique na seguinte pasta:
    C: \Programas\Ficheiros comuns\Microsoft Shared\Web Extensions\40\Bin de servidor
  5. Clique em Colar no menu Editar .
  6. Clique em Sim na mensagem apresentada na caixa de diálogo Confirmar substituição de ficheiro para confirmar que pretende substituir o ficheiro existente.
  7. Saia do Windows Explorer.
  8. Executar o Microsoft Project ou o programa de configuração do Office.

    Nota Em alguns casos, poderá ter também copiar o ficheiro Fp4autl.dll a partir do CD-ROM do Office ou Microsoft Project para a pasta adequada no disco rígido.
Se este procedimento não resolver o problema, repita os passos 2 a 7 para copiar o ficheiro Fp4autl.dll da pasta Pfiles\Common\Msshared\Websrvex\40\Bin no Microsoft Project ou CD-ROM do Office para a pasta C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\40\Bin no disco rígido e, em seguida, executar o Microsoft Project ou programa de configuração do Office.

Mais Informação

Para obter mais informações sobre como resolver uma mensagem de erro semelhante "erro 1933", clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
314812  (http://support.microsoft.com/kb/314812/ ) OFF2000: Mensagem de erro "Erro 1933" quando tenta instalar a actualização do Office 2000 Professional

A informação contida neste artigo aplica-se a:
  • Microsoft Office 2000 Standard Edition
  • Microsoft Project 2000 Standard Edition
  • the operating system: Microsoft Windows XP
Palavras-chave: 
kbmt kberrmsg kbprb KB324500 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 324500  (http://support.microsoft.com/kb/324500/en-us/ )