Office インストール時のエラー メッセージ "Windows インストーラー サービスにアクセスできませんでした"

文書翻訳 文書翻訳
文書番号: 324516 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Office をインストールするときに、次のようなエラー メッセージが表示される場合があります。
Windows インストーラー サービスにアクセスできませんでした。

原因

この問題は、Windows インストーラー ファイルが破損しているか、存在しない場合に発生することがあります。

解決方法

この問題を解決するには、以下のいずれかの方法を使用します。

方法 1: Msconfig ツールを使用してインストーラー サービスが実行されていることを確認する

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。(この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  2. [名前] ボックスに「msconfig」と入力し、[OK] をクリックします。(この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  3. [サービス] タブで、[Windows インストーラー] の横にあるチェック ボックスをオンにします (この手順のスクリーン ショットを以下に示します)。

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  4. [OK] をクリックし、[再起動] をクリックしてコンピューターを再起動します (この手順のスクリーン ショットを以下に示します)。

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  5. Office を再度インストールします。プロダクト キーを入力するように求めるメッセージが表示されたら、プロダクト キーを入力し、[次へ] をクリックします。
Office がインストールされ、プログラム起動時にプロダクト キーを要求するメッセージが表示されなくなります。

方法 2: Windows インストーラーを再登録する

重要 このセクション、方法、またはタスクには、レジストリを変更する手順が記載されています。しかし、レジストリを誤って変更すると、深刻な問題が発生する可能性があります。したがって、これらの手順は慎重に実行する必要があります。万一に備えて、変更前のレジストリをバックアップしてください。これにより、問題が発生した場合にレジストリを復元することが可能になります。レジストリのバックアップ方法と復元方法の詳細については、以下のサポート技術情報番号をクリックしてください。
322756 Windows でレジストリをバックアップおよび復元する方法


注: Microsoft Windows には複数のバージョンが存在するため、使用中のコンピューターによっては以下の手順が異なる場合があります。その場合は、製品のマニュアルを参照のうえ、手順を実行してください。

Windows インストーラーを再登録するには、次の手順を実行します。

: 次の手順を実行できない場合は、方法 3 に進みます。
  1. [スタート] ボタンをクリックし、[検索] をクリックします。(この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  2. [ファイルとフォルダーすべて] をクリックします。(この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  3. [ファイル名のすべてまたは一部] ボックスに「Msiexec.exe」と入力し、[検索] をクリックします。(この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  4. 検索が完了したら、Msiexec.exe ファイルの場所を書き留めておきます。ファイルの場所は次の例と同様です。
    C:\Windows\System32
    (この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  5. [ファイル] メニューで [閉じる] をクリックして [検索] ダイアログ ボックスを閉じます (この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  6. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします (この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  7. [名前] ボックスに「regedit」と入力し、[OK] をクリックします。(この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  8. 次のレジストリ キーに移動して、クリックします。
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer
    (この手順のスクリーン ショットを以下に記載)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  9. レジストリ エディター ウィンドウの右側のウィンドウで、[ImagePath] をダブルクリックします。(この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  10. 表示される [文字列の編集] ダイアログ ボックスで、[値のデータ] ボックスに、手順 4. で確認した Msiexec.exe ファイルのパスが正しく設定されていることを確認します。

    : 以下は正しいパスの例です。ドライブ は Windows がインストールされているドライブです。
    ドライブ:\Windows\System32\msiexec.exe /V


    [値のデータ] ボックスに正しいパスが入力されていない場合は、正しいパスに変更し、[OK] をクリックして、[文字列の編集] ダイアログ ボックスを閉じます。
    (この手順のスクリーン ショットを以下に示します)
    元に戻す画像を拡大する
    この手順のスクリーン ショット


  11. [ファイル] メニューの [終了] をクリックしてレジストリ エディターを終了します (この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  12. 次の手順を実行して、コンピューターをセーフ モードで起動し、Msiexec.exe ファイルを登録します。
    1. コンピューターをシャットダウンして再起動します。
    2. コンピューターの再起動中に、キーボードの F8 キーを押します。複数のオペレーティング システムを起動するように構成されているコンピューターでは、ブート メニューが表示されたときに F8 キーを押します。
    3. 方向キーを使用して [セーフ モード] を選択し、Enter キーを押します。
    4. ブート メニューが再度表示され、[セーフ モード] が青い文字で一番下の部分に表示される場合は、起動するオペレーティング システムを方向キーで選択し、Enter キーを押します。
    5. コンピューターにログオンします。
    6. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。[名前] ボックスに「msiexec /regserver」と入力し、[OK] をクリックします。
      (この手順のスクリーン ショットを以下に示します)
      元に戻す画像を拡大する
      この手順のスクリーン ショット


  13. コンピューターをシャットダウンし、通常の方法で再起動します。
これらの手順を実行しても依然として Microsoft Office を正常にインストールできず、「現象」に記載されているエラー メッセージが表示される場合は、方法 3 に進みます。

方法 3: サポート技術情報 319624 に記載されている方法を使用する

サポート技術情報の次の資料に記載されている方法を実行してみます。
319624 アプリケーションのインストール時にエラー メッセージ "Windows インストーラー サービスにアクセスできませんでした" が表示される

方法 4: Windows インストーラーを再インストールする

注: ここに記載されている手順は、Microsoft Windows 95、Microsoft Windows 98、Microsoft Windows Millennium Edition (Me)、および Microsoft Windows NT 4.0 に適用されます。Microsoft Windows 2000、Microsoft Windows XP、および Microsoft Windows Server 2003 の場合は、最新の Service Pack を再度適用するか、オペレーティング システムを修復してください。

Windows インストーラーを再インストールするには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします (この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  2. [名前] ボックスに「cmd」と入力し、[OK] をクリックします。(この手順のスクリーン ショットを以下に示します)

    元に戻す画像を拡大する
    この手順のスクリーン ショット


  3. コマンド プロンプトで、次のコマンドを入力します。各行の入力後、Enter キーを押します。
    cd %windir%\system32
    (この手順のスクリーン ショットを以下に示します)
    元に戻す画像を拡大する
    この手順のスクリーン ショット


    ren msi.dll msi.old
    (この手順のスクリーン ショットを以下に示します)
    元に戻す画像を拡大する
    この手順のスクリーン ショット


    ren msiexec.exe msiexec.old
    (この手順のスクリーン ショットを以下に示します)
    元に戻す画像を拡大する
    この手順のスクリーン ショット



    ren msihnd.dll msihnd.old
    (この手順のスクリーン ショットを以下に示します)
    元に戻す画像を拡大する
    この手順のスクリーン ショット



  4. コマンド プロンプトで「exit」と入力し、Enter キーを押します。
    (この手順のスクリーン ショットを以下に示します)
    元に戻す画像を拡大する
    この手順のスクリーン ショット


  5. コンピューターを再起動します。
  6. Windows インストーラー ファイルを最新版に更新します。この操作を行うには、次のいずれかのマイクロソフト Web サイトを参照し、Windows インストーラー 2.0 をダウンロードしてインストールします。

    注: Microsoft Windows XP には Windows インストーラー 2.0 が含まれています。Windows XP を使用している場合、この手順を実行する必要はありません。
  7. Windows インストーラーのインストール完了後、Microsoft Office をインストールする前に、通常どおりにコンピューターをシャットダウンして再起動します。

詳細

Windows をセーフ モードで再起動する方法の詳細については、以下のサポート技術情報番号をクリックしてください。
315222 Windows XP のセーフ モード ブート オプションの説明
281770 Windows 2000 でクリーンブート トラブルシューティングを実行する方法
273738 Windows Millennium Edition の起動時の問題をトラブルシュートする方法
180902 Windows 98 を搭載しているコンピューターをセーフ モードで起動する方法
Windows インストーラーの入手方法の詳細については、以下のサポート技術情報番号をクリックしてください。
292539 Windows インストーラー エンジンの入手方法

プロパティ

文書番号: 324516 - 最終更新日: 2014年1月31日 - リビジョン: 14.0
この資料は以下の製品について記述したものです。
  • Microsoft Office Professional 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Basic 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office XP Developer Edition
  • Microsoft Office XP Professional
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Standard
  • Microsoft Office 2000 Developer
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professional
  • Microsoft Office 2000 Small Business Edition
  • Microsoft Office 2000 Standard
キーワード:?
kbnomt kbgraphxlink kbscreenshot kbpubtypekc kbtshoot kberrmsg kbprb KB324516
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com