Help and Support
 

powered byLive Search

OFF2000: "Internal Error 2331" Error Message While Removing or Repairing Office

Article ID:324518
Last Review:February 1, 2007
Revision:1.2
This article was previously published under Q324518
On This Page

SYMPTOMS

If you try to remove or repair Office 2000, or an Office 2000 program, the process may stop responding after the Windows Installer service starts. You may then receive an error message similar to the following:
Internal Error 2331. The operation is invalid for this device.

Back to the top

CAUSE

This issue may occur if the Windows Installer files are outdated or corrupted.

Back to the top

RESOLUTION

To resolve this issue, rename the Windows Installer files, and then update Windows Installer. To do this, follow these steps.

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

Back to the top

Rename the Windows Installer Files

1.Click Start, point to Search, and then click For Files or Folders.
2.In the Search for files or folders named box, type msi.dll, and then click Search Now.
3.When the search process is complete, right-click Msi.dll, and then click Rename.
4.In the box that appears, type Msi.old, and then press ENTER.

Repeat this step for each file named Msi.dll.
5.Repeat steps 2 through 4 to rename the following files:
Msihnd.dll
Msiexec.exe

Back to the top

Install Windows Installer

1.Insert the Office CD into the CD-ROM drive or DVD-ROM drive. Hold down the SHIFT key to prevent the program from starting automatically.
2.Right-click Start, and then click Explore to start Windows Explorer.
3.Locate and then expand the drive that contains the Office CD.
4.If you have Microsoft Windows 98, Microsoft Windows 98 SE, or Microsoft Windows Millennium Edition (Me) installed on your computer, double-click Instmsi.exe.

If you have Microsoft Windows NT or Microsoft Windows 2000 installed on your computer, double-click the MSI folder, and then double-click Instmsiw.exe.

If you have Microsoft Windows XP installed on your computer, click Instmsiw.exe or Instmsi.exe.
5.Follow the on-screen instructions to complete the installation process.

Back to the top


APPLIES TO
Microsoft Office 2000 Developer Edition
Microsoft Office 2000 Premium Edition
Microsoft Office 2000 Professional Edition
Microsoft Office 2000 Small Business Edition
Microsoft Office 2000 Standard Edition

Back to the top

Keywords: 
kberrmsg kbprb KB324518

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.