Aparece el mensaje de error "El archivo MSIEXEC.EXE está vinculado a la exportación ausente MSI.DLL:222" al intentar instalar, actualizar o quitar un programa basado en Windows Installer

Seleccione idioma Seleccione idioma
Id. de artículo: 324638 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta instalar, actualizar o quitar algún programa basado en Windows Installer, es posible que reciba un mensaje de error similar al siguiente:
El archivo MSIEXEC.EXE está vinculado a un archivo MSI.DLL:222 de exportación que no existe.
Tras hacer clic en Aceptar, puede aparecer un mensaje de error similar al siguiente:
No se puede iniciar C:\Windows\System\MSIEXEC.EXE. Uno de los dispositivos vinculados al sistema no funciona.

Causa

Este comportamiento se produce si hay falta de coincidencia entre los archivos de Windows Installer debido a un intento de actualización de Windows Installer.

Solución

IMPORTANTE
Antes de seguir los pasos descritos más adelante en esta sección para resolver el problema, reinicie el equipo e intente instalar, actualizar o quitar de nuevo el programa de Office. Si Windows Installer ha recibido recientemente archivos actualizados, éstos se copian a una ubicación temporal y no se copian a la carpeta apropiada hasta que se reinicie el equipo.

Para resolver este problema, siga los pasos de este procedimiento que consta de cuatro partes en el orden en que aparecen.

Parte 1: descargar la actualización de Windows Installer

  1. Visite el siguiente sitio Web de Microsoft, según el sistema operativo:
  2. Haga clic en el vínculo Descargar ahora y, a continuación, haga clic en Guardar.
  3. Guarde el archivo en el escritorio.

Parte 2: cambiar el nombre de los archivos de Windows Installer

Windows 95 y Windows 98

  1. Haga clic en Inicio y, a continuación, haga clic en Apagar.
  2. Haga clic en Reiniciar en modo MS-DOS y, después, haga clic en Aceptar.
  3. En el símbolo del sistema, escriba lo siguiente y presione ENTRAR al final de cada una de ellas:
    cd system
    ren msi.dll msi.old
    ren msihnd.dll msihnd.old
    ren msiexec.exe msiexec.old
    exit
    Se reiniciará Windows.

Windows NT 4.0

  1. Haga clic en Inicio y, a continuación, haga clic en Ejecutar.
  2. En el cuadro Abrir, escriba command y haga clic en Aceptar.
  3. En el símbolo del sistema, escriba lo siguiente y presione ENTRAR al final de cada una de ellas:
    cd \winnt\system32
    ren msi.dll msi.old
    ren msihnd.dll msihnd.old
    ren msiexec.exe msiexec.old
    exit
  4. Reinicie el equipo.

Windows Millennium Edition

  1. Si tiene un disco de inicio de Windows Millennium Edition, vaya al paso 7.
  2. Haga clic en Inicio, seleccione Configuración y haga clic en Panel de control.
  3. Haga doble clic en Agregar o quitar programas.
  4. Haga clic en la ficha Disco de inicio.
  5. Haga clic en Crear disco para crear el disco de inicio.

    NOTA
    En algunas circunstancias, puede que el sistema le pida que inserte el CD de Windows Millennium Edition cuando haga clic en Crear disco. Esto ocurre si los archivos de instalación necesarios para crear el disco de inicio no están en el disco duro.
  6. Cuando se le pida, inserte un disco formateado en la unidad de disco y haga clic en Aceptar para confirmar que se puede sobrescribir el contenido del disco.
  7. Inserte el disco de inicio (o déjelo) en la unidad de disco.
  8. Reinicie el equipo. Cuando se le pida que seleccione cómo desea iniciar, haga clic en Inicio mínimo.
  9. En el símbolo del sistema, escriba lo siguiente y presione ENTRAR al final de cada una de ellas:
    c:
    cd \windows\system
    ren msi.dll msi.old
    ren msihnd.dll msihnd.old
    ren msiexec.exe msiexec.old
  10. Quite el disco de inicio y reinicie el equipo.

Parte 3: iniciar el equipo en Modo a prueba de errores

Windows 95 y Windows 98

  1. Haga clic en Inicio y, a continuación, haga clic en Apagar.
  2. Haga clic en Reiniciar y, después, haga clic en Aceptar.
  3. En un equipo basado en Windows 95, presione F5 en cuanto vea el mensaje "Iniciando Windows 95".

    O bien

    En un equipo basado en Windows 98, mantenga presionada la tecla MAYÚS al terminar las comprobaciones automáticas durante el encendido (POST).
  4. Cuando Windows finalice la carga, haga clic en Aceptar para cerrar el mensaje sobre el modo a prueba de errores.

Windows NT 4.0

NOTA
La condición más cercana al modo a prueba de errores en Windows NT 4.0 se presenta si se sale de todos los programas o tareas innecesarios.

Siga estos pasos para salir de todos los programas innecesarios que se ejecutan en segundo plano:
  1. Presione CTRL+ALT+SUPR.
  2. Haga clic en un programa cuya ejecución sea innecesaria.
  3. Haga clic en Finalizar tarea.
  4. Repita los pasos 2 y 3 hasta que se hayan cerrado todos los programas innecesarios.

Windows Millennium Edition

  1. Haga clic en Inicio y en Ejecutar, escriba msconfig en el cuadro Abrir y haga clic en Aceptar.
  2. En la ficha General, haga clic en Inicio selectivo.
  3. Desactive todas las casillas de verificación situadas bajo Inicio selectivo.
  4. En la ficha Inicio, active la casilla de verificación *StateMgr.
  5. Haga clic en Aceptar. Cuando se le pregunte si desea reiniciar el equipo, haga clic en .

Parte 4: instalar la actualización de Windows Installer

  1. En el escritorio, haga doble clic en Instmsiw.exe o en Instmsia.exe.
  2. Siga las instrucciones de la pantalla para finalizar la instalación.
  3. En Windows Millennium Edition, emplee la utilidad MSCONFIG para seleccionar un inicio normal.
  4. Reinicie el equipo.

Propiedades

Id. de artículo: 324638 - Última revisión: martes, 04 de diciembre de 2007 - Versión: 7.2
La información de este artículo se refiere a:
  • Microsoft Office 2000 Standard Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Outlook 2002 Standard
  • Microsoft Outlook 2000 Standard
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Publisher 2002 Standard
  • Microsoft Publisher 2000 Standard
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Office XP Professional Edition
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office XP Standard Edition for Students and Teachers
  • Microsoft Office XP Developer Edition
Palabras clave: 
kberrmsg kbtshoot kbprb KB324638

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com